Votre question

problème avec les $_session() [php]

Tags :
  • web
  • Programmation
Dernière réponse : dans Programmation
20 Février 2008 16:42:38

salut

je voudrais mettre des séssion sur mon site, donc dans mon index.php à la premiere ligne je fait
  1. <?php
  2. session_start();
  3. ?>


mais ca me met :

Citation :
Warning: session_start(): Cannot send session cookie - headers already sent by (output started at c:\program files\easyphp1-8\www\web\index.php:1) in c:\program files\easyphp1-8\www\web\index.php on line 2

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at c:\program files\easyphp1-8\www\web\index.php:1) in c:\program files\easyphp1-8\www\web\index.php on line 2


je ne vois vraiment pas d'ou ca viens puisque les erreurs me disent que j'ai déja déja initialisé les header alors que le session_start se trouve à la 2eme de la page ^^ avans mem tout le code php/html

Merci

Autres pages sur : probleme session php

Anonyme
20 Février 2008 19:16:25

Salut
tu as bien crée un repertoire sessions à la racine de ton site ?
20 Février 2008 19:17:59

j'utilise wamp donc il n'y a pas besoin puisque son php.ini utilise wamps/tmp/
Contenus similaires
Pas de réponse à votre question ? Demandez !
Anonyme
20 Février 2008 20:05:53

Il ne faut aucun espace ou ligne avant le <?php
est ce que cette page est inclue dans une autre ?
20 Février 2008 20:37:20

Je me sert de cette page pour inclure les autres, mais le code d'inclusion viens en fin de cette page.
20 Février 2008 21:33:32

l'erreur pointe la ligne 2 pour session_start
et la ligne 1 pour le premier affichage, tu dois avoir un espace en trop
20 Février 2008 23:07:04

J'ai essayé de réécrire ces 3 lignes mais il y a toujours le même problème.

edit:

je viens de faire une découverte, quand j'enregistre mes pages en codage AINSI le session_start(); fonctionne mais AINSI ne prend pas en charge les accents et charactere spécial, quand je met mon codage en UTF-8 mon session_start(); ne fonctionne plus mais mes accents reviennent :) 

re edit:

j'ai un gros problème dans mes encodage de fichier, en cherchant un peu j'ai vu que utf8 rajoutait un petit bout de code au début du fichier d'ou mes problèmes avec session_start, je viens de passer toute mes pages en utf-8 sans bom mais alors la c'est la cata ^^ je n'ai plus aucun accent :pfff: 
21 Février 2008 11:18:08

je vais tester cette apres midi, au niveau du codage il faut mieux que je sois en utf8 ou en ainsi ?
21 Février 2008 12:15:16

j'ai encore un problème avec mes session :D  :

Citation :

Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0
21 Février 2008 17:22:15

Tout fonctionne, merci de votre aide. Il me reste un problème à régler mais je vais ouvrir un autre post :) 
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS