Votre question

Problème Firefox: affichage de background! [resolu]

Tags :
  • table
  • Programmation
Dernière réponse : dans Programmation
30 Décembre 2006 00:49:10

Bonjour à tous,

J'ai un petit problème avec un site web!
Sous Internet Explorer, je n'ai aucun problème d'affichage, alors qu'avec Firefox, oui!!
En effet, l'image de fond d'une table refuse de s'afficher, on a donc l'impression que le contenu est dans "le vide"!

Voici donc le code de mon fichier header.php; ce que j'ai surligné en gras est le "background" qui refuse de s'afficher!!

<html>
<head>
<title>Mon site</title>
<link href="style.css" type="text/css" rel="stylesheet">
</head>
<body>

<center>
<table style="background-image: url(images/bg_table.png);" border="0" cellpadding="0" cellspacing="0" width="670">
<tbody>
<tr>
<td valign="top">
<img src="images/header.png">

<div style="height: 5px; width: 670px; z-index: 2; left: 10px; top: -49px; position: relative;" id="Layer2">
<table style="text-align: left; width: 650px;" border="0" cellpadding="0" cellspacing="0">
<tbody>
<tr>
<td style="width: 149px; vertical-align: top;">
<table align="center" cellpadding="2" cellspacing="0" width="100%">
<tbody><tr>
<td class="title">Navigation</td>
</tr>
<tr>
<td class="content">
<img style="width: 11px; height: 9px;" src="images/fleche.gif"> <a href="index.php">Mises à jour...</a><br>
- Toutes les nouveautés...</td></tr>
<tr>
<td class="content">
<img style="width: 11px; height: 9px;" src="images/fleche.gif"> <a href="avatarzone.php">Icons...</a><br>
- Vos avatars affichés ici...</td></tr>
</tbody>
</table>

</td>
<td style="width: 1px;"></td>
<td style="width: 500px; vertical-align: top;">[/cpp]

Merci d'avance de votre aide!! :) 

Autres pages sur : probleme firefox affichage background resolu

30 Décembre 2006 00:59:50

pourquoi mets tu des feuilles de styles internes ET externes !?
30 Décembre 2006 01:21:10

Est-ce la cause de ce problème?
Il ne me semble pas car il n'y a pas de doublons!

Mais pour repondre à ta question, on m'a appris comme ça et vu que je n'ai jamais eu de souci, je continue.... mais peut-être qu'un de ces jours, je n'utiliserai que des feuilles de style ernes, même si je ne suis pas une fan des css trop longs!


EDIT: J'édite ce post car j'ai trouvé la solution moi-même.
En fait, Firefox ne semble deployer le background que sur l'hauteur de la div contrairement à IE qui ne se soucie pas de ça!
J'ai donc supprimé le "height" de la div et cela marche dans les deux navigateurs.

Merci!!!!
16 Janvier 2008 18:36:53

Bonjour,

j'ai un problème similaire, la disposition de ma page s'affiche correctement sous IE et pas sous Firefox:

J'ai créé une feuille de style CSS externe où j'ai mis entre autre ce code:

body { margin-right: auto;
margin-left: auto;
position: relative;
width: 800px;
height: 100% ;
display: block;
background-color: #000000; }

body,td,th {font-family: Courier New, Courier, monospace;font-size: small;color: #FFFFFF;}


et les autres fonctions de ma feuille externe CSS fonctionnent parfaitement, notamment polices...

Autre chose bizarre, ça marche en local mais pas online !!! :cry: 

J'ajoute aussi le code dans l'html qui appelle le CSS:

<link rel='stylesheet' type='text/css' href='../stylecss.css' />
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS