Votre question

Probleme connexion base de donnée

Tags :
  • Copier coller
  • Programmation
Dernière réponse : dans Programmation
18 Décembre 2007 05:13:10

Bonjour,

Donc voila mon problème,

Lorsque je me connecte sur ma base de donnée de mon hébergeurs tout fonctionne, mais quand je passe en local sous WAMP SERVER 2, il me dit que le chemin vers le fichier qui ouvre la base de donnée n'est pas correcte alors que j'ai Copier Coller le chemin d'accès de la barre d'adresse de XP ! Est ce un problème du php.ini ou autres chose ? Tout en sachant que je n'ai rien touché au php.ini d'origine !

Cordialement bebar_974

PS : Je m'excuse sincèrement si ce n'est pas le bon forum !

Autres pages sur : probleme connexion base donnee

18 Décembre 2007 07:52:17

bebar_974 a dit :
il me dit que le chemin vers le fichier qui ouvre la base de donnée n'est pas correcte alors que j'ai Copier Coller le chemin d'accès de la barre d'adresse de XP !


De quel chemin et de quel fichier parles tu.

Essayes tu d'ouvrir phpmyadmin dans ton navigateur ?
18 Décembre 2007 12:55:07

require './script/php/open.php';

Voila le chemin qui ne marche pas ! pourtant j'ai bien mis open.php dans ce fichier, et même en le mettant dans le même dossier j'ai la meme erreur
Contenus similaires
18 Décembre 2007 22:44:22

tu lui indiques un chemin relatif, donc sans rapport avec celui que t'affiches l'explorateur windows.

le fait de commencer ton chemin par ./ indique que tu pars de la position de ton fichier courant.
18 Décembre 2007 23:43:00

Oui mais même si je mets 'script/php/open.php' j'ai le même résultat ! Je comprend pas pourquoi ça ne marche pas avec WAMP alors que sous EasyPHP elle passait bien !

Edit : Peut être que ce sera plus claire ^^, voici l'erreur :

Warning: mysql_query() [function.mysql-query]: Access denied for user 'ODBC'@'localhost' (using password: NO) in
19 Décembre 2007 00:03:27

ou est ce que tu vois un message sur le chemin du fichier n'est pas correct ??

il t'indique juste que l'acces a été refusé pour l'utilisateur 'ODBC'@'localhost'.
vérifie que c'est le bon utilisateur et regarde s'il n'y a pas de mot de passe.
19 Décembre 2007 00:11:11

Hum bon en fait je pensée que ça venez du fait qu'il trouvé pas le fichier ... Ouep je me suis pas penché sur le bon problème mais bon j'ai pourtant mis :

  1. require('script/php/open.php');
  2. //require './script/php/open.php';
  3. //Mise en forme des variables
  4. $pseudo = strip_tags(substr($_POST['pseudo'],0,32));
  5. $password = strip_tags(substr($_POST['password'],0,32));
  6. $cleanpw = md5($password);
  7. $erreur='Aucune';
  8. //Creation du compte, base, donnee et detection des erreurs
  9. $INScompte = "INSERT INTO compte(idcompte, grade_idgrade, statut_idstatut, experience, argent, pseudo) VALUES ('','1','1','50','100000','".mysql_real_escape_string($pseudo)."')";
  10. mysql_query($INScompte);
  11. if(mysql_error()){
  12. $erreur="Erreur interne (CPT01) changer de pseudo. Si le problème persiste contacter : XXX@XXX.XXX ! merci !";
  13. }



Ou alors l'erreur vient de là !
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS