Votre question

Pb_affichage-background

Tags :
  • Template
  • Programmation
Dernière réponse : dans Programmation
17 Août 2007 14:33:46

Bonjour a tous, je suis entrin de creer mon template de mes propres mains et j'ai un petit problem avec mon template ...
mon background ne s'affiche pasdu tout...
Bon j'ai tout essayer pouriez vous m'aider svp
http://csource.free.fr/coldfusion.zip
Merci a tous

Autres pages sur : affichage background

a c 232 L Programmation
17 Août 2007 15:31:59

Vu qu'il faut avoir Joomla pour faire tourner ton template, ça serait pas possible de le voir en action plutôt ?
17 Août 2007 15:36:52

Desolé je n'avais pas penser Autant pour moi :) 
Oui bien sur tu peut aller voir sur cette adress http://csource.free.fr
Tu verra une page blanche avec le footer qui s'affiche y a que ca qui s'affiche :D 
Contenus similaires
Pas de réponse à votre question ? Demandez !
a c 232 L Programmation
17 Août 2007 15:45:04

La page blanche s'explique car tu as mis dans body : color:#FFFFFF; ce qui fait que le texte est écrit en blanc, sur du blanc...

Ensuite, tu as créé un div background auquel tu as appliqué le background, mais vu que le div fait 0 px, tu ne pourras pas voir le background !
17 Août 2007 15:48:38

Mercie mille fois pour ton aide.... c'est gentil de ta part d'aider la communauté en difficulté, en plus service rapide, on peut pas rever mieux .... :)  Je vais voir ce que ca donne chez moi!
17 Août 2007 15:58:43

Pour la div comment j'intervient?
Sur la feuille de style ou sur mon index?
vue que le div que j'ai mis est dur l'index ca doit etre sur l'index?
Pourtant pour mon footer j'avais pas besoin de modifier la div bizare
a c 232 L Programmation
17 Août 2007 16:07:42

Et je sais pas si c'est un bug de Fx ou pas, mais quand j'ouvre la source de ta page, la balise <html> n'est pas fermée, j'ai ça :
Citation :
<html xmlns="http://www.w3.org/1999/xhtml" lang="fr" xml:lang="fr"


Edit : Et le background, je l'ajouterai directement dans le CSS du body {} et pas dans un nouveau div.
17 Août 2007 16:17:46

Att je te montre mon index.php


<?php defined( '_VALID_MOS' ) or die( 'Acces direct non autorise.' ); ?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="<?php echo _LANGUAGE; ?>" xml:lang="<?php echo _LANGUAGE; ?>"
<head>
<meta http-equiv="Content-Type" content="text/html; <?php echo _ISO; ?>" />
<?php
if ($my->id) { initEditor(); } ?>
<?php mosShowHead(); ?>
<link href="<?php echo $mosConfig_live_site;?>/templates/coldfusion/css/template_css.css" rel="stylesheet" type="text/css"/>
</head>
<body>
<div id="background"></div>
ma première page n est plus toute vide !!
<br/>
<h1>nom du site :</h1> <?php echo $mosConfig_sitename;?><br/>
<h1>repèrage dans le site :</h1> <?php mospathway()?>
<!-- vous définirai le contenu des modules dans la console d administration de joomla -->
<h1>module(s) top :</h1> <?php mosLoadModules('top');?>
<h1>module(s) left :</h1> <?php mosLoadModules('left');?>
<h1>contenu de votre site :</h1> <?php mosMainBody();?>
<h1>module(s) right :</h1> <?php mosLoadModules('right');?>
<div id="footer">
<?php include_once($mosConfig_absolute_path."/templates/".$mainframe->getTemplate()."/footer.php");?>
</div>
</body>
</html>

Je vient totu juste d'enlever la div background et j'ai egalement modifier le css.
Mnt mon fond est dans le body mais il s'affiche tjs pas! :pfff: 

http://csource.free.fr
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS