Se connecter / S'enregistrer
Votre question

Problèmes d'accents

Tags :
  • Serveur
  • Programmation
Dernière réponse : dans Programmation
5 Juillet 2007 21:58:37

Bonjour à tous, j'ai un soucis lors de l'envoi de mes pages persos, toutes les lettes ayant un accent (é,è,ù, etc...) se transforme en ceci : �

Que dois-je faire pour pouvoir utiliser les lettres a accents normalement ?

Merci d'avance

Autres pages sur : problemes accents

5 Juillet 2007 22:16:48

LOL

C'est sympa les sites comme sha X)
5 Juillet 2007 23:50:12

c'est un problème d'encodage de caractères (utf8, iso8859-1, etc...).

il faut un peu plus de renseignements!
Contenus similaires
6 Juillet 2007 00:01:30

C'est au niveau du serveur apache (ou autre) qui heberge t'es page perso.

Essai peu etre d'utiliser un encodage plus courant, il me semble que le utf8 est plutot bien compatible avec la majorité des serveur (je me trompe peu etre !)
6 Juillet 2007 00:04:35

tu veux dire quoi par l'envoi de tes pages persos ?
6 Juillet 2007 13:55:55

Je suis pas un pro de la programmation Html/Php mais j'essaie de m'en sortir, mais c'est la premiere fois que je rencontre ce probème, quand je lis mes pages avec Easy Php, tout est parfait mais lorsque je l'ai envoi et que je visualise mes pages sur le net, ces signes remplace les lettes aec accents =s

Edit:J'ai envoyer mon site sur le validateur XHTML et j'ai recu ce ci:


Byte-Order Mark found in UTF-8 File.

The Unicode Byte-Order Mark (BOM) in UTF-8 encoded files is known to cause problems for some text editors and older browsers. You may want to consider avoiding its use until it is better supported.
6 Juillet 2007 14:31:12

essaye d'ajouter cette ligne dans le <head></head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
Il dira au navigateur de passer en utf-8.
Sinon tu peux également écrire les accents en html :
é => é
è => è
à => à
....
tu peux les trouver sur le net facilement.
6 Juillet 2007 15:15:17

Même en plaçant ce code ca ne marche toujours pas

<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />

mais j'utiliserais

é => é
è => è
à => à
etc...

en attendant de trouver une solution, Merci!

6 Juillet 2007 15:36:42

Essaye ça

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
6 Juillet 2007 15:55:11

on peu avoir ladresse de la page pour faire des essais ?
6 Juillet 2007 17:16:45

Ce code a réparer ce petit problème:

<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />

Merci à tous de votre aide!!! =D
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS