Se connecter / S'enregistrer
Votre question

Encore un sujet formulaire Frontpage ???

Tags :
  • Logiciels
  • Programmation
Dernière réponse : dans Programmation
5 Juillet 2007 17:21:23

Bonjour à tous,

Après de longues heures passées devant mon PC à me taper tous les forums prog et le site du zéro je décide d'invoquer "infos du net"...

Ce sujet a déjà été abordé, je le sais, mais il ne m'a pas aidé à trouver la réponse à mon problème...

Je dois donc réaliser un formulaire de questions pour un certain nombre de personne. Avec espoir et naïveté (d’après ce que j’ai pu voir sur les forums…) j’ai décidé de prendre le logiciel de ma boite : Front page
=> ** frissons dans le dos **

Je suis maintenant confronté au problème suivant :

J’ai mis en ligne ma page sur lycos/multimania (qui est apparemment censé gérer les add-on FP) mais lorsque j’appuie sur « envoyer » vous vous en doutez, le néant. Pas de message d’erreur mis appart celui de lycos qui m’envoie plus de pub que d’infos…

Voici mon site :

http://membres.lycos.fr/stagiairephox/

Et la source sans la pub lycos : (il est gentil hein ?)

http://membres.lycos.fr/stagiairephox/source.txt

Ma prog est loin d’être parfaite je le sais, j’aspire à l’améliorer mais ça n’est pas ma priorité d’aujourd’hui (bien qu’elle m’aurait peut-être évité d’en être là aujourd’hui)
En tout cas, sachez que les lignes je les ai lu et relu et que je ne vous demande pas de le faire par flemme. Par ailleurs, je vous prierai d’éviter les commentaires du style « change de logiciel » ou recommence tout depuis le début.

Ce n’est pas ce genre d’infos que je suis venu chercher ;) 

Merci à tous.

Autres pages sur : sujet formulaire frontpage

5 Juillet 2007 17:38:10

Je doute qu'en parcourant des forums tu n'ai jamais trouvé la réponse à ta question...

  1. <FORM METHOD="POST" ACTION="--WEBBOT-SELF--" name="Enquête">


Il y a un mot clé "Action" c'est ce qui est exécuté lorsque tu appuies sur le bouton, il faut donc coder les actions qui seront réalisées du genre envoi d'un mail ou écriture dans une base de données...
5 Juillet 2007 17:43:53

Huhuuu bon déjà tu as pu me montrer la ligne erreur et je t'en remercie.

Pour ce qui est des forums je te l'assure je m'en suis fais un paquet, mais tous te les énumérer n'avancerai à rien et je n'ai sûrement pas été assez attentif comme tu l'as souligné…

Je comprends par contre assez mal ce que tu me conseilles. Il faut que je remplace webbot-self par une action d’envoi de mail ?
Une dernière aide de ta part serait plus que bien venue… :) 
Contenus similaires
5 Juillet 2007 18:00:37

Bon, ta page est en html, c'est un langage dit 'statique' et assez basique, il ne permet donc pas d'effectuer des actions complexes comme l'enregistrement dans une base de données où autre.
Si tu fais ce site pour tes loisirs alors l'envoi des résultats par mail devrait être suffisant, bien que pas super pratique.

Pour ça, visiblement, il faut remplacer --WEBBOT-SELF-- par /cgi-bin/mailer

  1. <FORM method=GET action="/cgi-bin/mailer">


http://webmaster.lycos.fr/topics/technic/html/html-work...

C'est sans garantie, puisque je n'ai pas moyen de tester, n'ayant pas de compte lycos.

Si tu veux un truc un peu plus pro et pratique, il faut utiliser un langage plus évolué, comme le PHP.
6 Juillet 2007 08:55:43

Et est il possible d'utiliser du php sans changer la totalité de ma prog ?

J'ai vu une technique sur le site du zéro qui consiste à déterminer une variable pour chaque question/réponse de la page...

Mais c'est super long...

Tu aurais un autre moyen?

=> Pour l'envoie mail php

http://www.siteduzero.com/tuto-3-1872-1-fonction-mail--...

ps : j’ai aussi free comme hébergeur, donc l’hébergement ne sera pas un problème…

Si c’est long et que tu as la flemme de me faire le code php, essaye de me donner un lien qui pourrait m’être utile ce serait gentil…

ps : lorsque je fais ce que tu m'as dis et ce qui est dit sur ton lien voici ce qui est affiché :

"Champ From invalide : "
6 Juillet 2007 09:24:07

Voici le mode d'emploi complet de la fonction mail de lycos, et effectivement, il faut un champ texte nommé "from" dans ton formulaire afin que ça fonctionne :
http://webmaster.lycos.fr/topics/technic/admin/admin-wo...

Pour la prog, je ne pense pas qu'il faille refaire beaucoup de choses, je regarde et je vois ce que je peux faire.
6 Juillet 2007 09:36:12

Merci beaucoup, jvais lire ce que tu m'as donné et jme refais encore le site du zéro là... ^^
6 Juillet 2007 14:19:58

Mwarf, j'avoue que j'y parviens toujours pas...

Donc si quelqu'un se sent capable de m'aider... Rodyrod en a déja fait pas mal, il va pas non plus passer tout son temps sur mon problème... ^^
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS