Votre question

formule de calcule sous exel

Tags :
  • Microsoft Excel
  • Programmation
Dernière réponse : dans Programmation
14 Novembre 2006 21:24:45

boujour a vous tous
je recherche la formule pour faire apparaitre sur une facture exp le chifre 2, mais elle cache une tva de 5.5 et ci je tape le chifre 1 elle cache une tva de 19.6.
ou maime faire une association entre c'est deux chivre de valeur.puis dans mes totaux quel face la difference entre s'est deux tva
cordialement lafouine44

Autres pages sur : formule calcule exel

a c 145 L Programmation
14 Novembre 2006 21:35:46

heu, en gros tu veux que la cellule C1 (on va l'appeler) comme ça soit égale à A1*1.196 si B1=1 et A1*1.055 si B1=2

donc, ça donne quelque chose comme (de tête parce que j'ai pas excel sous la main):
=SI(B1>0;(SI(B1<2);1.055*A1;1.196*A1);A1)
14 Novembre 2006 21:51:59

oui s'est bien cela mais elle ne convient pas sous exel trop long
Contenus similaires
14 Novembre 2006 21:56:04

trop long ?
on n'est pas limité a 255 caracteres par formule ?
a c 145 L Programmation
14 Novembre 2006 21:57:47

on est limité pour la taille des formules sous excel?
14 Novembre 2006 21:58:51

il me semble oui, en tout cas dans les anciennes versions mais comme je ne l'utilise plus...
14 Novembre 2006 21:59:57

oui c'est exacte il ne veux pas l'identifier
14 Novembre 2006 22:10:18

alors comment je peux faire pour qu'il puise identefier ou faire le raprochement entre s'est deux racourcie ou tva
14 Novembre 2006 22:45:22

ok merci a vous tous je vais y reflechir cette nuit bonne nuit a vous
19 Novembre 2006 22:58:04

MERCI D'ABROFONDIRE LE SUJET SI VOUS POUVER S4EST URGENT

CORDIALEMENT
19 Novembre 2006 23:01:43

explique un peu mieux ton souci stp
20 Novembre 2006 01:59:45

je doit associer le chifre 1 pour une tva a 5.5 et le chifre 2 pout la tva a 19.6 soit quand je marque le chifre 1 sur une colonne mon total tva de 5.5 doit etre idendifier ou tva 19.6 pour le chifre 2
ce qui fait que dans mes totaux d'une case il peux faire la difference
cordialement a vous
20 Novembre 2006 08:17:19

on considere:
colonne A: les prix HT
colonne B: le chiffre 1 ou 2
colonne C: le prix TTC
donc contenu de C1 par ex: =SI(B1=1;A1*1,196;SI(B1=2;A1*1,055;"Erreur TVA"))
20 Novembre 2006 20:47:35

oui tres bien cette formule est tres bien merci il me reste plus qu'a l'adabter sur plusieur colone pour differencier ma liste de produit

cordialement et merci
a c 145 L Programmation
20 Novembre 2006 21:00:53

crazycat@idn a dit :
=SI(B1>0;(SI(B1<2);1.055*A1;1.196*A1);A1)

BaCcHuSs@IDN a dit :
=SI(B1=1;A1*1,196;SI(B1=2;A1*1,055;"Erreur TVA"))

c'est clair que les différences sont énormes, mis à part le fait que j'utilise des . et non des , en séparateurs décimaux :) 

20 Novembre 2006 21:03:43

c'est bien pour ca que je l'ai réécrit vu qu'apparemment notre ami ne l'avait pas fait de lui même ;) ;)
mais ta réponse me sufffisait :) 
a c 145 L Programmation
21 Novembre 2006 09:25:23

:) 
D'ailleurs, sans vouloir comparer nos formules quasimment identiques, j'ai une préférence pour la mienne qui permet d'avoir le même type de variables dans la colonne C quel que soit la valeur dans B*, ce qui peut être utile dans le cadre de tableaux comptables avec une SUM() en fin de colonne :) 
21 Novembre 2006 11:23:14

certes mais je n'ai fait que répondre aux spécs ;) 
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS