Votre question

Probleme de script : page blanche

Tags :
  • MySQL
  • Programmation
Dernière réponse : dans Programmation
30 Octobre 2006 20:01:22

Ce script de news ne m'affiche rien qu'une page blanche... :
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
<head>
<title>mon site !</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</head>
<body>

<?php

mysql_connect("sql.free.fr", "****", "****");
mysql_select_db("****");

$_GET['id'] = $id;

$requete = mysql_query('SELECT * FROM essai WHERE id="'. $id .'"');
$donnees = mysql_fetch_array($requete);

echo ''.$donnees['contenu_news'].'';

?>
</html>

Merci

Autres pages sur : probleme script page blanche

30 Octobre 2006 20:13:22

Ben ça peut être pour plein de raisons...
Est ce que ta base est remplie? Est ce que tu utilises la méthode GET avec la variable id, en passant depuis une autre page? Est ce que il n'y a pas une vielle erreur dans ton script?
30 Octobre 2006 20:15:21

tu le sort d'ou ce code?? tu le teste en local ou sur un ftp ( surement free )?
Il faudrait peut être mettre un user et un pswd et aussi un nom de db !!
Contenus similaires
30 Octobre 2006 20:18:38

pour le nom et le mot de passe ils sont volontairement cachés.

voici le code de la page d'avant :


<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
<head>
<title>mon site !</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</head>
<body>

<?php

mysql_connect("sql.free.fr", "****", "****");
mysql_select_db("****");

$requete = mysql_query('SELECT * FROM essai');
while ($donnees = mysql_fetch_array($requete)) // ligne 15
{
echo '<a href="news.php?id_news='.$donnees['id'].'">'.$donnees['titre_news'].'</a>';?><br><?
}
?>



</body>
</html>
30 Octobre 2006 20:32:04

scaryman0 a dit :
Ce script de news ne m'affiche rien qu'une page blanche... :
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="fr" >
<head>
<title>mon site !</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
</head>
<body>

<?php

mysql_connect("sql.free.fr", "****", "****");
mysql_select_db("****");

$_GET['id'] = $id;

$requete = mysql_query('SELECT * FROM essai WHERE id="'. $id .'"');
$donnees = mysql_fetch_array($requete);

echo ''.$donnees['contenu_news'].'';

?>
</html>

Merci


peut-être parceque il n'y a rien dans ton champ "contenu_news" ;) 
30 Octobre 2006 20:47:37

si il ya des choses
30 Octobre 2006 21:57:32

si tu remplacais id_news par id tout court ou alors le contraire dans l'autre page.
ensuite les affectation se font dans l'autre sens
$id = $_GET['id']; et non le contraire (ds tous les langages je crois)
30 Octobre 2006 22:53:03

non ca ne fait rien la page s'affiche correctement mais blanche sans rien
31 Octobre 2006 00:18:32

est ce que la premiere page s'affiche bien
apres dans la deuxieme t'as pas mis de balise </body>
apres essaye un simple code qui t'affiche la table sans condition.
et enfin mets des if avec des affichage de mysql_error
sinon apres on peut pas deviner a la place de ton serveur ce qui se passe
c'est avec les messages d'erreur qu'on debogue un programme
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS