Se connecter / S'enregistrer
Votre question

Algorithme sur le tri, recherche.dans un tableau..pour une ame généreuse

Tags :
  • Ame
  • Programmation
Dernière réponse : dans Programmation
12 Décembre 2005 01:00:52

Bonjour amis du site, j'ai un niveau tres faible en algo c'est pour cela que je vous demande de l'aide sur ces 2 enoncés:( declaration de variable et algo)

1) J'ai stocké mes dépenses journalières pendant 1 ans, soit 365 jours. Ecrire l'algorithme qui remplit ce tableau de valeurs aléatoire( 0 a 500), puis trie ces valeurs par ordre décroissant, puis recherche -l'existence d'une valeur saisie, et enfin compte le nombre de montants entre 300 et 400 euros.


2)jeu du pendu

-Tableau de 20 cases qui stocke les mots: Tabmots
-choisir un mot tirage aleatoire d'un nombre entre 0 et 20
-indiquer a l'utilisateur le nombre de lettres composant le mot correspondant a ce nombre et stocker lettre par lettre le mot dans un tableau: Tmot
-demander une lettre a l'utilisateur
-placer cette lettre dans le tableau Tsolution si elle existe dans le mot a trouver ou affiche un message d'erreur si elle n'y est pas
-recommencer la saisie d' une lettre
fin du jeu :
-par pendaison au bout de 10 erreurs
en gagnant quand nombre de lettre trouvées = nombre de lettre de depart.

merci d'avance.
Edden


Autres pages sur : algorithme tri recherche tableau ame genereuse

12 Décembre 2005 08:42:13

Comment veux tu t'améliorer si tu ne les fait pas toi même...
16 Décembre 2005 15:25:01

Salut jsuis pas expert en algo mais p-e ksa pourra t'aider, c'est 3 algo 1er qui rempli un tablo de 365 entier et le 2eme recherche une valeur saisie 3eme trouve le nb de valeur entre 3 et 400 (pour ton exercice 1)
ensuite faut rassemble les 3 + celui kj'ai pas fais pour faire ton exo entier

algo remplisage de tableau

variable Tab[1..365] :entier;
i :entier;

Debut
pour i variant de 1 a 365 alors
Tab <- Random(0,500)
Fin Pour;
Fin Debut;


Algo Recherche Ocurrence

Variable Tab[1..365] :entier;
i,occurence :entier;

Debut
Saisir(occurence);
pour i variant de 1 a 365 alors
if (Tab = occurence) alors
afficher(occurence,tab); //tab = position dans Tab
sinon
Fin Si;
Fin Pour;
Fin Debut;

Debut
nombre<-0
pour i variant de 1 a 365 alors
if (Tab > 300) && (Tab < 400) alors
nombre<-nombre+1; //ou inc(nombre);
sinon
FinSi;
Fin Pour;
Afficher('nombre de valeur entre 3et 400',nombre);
Fin Début;
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS