Se connecter / S'enregistrer
Votre question

petit soussi avec fopen()

Tags :
  • Programmation
Dernière réponse : dans Programmation
2 Mars 2005 23:09:02

bonjour
j'ai un petit probleme avec fopen kan je linsair dans mon scrpite il me marke se message d'erreur "fopen(livre-d'or.txt): failed to open stream: Permission denied in" si kelkin aurai la solution cela m'arangerai beaucoup
merci d'avance

Autres pages sur : petit soussi fopen

2 Mars 2005 23:37:37

si vous voulez le scripte complet demander je vous le passe
3 Mars 2005 02:04:14

en gros, il trouve bien le fichier, mais t'a pas l'autorisation de le lire!
Si le serveur est sous linux, regarde les droits!
Si c'est sous windows..chelou!
Faut voir en niveau des priviléges sur ce fichier je pense.
3 Mars 2005 02:45:45

Peux-tu mettre le script en entier s'il te plait.
3 Mars 2005 10:19:48

voici le scripte complet :

<?php

$date = date("j") . "/" . date("m") . "/" . date("Y") . " " . date("G") . " : " . date("i");
$message = $date . " " . $speudo . " : " . $signature;

$handle = fopen ("livre-d'or.txt", 'ab');

fwrite ($handle, $message);

fclose ($handle);

?>

et voici toute les erreur qu'ilme cree :

Warning: fopen(livre-d'or.txt): failed to open stream: Permission denied in /home/likorg/public_html/traitement livre d'or.php on line 11

Warning: fwrite(): supplied argument is not a valid stream resource in /home/likorg/public_html/traitement livre d'or.php on line 13

Warning: fclose(): supplied argument is not a valid stream resource in /home/likorg/public_html/traitement livre d'or.php on line 15
3 Mars 2005 11:10:41

Simple probleme de permission.(sinon, si ca marche tjs pas apres avoir réglé le probleme de permission, enleve le "b" bien que conseillé pour la portabilité car il n'est pas supporté par certain serveur.)
sinon pour ta date tu peux faire plus simple :
$date = date("j/m/Y G:i");
3 Mars 2005 11:21:37

merci pour avoir redui la date mais un tit truc le probleme de permission je peu le regler comment ?
c'est au niveau du scripte ou du serveur si c'est au niveau du scripte peut tu me dire comment on fait sinon si c'est au niveau du serveur j'essayerai de trouver
3 Mars 2005 11:23:21

il est aussi déconseillé d'utiliser des caractères spéciaux comme le ' dans les noms de fichiers. Beaucoup de problèmes viennent de là.
3 Mars 2005 11:28:57

je vien de tester en enlevent les caractaires speciaux du fichier txt et il me donne toujour les meme erreur
merci commaime khayyam
3 Mars 2005 12:10:32

dite personne ne peut m'aider pour ma permission de fichier
svp help me
3 Mars 2005 12:14:36

b c'est pour binary, donc binaire, alors que un fichier texte ne l'est pas...
Essaye de remplacer "ab") par "a")
3 Mars 2005 12:15:33

fait un chdmod 777
3 Mars 2005 12:20:45

je vien d'essayer et il me marque toujour les meme erreur
voici le scripte avec les modification :
<?php

$date = date("j/m/Y G:i");
$message = $date . " " . $speudo . " : " . $signature;

$handle = fopen ("livredor.txt", "a+");

fwrite ($handle, $message);

fclose ($handle);

?>

aider moi svp :-( :-( :-( :-( :-( :-(
3 Mars 2005 12:22:51

phpdebutant.org
3 Mars 2005 12:46:16

merci pour le site j'ai lue tout sur le fopen mais je ne voi pas ou j'ai pu fair un erreur
3 Mars 2005 13:16:45

pourquoi personne n'ai capable de m'aider
je rappele mon scripte :

<html>
<head>
<title>Traitement de la signature</title>
</head>
<body>
<?php

$date = date("j/m/Y G:i");
$message = $date . " " . $speudo . " : " . $signature;

$handle = fopen("livredor.txt", "a+");

fwrite($handle, $message);

fclose($handle);

?>
</body>
</html>

et les erreue qu'il m'afiche :

Warning: fopen(livredor.txt): failed to open stream: Permission denied in /home/likorg/public_html/traitement livre d'or.php on line 11

Warning: fwrite(): supplied argument is not a valid stream resource in /home/likorg/public_html/traitement livre d'or.php on line 13

Warning: fclose(): supplied argument is not a valid stream resource in /home/likorg/public_html/traitement livre d'or.php on line 15


svp aider moi c'est super important je vous en serez tres reconaissant et merci d'avance :-( :-( :-( :-( :-( :-( :-( :-( :-( :-( :-( :-( :-( :-( :-(
3 Mars 2005 13:27:00

c'est nivo serveur.
il faut donner la permission d'ecriture sur le fichier au process de apache (dit bien plus haut, seulement tu n'as pas répondu a la personne qui te demandé si c'était un serveur linux ou windows, donc elle a peu etre décider de passer son chemin.)
suffit de le faire.
3 Mars 2005 13:32:57

Verifie que l'hébergeur n'a pas desactivé l'option fopen, ca expliquerai le pourquoi du comment...
3 Mars 2005 14:02:05

dsl a Mr_Keyser pour n'avoir repondue a sont message mon serveur est sous unix
3 Mars 2005 14:20:53

Tu pourrais quand même te relire de temps en temps ... ca demande pas un effort sur-humain nan ?
Bonjour l'orthographe :-?
3 Mars 2005 14:25:38

sa sert a rien de poster un truc si c pa pour repondre a ma question merci et j aime les fote d'ortographe
3 Mars 2005 14:26:34

Je poste si j'en ai envie, tu ne dictes pas la loi ici

Edit : je trouve que c'est difficile à lire j'ai encore le droit de le faire remarquer je pense ...
3 Mars 2005 14:26:41

salu a tous -aRNo- je peut savoir a quoi tu sert a par faire du freepost alala

mdr ya de titan maintenan bon titan tu te depeche de le finir le site pour ce quil save pas c mon pot et c'est lui qui fai le site car moi ji connai rien donc je peu pas l'edai mai l'autre il m'enerve
3 Mars 2005 14:28:17

est ce que je t'ai dicter une regle non donc voila
3 Mars 2005 14:28:39

Citation :

titan95 a écrit :
sa sert a rien de poster un truc si c pa pour repondre a ma question merci et j aime les fote d'ortographe


Arno à raison on n'est pas tes chiens, tu fais un effort sur lecriture et on fera un effort pour répondre
3 Mars 2005 14:32:04

deja que j'essaye de faire un efort c'est de ma fote si je suis nul en orthographe en cour j'ecrie comme sa donc désoler
3 Mars 2005 14:38:10

Je critique pas ton orthographe tout le monde peut faire des fautes y a pas de mal. Mais dans ton 1er post par exemple tu ecris ca :
Citation :
j'ai un petit probleme avec fopen kan je linsair dans mon scrpite

C'est plus des fautes d'orthographe, ces mots n'existent pas ...
M'enfin bon ... y'a pas de mal ;-)
3 Mars 2005 20:29:31

Ok, maintenant qu'on sait que ton serveur est sous unix.
tu te log en root ou avec le proprio du fichier ciblé.
et tu effectues un chmod
exemple : chmod 660 fichier.ext (lecture/ecriture pour le proprio et le group)
Ensuite, tu vérifies que soit le proprio soit le groupe correspond au process de apache.
(ls -l pour voir les droits/proprio/group)
Sinon, il faut changer l'un des deux
chgrp apache fichier.ext (pour changer le groupe)
chown apache fichier.ext (pour changer le proprio)

J'ai mis apache car c'est le nom du process par defaut, mais tu peux le changer le config.

Si avec ca, tu n'y arrives pas, cherche un peu sur google, tu as plein d'aide sur les fonctions chmod / chgrp / chown
3 Mars 2005 23:39:01

si tu te connecte sur ton serveur avec un client ftp tu peux voir a coté de tes fichiers les attributs -rw-------
il faut qu'il soit à -rw-r--r-- pour pouvoir etre ouvert par le serveur web donc comme dit resurectin ya le chmod
ou sinon selon ton client ftp tu peux directement modifier les droits faut que tu autorise la lecture pour toi, ton groupe et les autres.

avec flashFXP tu fais un click droit sur le fichier a ouvrir et tu fais attributes et t'as une fenetre avec owner group public


voilou
un complément qui te sera je l'espere utile
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS