Se connecter / S'enregistrer
Votre question

EXCEL filtre cellule

Tags :
  • Microsoft Excel
  • Programmation
Dernière réponse : dans Programmation
25 Novembre 2004 17:05:18

désolé si mon post n'est pas dans le bon topic

est il possibe dans excel de donné une valeur par default a des cellules

je vous explique mon cas

j'ai des cellules avec des formule sur une feuille ensuite je copie les valeurs de ces cellule sur une autre feuille et je voudrais sur cette autre feuille que par exemple si les valeur retourné ( copié )son diferente de "10" les cellules afiche alors "NON"

merci d'avance si vous pouvez me donner un petit coup de main

Autres pages sur : excel filtre cellule

25 Novembre 2004 17:14:05

slt

je ne sais pas si un filtre existe pour faire ca

mais en tout cas tu peux utiliser une formule de ce type

=SI(B2=10;B2;"non")

par contre tu ne fais pas de copier coller
tu va chercher la valeur de la case (B2 ici)

j'espere que ca correspond à ce que tu veux

voila
25 Novembre 2004 17:40:07

merci
mais c'est ma faute j'ai pas etait clair
en fait les valeur sont copier dans un autre classeur créer par macro donc je peux pas aller chercher les valeur comme ca !!!

moi je comptez appliquer par macro un filtre au nouveau classeur pour faire ce que j'ai expliquer au dessus !!
mais bon je vois pas trop comment !!! lol


edit : une autre petite question peut on donner un nom au classeur créé par macro au lieu de classeur 1, classeur 2 .... merci
Contenus similaires
25 Novembre 2004 18:07:14

bon en fait je m'y connais pas trop en macro

mais quand tu copie tes valeurs avec la macro tu ne peux pas lui dire de faire comme ma formule que je t'avais donner si la case vaut tant alors valeur sinon "non"

25 Novembre 2004 18:44:51

pour donner un "vrai" nom au classeur :

activeworkbook.saveas "C:\toto.xls" par exemple

le coup du filtre j'ai pas pigé, si t'as besoin d'aide tu peux me contacter sur msn ;-)
26 Novembre 2004 10:06:12

Pour mes cellules je me suis arriver a trouver une petite astuce mais je vous remercie beaucoup !!!

pour le nom de classeur je vais tester ca dessuite !!!
26 Novembre 2004 10:58:03

j'ai corrigé le code, j'avais oublié un k

tu as d'autres paramètres intéressants dans la méthode saveas, notamment la possibilité de mettre un mot de passe automatiquement, de mettre en lecture seule recommandée, etc... ;-)
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS