Résolu Forum MKV français

Solutions (88)
Tags :
  • Mkv
  • multimedia
  • Vidéo
  • Logiciels
|
Bonjour,
J'ai un problème avec MKVMERGE lors des Mux.
Si je prends n'importe quelle video en MKV que mon lecteur multimedia de salon lit sans problème et que je veux par exemple y rajouter des sous-titres anglais ( ma compagne est d'origine anglaise et a un peu de mal à comprendre totalement le français, enfin bref) mon lecteur multi-média de salon ne va plus reconnaitre la video, et ne plus la lire... Aucun soucis pour le PC et avec n'importe quel lecteur ( VLC, MPC etc.) le film avec les sous-titre anglais rajoutés passera nickel.
Je suppose que MKVMerge a fait son taff correctement ( comme il me le marque à la fin du MUX)
Contenus similaires
Meilleure solution
partage
, Tenue correcte |
Ok tant mieux ^^
  • Commenter cette solution |
Score
0
òh
òi
|
Voilou comme je disais Problème résolu avec une meilleure réponse de moi-même et une très impliquée aide de l'empereur noir ;) 
Voilou c clos !!!!!!!!!!!!!!!!!!!!
  • Commenter cette réponse |
Score
0
òh
òi
|
Meilleure réponse sélectionnée par zeitgeist_72.
  • Commenter cette réponse |
Score
0
òh
òi
|
OKY Problème résolu !!!!!!!!!!!!!
En fait j'ai utilisé le logiciel "mediainfo" et j'ai utilisé exactement la même version du logiciel avec laquelle le MKV avait été "encodé" la pemière fois...
En prenant une version plus vieille il me passait l'image en avance rapide et je n'avais donc plus accès au son... en prenant la version identique ça a fonctionné...
Maintenant est-ce que cela va fonctionner à chaque coup, je ne sais pas...
En tout K merci à toi
  • Commenter cette réponse |
Score
0
òh
òi
|
Mais je le répète encore une fois, il me prends toute les vidéos à la base, c juste une fois que j'ai rajouté les sous-titres que le MediaDisk ne me prends plus la video ( il m'affiche les sous-titres et fait tourner la bande-son)
Et MKVMerge fonctionne puisque tout passe niquel sur le PC avec MPC ou VLC à la base et après le Mux aussi, et j'ai aussi accès aux sous-titres Anglais (.srt).
Donc le problème est par rapport au MediaDisK pas directement par rapport à la manip du "Mux"...Si je ré-ouvre avec MKV-Merge le MKV qui ne passe plus sur le Média-Disk j'ai pour la video exactement et ce à la virgule près, le même descriptif que la première fois ( de toute façon il n'est censé toucher à rien au niveau de ce que tu mets ou enlève, il " compile" le conteneur, rien de plus)
  • Commenter cette réponse |
Score
0
òh
òi
|
MPEG4/AVC H264 (qui est une norme internationale d'encodage)
la majorité de mes films utilisent x264 (qui est open source) mais je sais que j'en ai quelques un avec l'encodeur de Ateme fourni avec Nero...Mais c la même chose ça reste du MPEG4/AVC H264 mais zvec le truc d'Ateme et non pas avec le x264
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Quant tu fais "ajouter" dans mkv merge, peut tu me dire sous quel format est ta piste vidéo stp? (codec+format)
  • Commenter cette réponse |
Score
0
òh
òi
|
Nan, cela ne fonctionne tjs pas... m4ng ou RI4M fonctionnent avec MKVMerge donc c normal que cela ne fonctione pas...
et comme je te disais les TS ou M2TS ne gèrent pas les sous-titres mais cela je le savais déjà (dès que tu vas mettre des sous-titres il va mettre un code erreur)...
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Ca marche??
  • Commenter cette réponse |
Score
0
òh
òi
|
Ha si c'est normal, en fait ça fonctionne avec MKVtoolnix...
  • Commenter cette réponse |
Score
0
òh
òi
|
Tiens, par exemple, une question, dans le tuto que tu m'as envoyé au N°4, on est dans outils-MUX/demux MAIS pourquoi si on passe par MKV au lieu de TS comme marqué c MKVMerge qui s'ouvre direct?
D'après toi, si je Vire MKVMerge il ferait de quelle manière puisque les deux programmes n'ont aucun rapports en fait?
  • Commenter cette réponse |
Score
0
òh
òi
|
Bon bha dès que je mets un sous-titre il me marque erreur code 2, donc j'ai fait sans le fichier .srt Anglais et ça a encore marqué erreur code2, j'ai viré tous les sous-titres et laissé juste la video et la bande son, et le MUX fonctionne Niquel...Ce qui me ramène à la case départ, une video, une piste son français... je te l'avais dit qu'il ne gérait pas les sous-titres...
  • Commenter cette réponse |
Score
0
òh
òi
|
Bon je V essayer mais, à force, je V me faire renvoyer mes DVD et cela sera plus simple, franchement 30euros de port pour mes 200dvd et ne pas pas perdre une heure de plus à galérer cela serait vraiment pas cher payer...
Bon alors, en fait RI4M V6 n'existe pas en fait c'est un leure, le RI5M c'est arrêté a la V5 et donc c'est V6 est juste pour te faire passer du RI4M à m4ng qui est en quelque sorte son remplaçant...
Donc si je prends la V5 de RI4M dès le début du mux elle me plante...
Quant à m4ng_v3, il passe comme je le disais par MKVMerge pour fair ele MUx ( à moins qu'il y'ait un truc à configurer mais j'ai pas vu) et le seul truc qui change c'est que le MUX prends 25minutes au lieu d'1minute et c'est exactement le même résultat...
Bon je V voir ton tuto
Merci encore
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Essaie de suivre ce tuto (fait pour ps3 mais ca vaut le coup d'essayer ^^)
Par contre a la fin de l'étape 1 tu lances le MUX normalement et tu teste

http://lauden.fr/Ducke/Tutos_m4ng_v3/Mkv_ps3.html
  • Commenter cette réponse |
Score
0
òh
òi
|
Merci pour le Lien mais j'avais déjà essayé et en TS ou M2TS les sous-titres ne sont pas pris en charge...
  • Commenter cette réponse |
Score
0
òh
òi
|
Avec virtualdubmod c la grosse galère...
Avec RI4M j'ai choppé la version 6 qui ne fonctionne pas parce qu'il me dit que la version est périmée, il faut m4ng_ "v3-v3 ou la V1" et après deux heures de galère pour tout remettre à jour, dès-installer tout le merdier de RI4M... cette Nouvelle mouture de m4ng_v3 quand je me prépare à faire un "MUX" bha c super il ouvre et utilise MKVMerge...
Je crois que je V laisser tomber.... ça commence à me gonffler sévère....
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Au pire tu peux tester avec tsmuxer :
http://webcache.googleusercontent.com/search?q=cache:ru...
  • Commenter cette réponse |
Score
0
òh
òi
|
Bonjour à l'Artiste de la Gamberge, lol
Nan, je l'avais fait aussi pratiaquement dans la foulée et cela n'avait pas fonctionné non plus...
J'avais eut une autre idée aussi qui n'a pas fonctionné nan plus. Dans le fichier destination dans le "type de fichier" au lieu de prendre "MKV, MKA, MKS, MK3D" j'ai pris *.*, parce que je me suis dis peut-être qu'il y'a un truc que le Mediadisk ne "capte" pas parce que ce n'est pas uniquement spécifié MKV et finalement, ça ne change strictement rien...
Je V aller voir avec "virtualdubmod" et essayer un ptit MUX...
Les mises à jour dur firware n'ont rien données (de toute manière vu les mises à jour que c'était, cela n'avait aucun rapports)
La suite au prochain épisode...
@+

  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Essaie avec le FPS : 24000/1001
Ce corresponds a 23.98 je pense (24000/1001=23.98)
  • Commenter cette réponse |
Score
0
òh
òi
|
Ouep, tout est OK en fait...
Bha moi aussi je V aller au pieu, lol, je doit me lever dans 4H30, lol...
Merci encore une fois !!!!!!!!!!
Bonne Nuit
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Bah verifie dans mkvmerge que les dimension (en px) sont ok, si oui je saispas trop.
La seule chose sure c'estque ca foire a ce niveau la. Je verrai ca en details demain : la nuit porte conseil ^^
  • Commenter cette réponse |
Score
0
òh
òi
|
En fait dans le menu déroulant y'a 24 25 30 60000/1001 30000/1001 ou 24000/1001 comme choix possibles pour FPS


Dans les infos fichier pour la video y'avait ideo: MPEG4 Video (H264) 640x480 23.98fps [Video]
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Arf ... C'est bizarre je pensai vraiment que c'était ca qui marchait pas.
Dans le menu en question(celui des FPS) il ya bien des dimensions au niveau des pixels ?
  • Commenter cette réponse |
Score
0
òh
òi
|
NAN, Helas, cela ne fonctionne pas non plus...
Il me remarque sur le médiadisk format info Unknow 0x0 0fps
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Lol oki
  • Commenter cette réponse |
Score
0
òh
òi
|
Bon sur le PC ça fonctionne nickel comme d'hab... et sur le médiadisk je sais pas encore parce que j'y suis allé mais j'ai hommis de copier sur le hdd portable, lol alors forcément je ne le trouvais pas...
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Ok parfait, une fois le mux terminé tu test pc puis mediadisk ca devrai marcher je pense :) 

Lol t'as raison je vais m'enfiler une bouteille Xd
  • Commenter cette réponse |
Score
0
òh
òi
|
Bha l'alcool ça aide parfois moi aussi jsuis à 3G"rammes" ptdr, nan, je déconne...;)
  • Commenter cette réponse |
Score
0
òh
òi
|
23.98fps
j'ai donc mis 24 parce que ce sont des menus déroulants pour FPS donc j'ai pas trop le choix puis j'ai lancé le MUX.
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Dans format factory tout en bas du menu a gauche tu as un sous menu advanced, tu fais media file info et tu va chercher ton film puis il te dira tout dessus y comris frame rate ( valeur approchée) apres tu pourra faire mon astuce.
Si je te réponds plus c parcque mes parents on coupé la box (suis en 3G ^^) donc je peu taider kun minimum

Ps :D sl pour fautes orthographe
  • Commenter cette réponse |
Score
0
òh
òi
|
Oui, j'avais bien compris la seconde étape mais le fichier de base qui fonctionne de base étant un MKV aussi si je fais un clic droit propriété et détail, je n'ai que Nom, Type, Chemin, taille, date de création attribut proprio etc. rien à proprement parlé sur les détail de la video puisque il me donne les détails du MKV et pas les détails de ce qu'il contient... Le truc c'est que quand j'ai fait mes MKV à la base avec RI4M, à chaque fin de "Mux" il me joignait un dossier ".txt"avec tous les détails du "mux" sur la vidéo, le taux de compression etc. mais je les ai viré tous ces fichier .txt de détails...
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
NNNNN ....
Une fois que tu ouvres ton fichier vidéo (mkv) tu as pleins de trucs dedans ok?
Genre Piste vidéo puis piste audio ok?
Tu fais un CLIC GAUCHE (en gros tu le selectionne juste) sur le fichier (dans le mkv) qui contient la piste vidéo
Ensuite tu vas dans Options spécifiques de format et tu met le FPS que tu a pris dans propriétés !
Normalement rien ne sera grisé

Enfin tu rajoutes tes sous titres normalement > Mux et test ca marcheras
  • Commenter cette réponse |
Score
0
òh
òi
|
Ouep, je comprends ce que tu veux dire... cependant vu que la vidéo qui fonctionne est déjà à l'intérieur du MKV je ne peux pas faire le clic droit sur le fichier video...Faudrait que je regarde cela sur MKVMERGE mais je ne vois rien
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Sérieux si c'est pas ça je suis a court ! :D  :D 
Mais je le sens bien t'inquiètes
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Ok c'est ce que je voulais (qu'elle ne passe pas ! XD)
Alors voici les étapes que j'ai en tête :
- Tu fais clic droit sur ta vidéo (d'origine) et va dans Propriétés > Détails > Retiens la valeur (dans vidéo) de la fréquence d'images (en trames/s)
- Puis retourne dans le menu de mkvmerge fais ajouter (met le film + sous titres ...) sauf que avant de lancer le mux tu fais les étapes suivantes
- Clique sur ce qui corresponds a la vidéo (dans ton mkv) > Options spécifiques de format > Et dans FPS tu mets la valeur retenue précédemment (dans les options du film premier tiret!)
- Puis lance mux > test déja depuis pc puis si ok > mediadisk

Je pense que ca devrai marcher ( Prions ! )
:bounce: 
  • Commenter cette réponse |
Score
0
òh
òi
|
Est-ce que tu connais un autre logiciel que MKVMerge pour faire cela?
  • Commenter cette réponse |
Score
0
òh
òi
|
Il me marque pareil Unknow 0x0 0 fps
  • Commenter cette réponse |
Score
0
òh
òi
|
Nan, la video ne passe pas, ce n'est donc pas par rapport aux sous-titres
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
On va voir, sinon j'ai encore une soluce qui peut être assez efficace (je me la garde pour l'instant^^)
  • Commenter cette réponse |
Score
0
òh
òi
|
MUX fINIT... je V voir... je ne sais pas pourquoi mais il m'a prit bcp plus de temps que d'hab...
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Oui, histoire de voir si c'est pas Mkvmerge qui foire quelque part
  • Commenter cette réponse |
Score
0
òh
òi
|
Je prends donc le film de base qui fonctionne en MKV, je fais un "faux" mux pour le garder tel quel....
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Peux tu essayer de muxer ton film sans rajouter les sous-titres stp?
Tu fais juste Ajouter puis Démarer le mux.
Et ensuite essaye le sur ton mediadisk
Normalement il devrait le lire
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Oui ... attends j'essaie un truc de mon coté ^^ (une idée me viens)
  • Commenter cette réponse |
Score
0
òh
òi
|
Salut...
Mais en même temps elle est bien là ( la vidéo) puis le PC la lit
  • Commenter cette réponse |
Score
0
òh
òi
, Tenue correcte |
Non il n'est pas censé modifier la bande vidéo c'est pour ca que c'est bizarre
  • Commenter cette réponse |
Score
0
òh
òi
|
Alors, j'avance à petits pas, mais comme il se comporte ( le Mediadisk) comme s'il n'y avait pas de vidéo, j'ai relancé le MKV et j'ai mis "info" et dans video info il marque Unknown 0x0 , 0fps
Pourtant il n'est pas censé toucher à la vide pendant le mux ou je me trompe?
  • Commenter cette réponse |
Score
0
òh
òi
|
Alors, j'avance à petits pas, mais comme il se comporte ( le Mediadisk) comme s'il n'y avait pas de vidéo, j'ai relancé le MKV et j'ai mis "info" et dans video info il marque Unknown 0x0 , 0fps
Pourtant il n'est pas censé toucher à la vide pendant le mux ou je me trompe?
  • Commenter cette réponse |
Score
0
òh
òi
|
Bon,
Alors... j'ai mis trois sous-titres différents, spécifiant cette fois que les sous-titres sont en french ( mais cela n'a pas d'importance en fait puisque sinon il met sous-titre inconnu pour la langue,c pas important) et j'ai mis oui pour défault track flag ( ce n'est pas très important non plus puisque cela sert apparement à activer directement ce sous-titrage quand tu lances le film, ça évite juste une manip quand tu lances le film) , et j'ai accès à tous les sous-titres, idem pour les pistes son mais tjs pas de vidéo...
Par contre j'ai remarqué une chose, comme je le disaisau début le "chrono" du film se déroule normalement cependant ce que je n'avais pas remarqué c'est que ce n'est pas le temps du film mais le temps de la piste son... Si je veux faire une avance rapide de l'image "inexistante, lol", le chrono ne bouge pas et dès que je remets lecture le MKV repart à zéro...et relance la piste son au début...
Tout fonctionne tjs niquel du côté PC...
Je fais bien add/ajouter à chaque fois je ne fais pas mettre à la suite. De toute façon si je m'étais trompé sur cette manip cela ne fonctionerait pas correctement sur le PC.


  • Commenter cette réponse |
Afficher plus de solutions

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS