Résolu Comment intégrer une formule à 3 conditions sous Excel ?

Solutions (4)
Tags :
  • Microsoft Excel
  • Programmation
|
Bonjour,

Je cherche une formule a plusieurs conditions, j'arrive avec deux mais je n'arrive pas pour la troisieme.
mon probleme est le suivant:
SI X>250 alors c'est "bientot a faire"
SI X<280 alors c'est "bientot a faire"
SI X<250 alors ce n'est "pas a faire"
SI X>280 alors c'est "a faire"

je voudrais que pour chacune de ces conditions apparaisse dans la case le mot entre guillemet
ma formule avec deux conditions est la suivante:
=SI(ET(X>250;X<280);"BIENTOT A FAIRE";"A FAIRE")
je n'arrive pas a intergre la troisieme conditions qui est si X<250 alors "pas a faire"
merci pour votre aide
  • Meuniers a édité ce message
  • Meuniers a édité ce message
Contenus similaires
Meilleure solution
partage
|
Slt, voila :

  1. =SI(E3<250;"Pas a faire";SI((E3>250)*ET(E3<280);"Bientot";"A faire"))

le E3 étant ton X
  • OmaR a sélectionné cette solution comme la meilleure réponse
  • Commenter cette solution |
Score
0
òh
òi
|
quand une formule te semble compliquée a faire, tu peux la décomposer en plusieurs étapes, pour ensuite les emboiter : exemple

condition 1 et(x>250;x<280) "bientôt a faire"
condition 2 x<250 "pas a faire"
condition 3 x>280 "a faire"

cd1 si(et(x>250;x<280);"bientôt a faire";"cd2")
cd2 si(x<250;"pas a faire";"cd3")
cd3 si(x>250;"a faire";"")

Si la condition 1 n'est pas valide, elle va chercher la conditon 2 et si c'est celle-ci n'est pas valide non plus, elle va chercher la condition 3
Il suffit donc de copier la dernier formule pour l'encastrer a la place de "cd3" et ensuite copier la nouvelle formule du cd2 dans "cd2"
Ce qui fait qu'au finale tu auras une formule unique en cd1, ce qui donnera :

si(et(x>250;x<280);"bientôt a faire";si(x<250;"pas a faire";si(x>250;"a faire";"")))

Avec cette technique tu peux emboiter autant de formules que tu veux
  • Commenter cette réponse |
Score
0
òh
òi
|
Bonjour

As-tu essayé =si(X<250;'pas à faire';si(X<280;'bientôt à faire';'à faire')) ?
Dans ce cas, excel regarde si X<250; si c'est la cas, il écrit pas à faire; sinon, il regarde si X<280, si oui, il écrit bientôt à faire, et si non, il écrit à faire dans ta cellule.

Bon courage!
  • Commenter cette réponse |
Score
0
òh
òi
|
DivX_666 a dit :
Slt, voila :

  1. =SI(E3<250;"Pas a faire";SI((E3>250)*ET(E3<280);"Bientot";"A faire"))

le E3 étant ton X

Merci pour la formule, ça avait l'air simple.
ça marche tres bien pour mon probleme.
  • Commenter cette réponse |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS