Se connecter / S'enregistrer

Résolu Aide formule excel - référence circulaire

Solutions (2)
Tags :
  • Microsoft Excel
  • Vecteur
  • Logiciels
|
Voici mon problème, j'ai cette formule dans G7 : =RECHERCHE(A7;nom;repas)
A7 est le nom recherché dans feuille#1; nom est le vecteur de recherche parmi la liste des nom sur la feuille#2; repas est le vecteur résultat qui est représenté sous forme "oui" ou "non"

Alors, maintenant oui ou non s'inscrit dans la cellule G7. Jusqu'ici tout va bien.

Voilà ou ça ce gâte.

J'ai maintenant besoin d'ajouter un SIG7="oui" multiplie (cellule X(D19) ayant pour valeurs 100$ que je la fige avec F4 pour qu'elle reprenne toujours ce 100$)
par une autre cellule X(C7) ayant pour valeurs le nombre de jours... Si faux = 0 (toutes ces cellules sont contenues dans la feuille#1)

ce qui donne ça au long: =RECHERCHE(A7;nom;repas)+SI(G7="oui";$D$19*C7;0)

Excel me donne un message d'erreur qui me prévient d'une référence circulaire.

Quelqu'un peux m'aider c'est pour un travail scolaire ..

merci.







Contenus similaires
Meilleure solution
partage
|
Salut

=RECHERCHE(A7;nom;repas)+SI(RECHERCHE(A7;nom;repas)="oui";$D$19*C7;0)

ça devrait permettre de casser la boucle dans ta logique puisque tu renvois le calcul et non la cellule qui contient le calcul.
Toutefois je te réponds sans réellement mettre penché sur la logique de ton calcul, je te conseillerais de faire une recherche verticale genre ça :

=SI(RECHERCHEV(A7;Clients!A2:D 7;4)="oui";$D$19*C7;"0")
  • Commenter cette solution |
Score
0
òh
òi
|
merci de ta réponse ça ma aider pour trouver la solution. Mais elle n'était pas complète. Je publie la solution si ça peux aider quelqu'un d'autre

=SI(RECHERCHE(Séjours!A7;nom;repas)="oui";RECHERCHE(A7;nom;personnes)*$D$19*C7;0)
  • Commenter cette réponse |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS