Se connecter / S'enregistrer

Résolu Excel ajouter 1 an à la date si mois dépassé

Solutions (1)
Tags :
  • Microsoft Excel
  • Logiciels
|
Bonjour à tous,

Je souhaiterai savoir comment incrémenter l'année actuel de +1 si le mois de sa date de naissance est déjà passé pour signifier que l'anniversaire du client sera l'an prochain.

Ex:28 Janvier donc + 1 pour 2014
J'ai commencé avec deux fonctions si quelqu'un peut m'aider:
=SI(MOIS(E2)>AUJOURDHUI();AUJOURDHUI()+ANNEE(E2)+1;E2)
ou alos
=SI(MOIS(E3)>AUJOURDHUI();DATE(ANNEE(E3)+1;MOIS(E3);JOUR(E3));E3)

Merci à vous pour réponses^^

  1.  

Contenus similaires
Meilleure solution
partage
, Administrateur |
Salut knaky69

A mon avis tu vas galérer en essayant de faire ceci de cette façon. L'année prochaine ta formule ne fonctionnera plus.
Est-ce que tu disposes de la date de naissance complète de chaque personne ? Auquel cas on pourrait faire une formule qui dans une colonne te met simplement la prochaine date d'anniversaire.

Pour faire ceci:
1. On compare la date d'anniversaire de l'année courante avec la date courante
2. Si la date est dépassée pour cette année, le prochain anniversaire est ANNEE+1, sinon c'est l'année courante

En supposant que la date de naissance de la personne soit en E2, ca ferait:
  1. =SI((DATE(ANNEE(AUJOURDHUI());MOIS(E2);JOUR(E2)))-A2<0;DATE(ANNEE(AUJOURDHUI())+1;MOIS(E2);JOUR(E2));DATE(ANNEE(AUJOURDHUI());MOIS(E2);JOUR(E2)))
  • Dreamcaster a sélectionné cette solution comme la meilleure réponse
  • Commenter cette solution |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS