Problème avec mon include

Solutions (1)
Tags :
  • Index
  • VIA
  • Php
  • CSS
|
Bonjour, j'ai un fichier index.php qui appelle un autre: menu.php via la fonction include. Le fichier css de menu.php est stocké dans un autre dossier. Mon problème est le suivant: lorsque je lance ma page index.php elle génère correctement ma page mais sans inclure la page menu.php. Je n'ai pas trouvé ma réponse sur d'autres forum .. Je mets un bout de code des 2 fichiers pour que vous compreniez mieux le problème.

index.php
<body>
<header>
<div id="header">
<p> <h1>Test</h1>
Recherche:
<input type="text" name="recherche"> <br \>
</p>
</div>
</header>
<div id="corpsDuTexte">
<?php include "menu.php"; ?>
<h1> Accueil </h1>
<div id="texte">

menu.php
<head>
<link href="css/style.css" rel="stylesheet" type="text/css" />
</head>
<div id="info">
<div class="stretchHolder">
<div class="stretchMenu">
<ul class="stretchDrop">

Je vous évite la suite interminable.

J'ai donc un dossier contenant index.php, menu.php et un dossier nommé: css contenant stylemenu.css. Wampserveur est bien allumé.
(Pour être clair)

Vous avez une petite idée ?

Merci

  • AAymeric a édité ce message
Contenus similaires
Score
0
òh
òi
|
alors la ... tu est sur que index.php et menu.php sont bien dans le même niveau d’arborescence ?
es que tu n'aurais pas oublié un ";" dans ton code en amont de celui que tu nous a fournis ?
  • Commenter cette réponse |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS