Résolu Comparaison entre deux colonnes Excel

Solutions (3)
Tags :
  • Microsoft Excel
|
Bonjour

voici j'ai un petit problème avec une comparaison sur deux colonnes Excel
en effet si les deux nom ne sont pas écrit à la lettre près, il n'y a aucune liste qui sort

Exemple:
en A LOTION DERMANIOS / SKINMANN

en B Lotion Dermanios Scrub Chlorhexidine 4% 30ml / Skinmann soft Protect désinfectant mains 100ml

J'ai essayé: =RECHERCHEV(A2:A21;$B$2:$B$1500;1;FAUX) ou =SI(NB.SI($B$1:$B$50;A2:A31)>0;"présent";"absent")

résultat en C néant
merci de regarder

Bonne
Contenus similaires
Meilleure solution
partage
, Modérateur |
Salut,

Peux tu préciser ton problème ?
Est-ce que par hasard tu voudrais comparer la valeur d'une cellule avec des valeurs situées dans une plage de cellules pour convertir un nom abrégé et variable en une référence formatée ?

Par exemple :
En A1 : saisir le nom du produit
En A3:A100 liste de mots discriminants, par exemple "LOTION DERMANIOS"
En B3:B100 liste de références formatées, par exemple "Lotion Dermanios Scrub Chlorhexidine 4% 30ml"
En B1 : faire apparaitre "Lotion Dermanios Scrub Chlorhexidine 4% 30ml" si on a tapé "LOTION DERMANIOS" en A1

Dans ce cas, il faut utiliser un RECHERCHEV, mais en convertissant tout avec un MAJUSCULE() de façon à ce que la comparaison ne soit pas perturbée par des saisies mixant majuscules/minuscules. Ce qui n'empêche pas d'avoir une sortie sans majuscules, bien sûr.

Par contre, si tu veux que "DAIRMANIOS" ou "DERMANIOS LOTION" sortent le même résultat, il faudra compliquer un peu l'ensemble...
  • Dreamcaster a sélectionné cette solution comme la meilleure réponse
  • Commenter cette solution |
Score
0
òh
òi
, Modérateur |
Je détaille un peu ici le commentaire laissé sous ma 1ère contribution.
Si tu veux chercher dans ta colonne B si il y a une occurrence contenant chacun des trois mots de la colonne A, il te faut extraire chaque mot de ta colonne A, les formater (maj/minuscule) puis les comparer en une fois avec la colonne B.

Perso, je mettrais la colonne B en colonne E.
Je ferais 3 colonnes masquées B,C,D dans lesquelles j’extrairais les mots discriminants de la colonne A.
Puis en colonne F, je mettrais un triple test avec un recherche() mot B ET recherche() mot C ET recherche() mot D.

Et je ferais aussi une colonne masquée qui soit un clone de la colonne E mais avec une mise en forme MAJUSCULE(), pour ne pas avoir à gérer ça dans les tests.

Il y a peut-être plus élégant, mais ça, c'est facile à faire...
Une solution en macro est aussi envisageable...
  • mezigo a édité ce message
  • Commenter cette réponse |
Score
0
òh
òi
, Animateur |
Bonjour,

Si tu veux une recherche relative, il te faut écrire la formule =RECHERCHEV(A2;$B$2:$B$1500;1;VRAI) et la recopier vers le bas pour les autres cellules.
A ce moment là, Excel cherchera la valeur se rapprochant le plus de la valeur en A2.
  • Commenter cette réponse |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS