Se connecter / S'enregistrer

Résolu Page Index

Solutions (27)
Tags :
  • Arrière plan
  • Index
  • Sites Internet
  • Programmation
|
Bonjour à Tous.
J'ai Récemment Créer un Site Internet Comprenant Une Galerie.
Mon Site se Présente Sous La Forme http://technixgraphist.hebergratuit.com/ et La Galerie http://technixgraphist.hebergratuit.com/piwigo/
Seulement, La Page Du Premier Lien est Vide...
J'aimerai Créer Une Page Simple Avec un Background, Et Un Lien Vers La Galerie. Et Tout en Insérant Des Images Dans Cette Page.
Seulement Le Codage De Ce Genre, Ce N'est Pas Vraiment Mon Truc ^^'
J'aurais Besoin D'une Petite Aide =)
J'ai Accès au FTP du Site Si il y a Besoin.

En Vous Remerciant à L'avance.
Cordialement.
Contenus similaires
Meilleure solution
partage
|
Pour le "/hth", c'est ce qui est juste après la balise body.
Pour ajouter tes liens (et pas des boutons), le code est:
  1. <a href="/piwigo/">Galerie</a> | <a href="mailto:ton.adresse@fai.com">Contact</a>

En fait, à mettre à la place du "/hth" qui est dans ta page.

Et franchement, apprends les bases du html.
  • Commenter cette solution |
Score
0
òh
òi
|
Meilleure réponse sélectionnée par juJu51.
  • Commenter cette réponse |
Score
0
òh
òi
|
Bah euh, Comment dire...
CA MARCHE x)
Je te remercie vraiment pour toutes tes information et ton aide ainsi qu'Edyr.
Je n'ai plus qu'à positionner correctement et voilà.
Encore Merci à Vous :) 
  • Commenter cette réponse |
Score
0
òh
òi
|
Ne mets pas d'espace entre "300" et "px"
  • Commenter cette réponse |
Score
0
òh
òi
|
Si je te suis, j'arrive à cela :
  1. <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  2. <html><head>
  3.  
  4.  
  5. <script></script>
  6.  
  7. <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type"><title>Technix Graphist</title>
  8.  
  9.  
  10.  
  11. <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1"></head><body style="background-image: url(background1.jpg); height: 300px; width: 1534px;"><br>
  12.  
  13.  
  14. <span style="position: absolute; top: 300 px; left: 300 px;width: 150px; height: 100px">
  15. <A href="/piwigo/"><IMG src=boutongalerie.gif alt="Galerie" border=0 ></A>
  16. <link rel="icon" type="image/png" href="mafavicon.png" />
  17. </span>
  18. </body>


Mais ma "vignette" lien vers la galerie ne se positionne pas à 300 px du haut et 300 px de la gauche...
  • Commenter cette réponse |
Score
0
òh
òi
|
Ton code (tes liens, ton contenu) doit aller avant la balise </body>
  • Commenter cette réponse |
Score
0
òh
òi
|
J'ai trouvé sur un site les balises <span> pour positionner un élément, mais impossible de l'appliquer à mon élément, j'ai essayé tour ce que j'ai pu, mais je n'ai pas réussi...
  • Commenter cette réponse |
Score
0
òh
òi
|
Mon Problème de "/hth" Est résolu enfin^^
Je te remercie pour le code, mais je souhaiterais savoir si l'on peut "adapter" ces liens à une image ou un logo?
Du Genre, on clique sur le logo ou l'image pour accéder à la galerie et pas sur la petite écriture de "Galerie"
Et par la suite, comment positionner ce lien pour qu'il soit en dessous de mon logo "Technix Graphist" qui est en fond

Edit : J'ai finalement réussi à placer l'image comme lien vers ma galerie grâce à un petit cours sur le html :) 
Mais un problème persiste, que je ne sais toujours pas résoudre. Comment déplacer cette image en dessous de "Technix Graphist" tout en sachant qu'un autre logo "Contact" sera placé juste à sa droite.

En vous remerciant à l'avance.

PS : Voici Mon Code de La Page :

  1. <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
  2. <html><head>
  3.  
  4.  
  5. <script></script>
  6.  
  7. <meta content="text/html; charset=ISO-8859-1" http-equiv="content-type"><title>Technix Graphist</title>
  8.  
  9.  
  10.  
  11. <meta http-equiv="content-type" content="text/html; charset=ISO-8859-1"></head><body style="background-image: url(background1.jpg); height: 300px; width: 1534px;"><br>
  12. </body>
  13.  
  14. <A href="/piwigo/"><IMG src=boutongalerie.gif alt="Galerie" border=0 ></A>
  • Commenter cette réponse |
Score
0
òh
òi
|
Mais après la balise body je n'ai rien juste </html>

Edit : Et quand je retire </html> je me retrouve simplement avec une page blanche et la bannière publicitaire... Et le /hth a disparu...
  • Commenter cette réponse |
Score
0
òh
òi
|
Hum, si tu as un hébergeur simple, même payant qui me donne accès au FTP avec une base de données MySQL, et 1Go d'espace disque ou plus, je suis preneur... Mais là n'est pas ma priorité^^
Maintenant que j'ai ma page. Voir : http://technixgraphist.hebergratuit.com
Je souhaiterais :
-Enlever Le /hth en haut à Gauche
-Insérer 2 Boutons Dans Ma Page :
-Un pour accéder à ma galerie ( http://technixgraphist.hebergratuit.com/piwigo/ )
-Un autre pour que les gens puissent me contacter par mail si ils le désirent.
Et là, je suis vraiment perdu^^
  • Commenter cette réponse |
Score
0
òh
òi
|
De base passer par un hébergeur qui t'impose de la publicité en l'intégrant lui même au site c'est pas viable. Tu es complètement dépendant des choix des campagnes publicitaires qu'il va faire et qui peuvent détruire l'affichage de ton site. Pour un graphiste c'est très moyen.

Tu as plein d’hébergeurs associatifs qui t'imposent pas de publicité et des hébergeur pro pour même pas le prix d'un café par mois :) 
  • Commenter cette réponse |
Score
0
òh
òi
|
Bah au Début, Avec Leur Page D'index, La Publicité Se Trouvait Tout en Bas de La Page...
  • Commenter cette réponse |
Score
0
òh
òi
|
juju51 a dit :

Cependant, J'ai Une Bannière Publicitaire Tout en Haut Qui cache Tout --'
Serait il possible de la mettre tout en Bas?


Non, change d’hébergeur :) 
  • Commenter cette réponse |
Score
0
òh
òi
|
Les deux y sont déjà.
Mais que dois-je mettre dans le fichier "index.html" pour que mon image de fond s'affiche??

Edit : J'ai Retiré le htdocs et j'ai Bien Mon Image de Fond.
Cependant, J'ai Une Bannière Publicitaire Tout en Haut Qui cache Tout --'
Serait il possible de la mettre tout en Bas?
  • Commenter cette réponse |
Score
0
òh
òi
|
Non, il ne faut pas le htdocs/
Ton index.html et image.jog doivent être dans le répertoire htdocs.
  • Commenter cette réponse |
Score
0
òh
òi
|
Bah, j'ai placé mon image dans mon FTP ici : /htdocs/image.jpg

Avec mon indez que j'ai modifié, je suis arrivé à ceci :

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html><head>


<script></script>

<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type"><title>htdocs/index.htm</title>



<meta http-equiv="content-type" content="text/html; charset=ISO-8859-1"></head><body style="background-image: url(htdocs/image.jpg); height: 106px; width: 1534px;">/hth<br>
</body></html>

Cependant, lorsque je vais sur le site, rien ne s'affiche, juste /hth
Comment Doit être mon index.html?
  • Commenter cette réponse |
Score
0
òh
òi
|
le chemin (../Pictures/Site/Background%20Index.jpg) est relatif à la page index. Donc, soit tu copies l'intégralité des sous-répertoires (Pictures/Site/) soit tu déplaces ton image et change le chemin.

Petit détail: évite les majuscules, espaces et accents dans les noms de répertoires et fichiers.
  • Commenter cette réponse |
Score
0
òh
òi
|
Je pensais qu'il fallait l'héberger sur internet ^^'
Je me retrouve avec ceci dans mon html :
<body style="background-image: url(../Pictures/Site/Background%20Index.jpg); height: 106px; width: 1534px;"><br></body>
Si je place mon image dans le dossier "htdocs" de mon FTP, quel chemin d'accès dois-je rentrer? Et où entre les balises?
  • Commenter cette réponse |
Score
0
òh
òi
|
Salut,

L'erreur classique c'est de na pas avoir envoyé l'image sur le FTP et/ou utilisé un mauvais chemin pour l'image :) 
  • Commenter cette réponse |
Score
0
òh
òi
|
Hum, qu'est ce que le "manuel"??
  • Commenter cette réponse |
Score
0
òh
òi
|
Je pense qu'il faut que tu lises le manuel.
Pour ma part, je développe avec nano, alors les wysiwyhtg*, je ne peux pas trop t'aider.

* What You See Is What You Hope Too Get
  • Commenter cette réponse |
Score
0
òh
òi
|
J'ai téléchargé Composer, Je me suis fais une jolie page d'index, simplement avec une image. Mais lorsque je transfère mon ficher index.htm et que je vais sur la page de mon site, il n'y a rien...
Je ne comprends pas... Sous Composer je la vois bien mais pas sur le site.
Et je voudrais savoir, comment insérer dans cette image, d'autres images ou bouton contenant des liens (On clique sur le bouton "Galerie" pour aller à la galerie par exemple)
  • Commenter cette réponse |
Score
0
òh
òi
|
Je ne comprends pas la question. Merci d'expliciter.

Avec un éditeur graphique, tu vas créer un fichier (ou un ensemble de fichiers) qu'il faudra transférer ensuite avec ton client FTP.
  • Commenter cette réponse |
Score
0
òh
òi
|
Je n'arrive pas à m'en passer de majuscules xD
Mais avec un simple editeur graphique, je peux "fabriquer" ma page d'index, puis la retrouver directement le codage à mettre dans le fichier "index" de mon FTP?
  • Commenter cette réponse |
Score
0
òh
òi
|
Tu. As. Raison. OmaR :D 
  • Commenter cette réponse |
Score
0
òh
òi
, Modérateur |
Tu sais aussi qu'il n'y a que les phrases qui commencent par une majuscule, pas tous les mots...
  • Commenter cette réponse |
Score
0
òh
òi
|
Pour la page "simple", il te suffit soit de te mettre un peu au html (http://www.siteduzero.com/tutoriel-3-13666-apprenez-a-c...) soit de prendre un éditeur graphique (http://www.kompozer.net/ par exemple) et de la faire.

Pour y intégrer des images de ta galerie, c'est un peu plus dur si tu veux que ce soit dynamique (par exemple les dernières images, les plus vues, ...) et il te faudra du PHP.
  • Commenter cette réponse |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS