Se connecter / S'enregistrer

Résolu Aux experts Drupal... I need you !

Solutions (12)
Tags :
  • default
  • Programmation
, Helper en formation |
Bonjour,

Je craque complètement avec un site que j'ai à mettre en ligne dans les jours qui viennent et où rien ne se passe "comme d'hab'" (enfin je ne suis pas si habituée que ça mais j'ai passé ma BdD et mon dossier à un ami qui en déjà installé plus d'un et il ne semble pas y piger plus :cry:  )
- En localhost : impossible d'ajouter un module, j'obtiens une "fatal error" 9 fois sur 10
- Si j'ai le malheur de jouer sur le thème via l'administration du site, cela me crée un nouveau dossier dans sites\default\color et mon style.css qui devrait normalement se trouver dans "monsite"\sites\all\themes se retrouve chaque fois dans un nouveau dossier qui se crée automatiquement sous "monsite"\sites\default\files....
- Je n'ai toujours pas trouvé quel fichier php modifier, mais ça c'est l'objet d'un autre topic

Au secours ! :whistle: 

Merci [:mary]
Contenus similaires
Meilleure solution
partage
|
Tu dis que ces derniers jours cela fonctionnait "normalement", est ce qu'entre ces derniers jours, et à partir du moment ou tu as ces "gros" problèmes de lenteurs tu as installé quoi que ce soit ou touché a un paramètre quelquonque ? (activation de CCK entre temps?)

Je pense que tu ne va pas avoir le choix, c'est à dire, repartir entirement de zéro !
1) réinstallation complete de drupal (sur ovh) sans rien de plus
2) tu regardes si tes lenteurs sont présente ou pas (logiquement non)
3) active/désactive quelque modules DEJA existant à drupal afin de faire des test à la con mais qui te certifiront que tout fonctionne bien.
4) parmis les modules que tu veux ajouté (dont ton CCK), tu les ajoutes un à un sur l'hébergement et tu les active également un à un afin de voir lequel foire.
5) si l'un foire, fait une recherche sur le net concernant ce module afin de voir si il n'existe pas un bug pour une version X de php/sql, version de drupal etc, parfois tu as des petits correctifs qui sont publié (une ligne ou deux à remplacer peut suffir)
6) si c'est reelement un module qui merde grave et que tu ne trouve aucune solution pour parer à ce probleme, tu n'aura pas d'autre choix que de ne pas l'intégrer malheuresement pour le moment ...et t'etre qu'a un moment, sans forcement chercher tu trouvera la solution ;) 
7) il ce peut aussi que ce soit une incompatibilité entre deux modules une fois activé, c'est déja arriver sur d'autre portail (phpbb, phpnuke ...)
  • Commenter cette solution |
Score
0
òh
òi
, Modérateur |
Edyr a dit :
Ça résoudra peut être pas le problème mais c'est une épreuve nécessaire pour être un développeur productif et bien dans sa tête :D 

Euh... :pt1cable: 
  • Commenter cette réponse |
Score
0
òh
òi
|
Ça résoudra peut être pas le problème mais c'est une épreuve nécessaire pour être un développeur productif et bien dans sa tête :D 
  • Commenter cette réponse |
Score
0
òh
òi
|
Ovh tourne sur linux pour l'hébergement mutualisé, donc cela ne résoudra rien, et dans ces conditions changer d'os n'apportera rien non plus vu qu'il s'agit d'un probleme de script, enfin bon, bon courage car j'ai plus vraiment de proposition à t'apporter :( 
  • Commenter cette réponse |
Score
0
òh
òi
, Helper en formation |
Meilleure réponse sélectionnée par TCM@IDN.
  • Commenter cette réponse |
Score
0
òh
òi
, Helper en formation |
Merci merci !

Dsl Okinou, je n'avais même pas vu ce message et ta gentille proposition du 28 avant de me faire relancer pour sélectionner une meilleure réponse (?!)

Au niveau des modules, un copain a testé et ne retrouve pas du tout les mêmes problèmes que moi. J'en conclue donc que ça vient de ma bécane :cry:  Sauf qu'en direct sur OVH, je reproduis les mêmes problèmes re- :cry: 

Aux dernières nouvelles, on m'a conseillé... d'essayer sous Linux :ange: 
C'est ce que je fais (au moins ; depuis le temps que je disais que j'allais me mettre à Linux, ce sera fait= messages à foison à prévoir dans cette section, noob que je suis ! ;)  )

Je sélectionne toujours une "meilleure réponse" même si ce n'est pas si résolu que ça et garde sous le coude ta proposition de l'avant-dernier post "au cas où"

Encore merci
  • Commenter cette réponse |
Score
0
òh
òi
|
envoi moi un mp avec l'adresse quand tu aura envoyé ton site local vers ovh afin que j'y jette un oeil si une idée de génie me vient.
  • Commenter cette réponse |
Score
0
òh
òi
, Helper en formation |
Yeah, avec tout ça :D 


Alors 1 et 2 pas encore essayé : jusqu'à ces derniers jours ça fonctionnait "normalement" et comme je ne suis pas pro, ça m'embête un peu d'aller trifouiller dans le php conf & cie

Pour le 3, j'avais essayé. J'ai pensé que c'était un module appelé CCK qui bloquait. Et jusqu'à preuve du contraire, il bloque effectivement (il correspond à une dizaine de sous-modules à activer, ce peut être ça) mais, en même temps, je l'avais déjà utilisé sur un autre site et c'est un "incontournable" :/ 

4 - Bonne idée, je suis en train d'essayer (sur OVH)

5 et 6 - message passé sur drupalfr. J'essairai Développez.com s'il n'y a pas de suite

7 - Ma foi... Je commence à y songer :( 

8 - C'est déjà pas mal !!

et pour le ps ; c'est essentiellement sur les modules mais pas uniquement. Simplement quand ça se produit sur un autre "domaine", il suffit de rafraichir la page pour que ça passe (sur les modules, je peux rafraichir 10 fois en vain)

Voili-voiloù. Encore merci pour toutes ces pistes.

La question reste ouverte et je vous tiens évidemment au courant des avancées


  • Commenter cette réponse |
Score
0
òh
òi
|
Maximum execution time of 30 seconds exceeded in

Bon bah voila, premier constat de cette erreur :

1) soit tu augmente le temps d'éxécution de php via le php.conf
2) soit tu rajoute un ini_set avec une valeur de max_execution_time afin de faire comme la premiere suggestion sans touché au config de php afin d'avoir un temps d'éxécution plus long, mais aucune de ces 2 solution n'est top car si un script met plus de 30s à s'éxécuter c'est que quelque chose cafouille assez sévèrement du style une boucle qui boucle à l'infini et qui creer un timeout (une cause parmis bien d'autre possible)

donc 3) :
comme je te l'ai déja dit, je ne connais pas du tout drupal, cependant comme beaucoup de CMS, il doit y 'avoir des modules que tu as activer ou que tu as ajouté, pour trouver la cause de se ralentissement et de ce timeout, tu désactive tout les module/plugin que tu peut et tu fais les test un à un pour voir de qu'elle partie cela peut bloquer.

4) à tout hasard, si tu possède un hébergement mutualisé chez un hébergeur style ovh, maven ... berf un hébergeur performant, envoie ton drupal en ligne afin de vérifier si le probleme vient bien du script/plugin/module et non pas d'un probleme local avec ton serveur personnel (easyphp/wamp ...) à tout hasard, mais de cette façon tu en aura le coeur net.

5) comme la suggérer edyr, essaie de trouver des forums spécialisé drupal notament le site officiel qui doit avoir sa communauté.

6) si tu ne l'a pas déja fait, essai le site developpez.com tu as de très nombreux forum et expert de dev qui sont top.

enfin, en 7) change de CMS pour le moment :p 

et 8) j'ai plus d'idée

ps: l'error fatal du timeout se produit uniquement sur l'activation d'un module ? tu arrive à surfer normalement dans le CMS en dehors de ça ? (module actif, zone d'admin, zone membre ?) si oui, c'est le script php qui gère l'activation des modules qui cafouille grave.
  • Commenter cette réponse |
Score
0
òh
òi
, Helper en formation |
Merci à vous deux déjà, tant que quelqu'un répond, j'essaie de ne pas désespérer !

okinou a dit :
pour ton premier probleme, quel est l'erreur complete retourné avec le "fatal error" ?

Citation :
Fatal error: Maximum execution time of 30 seconds exceeded in C:\wamp\www\***\includes\file.inc on line 922

Je ne jurerais pas que c'est systématiquement la même ligne, mais dans 90% des cas, oui.

Edyr a dit :
Après un "Au secours!" je ne peux pas m'empêcher d'intervenir!
C'est super sympa ; comme indiqué, ça aide à ne pas baisser les bras !

Edyr a dit :
Même si je ne connais pas trop Drupal, je pense que tu trouveras les experts qu'il te faut sur http://drupalfr.org/forum :D 
Moui... Sont bien moins présents qu'ici les "experts" en question :/  mais tu as raison, il faut que j'essaie tout
  • Commenter cette réponse |
Score
0
òh
òi
|
Bonjour!

Après un "Au secours!" je ne peux pas m'empêcher d'intervenir!
Même si je ne connais pas trop Drupal, je pense que tu trouveras les experts qu'il te faut sur http://drupalfr.org/forum :D 
  • Commenter cette réponse |
Score
0
òh
òi
|
pour ton premier probleme, quel est l'erreur complete retourné avec le "fatal error" ?
  • Commenter cette réponse |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS