Votre question

linux a l'école

Tags :
  • linux
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
21 Février 2008 14:16:15

À mon école j'ai linux et j'aimerai changer le theme de ma session.
J'ai un dossier avec des themes par défo qui s'appelle .icewm tout les themes sont dedans mais je ne sais pas comment les activer.pour qu'ils soit dans mes applications favorites (le menu démarer) et que je puisse les utiliser.

Pouriez-vous me dire comment faire svp ?

merci

Autres pages sur : linux ecole

21 Février 2008 16:23:19

il faut d'abord savoir de quel "linux" il s'agit.

Ensuite il faut savoir si tu as besoin des droits d'admin pour le faire.
21 Février 2008 16:32:45

Pas besoin de savoir quelle distrib c'est, on voit bien qu'il utilise icewm.
De plus, si il est sur sa session, il peux modifier les fichiers cachés de son répertoire perso.

Donc:
  1. cd ~/.icewm && mkdir themes
ensuite il te suffit de télécharger l'archive du thème, et de l'extraire dedans.
Contenus similaires
21 Février 2008 16:37:55

Tu lui parles chinois là.

Il sais probablement même pas où il doit écrire ca.

Christo, créées un dossier nommé themes dans le .icewm, puis télécharges un thème sur internet et colles-le (où décompresses-le) dans ce dossier themes. Ensuite, pour utiliser ce thème il faut aller dans le panneau de personalisation d'IceWM mais là je ne me souviens plus du chemin...
21 Février 2008 16:51:59

Kwales6, il suffit que l'admin ai décidé de protéger les fichiers cachés voir même tout le contenu de home et il ne pourra rien faire!

Donc il faut plutôt s'adresser à son administrateur système avant d'essayer de trifouiller!
21 Février 2008 17:59:00

en théorie, la config par défaut d'icewm est d'afficher la liste des thèmes dans menu->paramètres->thème
21 Février 2008 22:06:10

les themes son déja dedans il faut juste que je les activent mais je sais pas comment.
21 Février 2008 22:23:27

ChristoBlonde a dit :
les themes son déja dedans
dans le menu?
si c'est le cas, il suffit d'en séléctionner un!
22 Février 2008 01:28:12

Est-ce que ca se peut dans buefish editor ? Je veu dire ouvrir le theme avec ?
22 Février 2008 11:01:37

bluefish plutot :) 
les répertoire de thème ne sont en fait qu'un fichier de description (default.theme je crois) + des fichier images donc tu peux ouvrir le fichier de description avec n'importe quel éditeur de texte
22 Février 2008 14:34:46

quelqu'un ma dit qu'il fallait ouvrir le fichier avec bluefish et mettre des 1 à la place des 0

voici quelle genre de de message il y a dans bluefish :

# Focus windows by clicking
# ClickToFocus=1 # 0/1

# Raise windows when focused
# RaiseOnFocus=1 # 0/1
22 Février 2008 14:52:52

je sais pas pour les autres, mais la je suis perdu...
le theme se charge??

pour les 0/1, je vois ce que tu veux faire avec, c'est du parametrage:
"ClickToFocus" => cliquer sur la fenetre pour la rendre active (oui/non)
"RaiseOnFocus" => mettre la fenetre au premier plan quand elle est active
22 Février 2008 18:36:41

SI C'EST VRAI ce que cette personne ma dit ces qu'il faut mettre un 1 ou un 0 pour les activés mais je ne sai pas ou il faut mettre le 0.
22 Février 2008 18:44:53

0 normalement tu dois pas en mettre, 0 veut souvent dire "non"
22 Février 2008 18:50:32

tass@IDN a dit :
0 normalement tu dois pas en mettre
ben ca dépend, si tu veux avoir le survol au lieu du clic pour le focus, tu mets 0!
22 Février 2008 18:54:38

Oui c'est vrai ca dépend des options. Mais bon, en général :whistle: 
22 Février 2008 22:40:16

Mais je sai pas ou mettre le 1 .
Et-ce que vous avez une idée ?
22 Février 2008 23:00:37

IceWM peut être configuré via des fichiers texte situés dans le répertoire utilisateur, ce qui facilite la personnalisation.

http://www.linuxpedia.fr/doku.php/icewm

Je viens de trouver une piste , il faut que jaille configurer icewm dans bluefish . Et dans bluefish il y a les 1 et les 0 que je parlais mais le problème c'est quelle 0 il faut que je mette 1 .

Pouvez-vous me dire quelle option je dois mettre a 1 ?
23 Février 2008 00:01:42

il y a un problème de communication...
le fichier ou tu peux mettre des 1 et des 0 ne sert que pour la configuration des options de icewm, ca n'influe pas sur la prise en compte du thème.
ta 1ere question était: "comment activer un thème?" (en tout cas, c'est comme ca que je l'ai comprise), est ce que tu as fini par l'activer?

pour la partie personnalisation (les 0 et 1) tu peux mettre ce que tu veux, je m'explique:
- prenons le paramètre "ClickToFocus".
- si tu lui mets "1": tu as un comportement comme sur la plupart des wm par défaut, il faut cliquer sur la fenetre pour la rendre active.
- si tu lui mets "0": tu as un comportement à l'ancienne (enfin ca dépend des gens), il suffit de passer la souris sur la fenetre pour la rendre active.

11 Mars 2008 01:12:46

Finalement j'ai pas trouver
11 Mars 2008 12:06:21

Kwales68 a dit :
Pas besoin de savoir quelle distrib c'est, on voit bien qu'il utilise icewm.
De plus, si il est sur sa session, il peux modifier les fichiers cachés de son répertoire perso.

Donc:
  1. cd ~/.icewm && mkdir themes
ensuite il te suffit de télécharger l'archive du thème, et de l'extraire dedans.


Donc la je tape le code dans la console ET après ?

merci d'avance
11 Mars 2008 12:46:57

Citation :
ensuite il te suffit de télécharger l'archive du thème, et de l'extraire dedans.
11 Mars 2008 17:30:10

Bon le fichier themes est déja dedans il faut juste l'activer et je ne sai pas comment ?

merci d'avance
11 Mars 2008 22:02:08

il n'y a pas d'activation dans icewm, les thèmes sont listés dans le menu, si tu ne l'as pas, c'est que ton thème n'est pas bon (il doit avoir au minimum un fichier default.theme)
12 Mars 2008 17:59:08

Je telecharge un theme http://themes.freshmeat.net/browse/924/ firefox dit que ca se telecharge sur le disque mais je sais pas ces ou et meme si je telecharge ca ca ne regle pas mon problème que l'option themes ne se retrouve jamais dans le menu demarer (aplications favorite),

Pouvez-vous m'aider ?

merci d'avance.
12 Mars 2008 18:13:19

en fait, je me demande meme si tu es sur linux, c'est un ordi? :p 

tu as les thèmes, tu les as plus,
tu télécharges mais tu sais pas ce qu'il y a à faire après,
maintenant, tu ne sais meme plus si ca s'est téléchargé ou pas
les thèmes n'ont jamais été dans la menu après y avoir été
"applications favorites", je vois même pas c'est quoi, ce n'est pas sur le menu par défaut de icewm

bref, une capture d'écran, un copie/coller de commande que tu essais, la liste de ce qui existe vraiment dans ton répertoire ~/.icewm, ca peut aider, sinon, faut être un minimum cohérent dans ce que tu dis!
12 Mars 2008 21:52:51

ChristoBlonde a dit :
on repar de zero Je telecharge un theme http://themes.freshmeat.net/browse/924/ firefox dit que ca se telecharge sur le disque mais je sais pas ces ou et meme si je telecharge ca ca ne regle pas mon problème que l'option themes ne se retrouve jamais dans le menu demarer (aplications favorite),

Pouvez-vous m'aider ?

merci d'avance.


12 Mars 2008 22:37:24

et tu télécharges quoi exactement, la page que tu donnes liste aussi bien les thèmes que les pack d'icones ou autre.

et c'est quoi applications favorites ?
14 Mars 2008 13:09:08

1-je telecharge le deuxième bluecrux

2-menu demarer

détails:quand je clique sur telecharge firefox me donne l'option
ouvrir avec,
enregister sur le disque(qui est déja cocher,

merci d'avance
14 Mars 2008 13:10:36

comme j'ai dit plus haut quand je telecharge sur le disque je ne sais pas c'est ou .
14 Mars 2008 13:31:53

Salut,

Pour Firefox Menu- Edition -> Préférences:
Onglet Général (Téléchargements).

Ici tu peux voir et choisir l'emplacement de sauvegarde de tes téléchargement.
L'idéal étant de cocher "Toujours demander où enregistrer les fichiers".


14 Mars 2008 15:08:16

tu fumes avant de poster?? :D 
il n'y a pas de bluecrux sur la page que tu donnes!


mkdir -p ~/.icewm/themes
cd ~/.icewm/themes
wget http://download.freshmeat.net/themes/bluecrux/bluecrux-default-1.1.tar.gz
tar zxvf bluecrux-default-1.1.tar.gz
rm bluecrux-default-1.1.tar.gz
echo 'Theme="blueCrux/default.theme"' > ~/.icewm/theme

et tu redémarres icewm
14 Mars 2008 17:31:51

Si t'aime mieux kubical numéro 8
14 Mars 2008 17:35:11

n°9 mais peu importe, j'ai l'habitude maintenant...
12 Juin 2008 23:03:26

J'ai réussi finalement !

Tout seul :na:  lol

Il fallait aller dans le fichier .icewm et dans celui si dans preferences ensuite dans l'éditeur de texte bluefish mettre showThemesmenu=1 redémarrer icewm dans déconnexion et l'option thèmes apparait dans application favorites et le tour est joué !!!

:pt1cable: 

Et merci pour vos réponses même si ça fait longtemps.
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS