Se connecter / S'enregistrer
Votre question

[PHP] Probleme WAMP 5

Tags :
  • Wamp
  • Programmation
Dernière réponse : dans Programmation
9 Juillet 2006 15:52:27

Voila,
Je vien d'installer easyphp sur ma machine et tout c'est bien derouler ...
Je vien de mettre sur easy php un de mes site que je suis en train de dévvellopé.
Avant je developait ce site sur free et sa marchait tres bien
Depuis que j'ai mis ce site sur Easy php j'ai des erreur de variable ...
savez vous a quoi c'est du ?
Peut etre a la version de PHP ?
Avez vous une solution ?

Merci d'avance

Autres pages sur : php probleme wamp

9 Juillet 2006 15:54:24

Tu utilise Easy PhP pour un site Online ?
9 Juillet 2006 15:55:06

Non pour dévelloper mon site en intranet
Contenus similaires
9 Juillet 2006 16:06:11

Moi aussi avec EasyPhp j'avait plein d'erreurs j'ai éssayé Wamp5 et la pouf plus d'erreurs !
Wamp5 sur Infos-Du-Net
9 Juillet 2006 16:07:00

OK je vai essyer merci
9 Juillet 2006 16:26:52

Je vien de l'installer et quand j'affiche ma page il n'y a que tu HTML tout le code php n'est pas traiter
une solution ?
9 Juillet 2006 16:35:55

Vos erreurs de variable ne sont pas causées par easyPHP ou WAMP à coup sur.

Vous devez être habitués au register_global qui "transforme" vos variables POST et GET en simple variable. Dans les version de récente de PHP cette option register_global est à off ce qui signifie que par exemple pour accéder à une variable transmise par un formulaire via la méthode POST, il faut utiliser le tableau associatif $_POST, pareil pour la méthode GET : $_GET, pour les fichier par méthode PUT : $_FILES, ...
9 Juillet 2006 16:43:44

Sur wamp je n'ai plus d'erreurs de variables :-)
Mais :-(
Tout le php qui est dans ma page n'est pas traiter....
Ja page que tu m'a donner ne regle malheuresement pas mon probleme
9 Juillet 2006 16:47:59

Citation :
Sur wamp je n'ai plus d'erreurs de variables
Mais
Tout le php qui est dans ma page n'est pas traiter....


C'est peut être parce que ton PHP n'est pas interprété que tes erreurs ont disparues. Parce que à ma connaissance, WAMP5 utilise PHP5 qui est configuré par défaut avec register_global=off.
9 Juillet 2006 16:50:24

En effet j'ai :
register_globals Off

Mais comment le mettre sur ON ?
9 Juillet 2006 16:52:26

J'ai mis sur on dans la configuratuion de php mais je n'ai aucun resultat
9 Juillet 2006 17:55:22

J'ai pris un screen shot pour que vous puissiez voir :
9 Juillet 2006 23:30:29

Personne ne peut m'aider ?
10 Juillet 2006 13:55:55

Help me ;-)
10 Juillet 2006 14:33:47

Sa ne sert a rien de poster des "help me", "aidez moi svp", ...c'est pas comme sa que tu vas attirer les réponses.

Tu a mis register_global à ON ok mais sache que ce n'est pas une bonne chose car cette option va certainement disparaitre un jour. Habitue toi plutôt à utiliser la manière propre : $_POST['nomVaraible'], $_GET['nomVariable'], ...

Ensuite, pou ton problème de PHP qui n'est pas interprété, je ne vois pas d'où sa peut venir. WAMP est un très bon package qui fonctionne habituellement très bien, peut être une erreur de ta part dans tes pages, tes extensions, ... ?

[EDIT] J'ai trouvé ton problème : utilise les balises <?php ?> et non pas <? ?> qui sont désactiver par défaut dans les vcersions 5 de PHP. Faudrait, à mon avis, que tu lise un peu de doc sur comment coder proprement en PHP (sans être méchant, c'est juste un conseil) car tes applications fonctionneront surement sur un serveur mais peyt être pas sur un autre. Tu as pu en faire l'expèrience.
10 Juillet 2006 14:56:30

OK je vai essayer merci de tes conseil :-)
Ps: Help me etait une facon de fire un UP :-)
Juste pour savoir est-il possible de remetre <? ?> ?
10 Juillet 2006 15:12:14

Citation :
Ps: Help me etait une facon de fire un UP


Encore pire, je trouve que ces message "UP" c'est la pire connerie du monde!!! (excusez moi pour l'expression)

Citation :
uste pour savoir est-il possible de remetre <? ?> ?


Oui tu peux les remettre en activnat les short tag mais encore une fois ce n'est pa une manière propre de coder en PHP. Vaut meiux perdre quelque minutes à remplacer les <? par <?php que de voir ses script ne pas fonctionner sur certains serveur (ceux où tu n'auras pas accès à la config).
10 Juillet 2006 15:15:09

Ok je vai suivre tes conseil
Je te remercie de tes reponces
@ bientot
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS