Se connecter / S'enregistrer
Votre question

utilisation de fichier .htaccess

Tags :
  • Blog
  • Programmation
Dernière réponse : dans Programmation
1 Mars 2005 08:55:45

bonjour,
j'ai un probleme avec l'utilisation du fichier .htaccess .

en effet, je souhaiterai juste cacher l'acces a l'arborescence des mes fichiers sur mon site chez free.

Or en rentrant un .htaccess , ça bloque aussi l'acces aux fichiers qui sont dedans si on a pas le code.
Comme j'utilise certains fichiers sur un blog, le blog se retrouve amputé des fichiers. Bref je veux juste que les gens qui visitent le blog, n'aient pas acces a l'arborescence.

voila ce que j'ai mis dans mon fichier .htaccess :

PerlSetVar AuthFile secret/pass
AuthName "Acces Restreint"
AuthType Basic
<limit GET POST>
require valid-user
</limit>

merci d'avance.

Autres pages sur : utilisation fichier htaccess

1 Mars 2005 09:04:19

Pour éviter que les personnes ne voient l'arborescence, place tout betement une page index.htm vide dans chaque répertoire ;-)
1 Mars 2005 09:28:33

en utilisant
  1. options -indexes
tu peux aussi y arriver.

quelques info ici
Contenus similaires
28 Octobre 2005 22:47:49

encore plus étrange pour moi :

j'ai déjà fait des fichiers .htaccess et ca marchais mais j'ai fait un autre site web et j'ai échangé mon internet exploreur contre firefox et depuis ca marche plus !!! alors j'ai retenté avec internet exploreur idem.

alors voici ma programmation :

>securite
-->motdepass
---->motsdepass.txt ( oui il y a bien un s de plus donc "mots" et pas "mot" et la seul ligne de code est "admin:1234" sans espace ni validation de ligne )
---->.htaccess ( deny from all )
-->prive
---->pagemembre.html
---->.htaccess ( qui contient les codes suivants :

PerlSetVar AuthFile securite/motdepass/motsdepass.txt
AuthName "Acces Restreint"
AuthType Basic
require valid-user


alors svp dites moi où je me suis trompé svp car j'ai bien fait le transfert de fichiers en mode ASCII. alors je commence à m'arracher les cheveux et je vais vite finir chauve à ce rythme là ! :-(

merci à tous
30 Octobre 2005 01:16:33

toujours pas de réponse ?

Citation :

ketrarde a écrit :
encore plus étrange pour moi :

j'ai déjà fait des fichiers .htaccess et ca marchais mais j'ai fait un autre site web et j'ai échangé mon internet exploreur contre firefox et depuis ca marche plus !!! alors j'ai retenté avec internet exploreur idem.

alors voici ma programmation :

>securite
-->motdepass
---->motsdepass.txt ( oui il y a bien un s de plus donc "mots" et pas "mot" et la seul ligne de code est "admin:1234" sans espace ni validation de ligne )
---->.htaccess ( deny from all )
-->prive
---->pagemembre.html
---->.htaccess ( qui contient les codes suivants :

PerlSetVar AuthFile securite/motdepass/motsdepass.txt
AuthName "Acces Restreint"
AuthType Basic
require valid-user


alors svp dites moi où je me suis trompé svp car j'ai bien fait le transfert de fichiers en mode ASCII. alors je commence à m'arracher les cheveux et je vais vite finir chauve à ce rythme là ! :-(

merci à tous
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS