Se connecter / S'enregistrer

Résolu Probleme site internet

Solutions (26)
Tags :
  • Google Chrome
  • Sites Internet
  • Programmation
|
Voila depuis hier j'ai un probleme avec mon site internet,

C'est un jeu en reseau et ça bug sur une certaine pages

Quand j'ouvre ma page avec google Chrome sa marche bien, mais avec firefox et IE, rien ne marche cette page bloquent...

quand je me connecte avec mon site apres j'ai le droit a une pages toute blanche avec rien ecrit dessus,

Je pense que cela peut venir de l'hebergeur, je suis chez lws.fr j'ai un forfait basic...

Voila je peut vous donnez ma page qui bloquent c'est

http://lordofgame.fr/frames.php

Je vous donne le fichier : de mon site, si vous voyez une erreur dite le moi,

<?php

/**
* frame.php
*
* @version 1.0
* @copyright 2008 by e-Zobar for XNova
*/

define('INSIDE' , true);
define('INSTALL' , false);

$InLogin = false;

$XNova_Host = $_SERVER['HTTP_HOST'];
$XNova_Script = $_SERVER['SCRIPT_NAME'];
$Uri_Array = explode ('/', $XNova_Script);
// On vire le script
array_pop($Uri_Array);
$XNova_URI = implode ('/', $Uri_Array);

$XNovaRootURL = "http://". $XNova_Host ."/". $XNova_URI ."/";

$ugamela_root_path = './';
include($ugamela_root_path . 'extension.inc');
include($ugamela_root_path . 'common.'.$phpEx);

$page = "<html>";
$page .= "<head>";
$page .= "<meta http-equiv=\"Content-Type\" content=\"text/html;charset=". $langInfos['ENCODING']."\">";
$page .= "<link rel=\"shortcut icon\" href=\"favicon.ico\">";
$page .= "<title>". $game_config['game_name'] ."</title>";
$page .= "</head>";

$page .= "<frameset framespacing=\"0\" border=\"0\" cols=\"190,*\" frameborder=\"0\">";
$page .= "<body>";
$page .= "<frame name=\"LeftMenu\" target=\"Mainframe\" src=\"leftmenu.php\" noresize scrolling=\"no\" marginwidth=\"0\" marginheight=\"0\">";
$page .= "<frame name=\"Hauptframe\" src=\"overview.php\">";
$page .= "<noframes>";
$page .= "<p>". $lang['NoFrames']."</p>";
$page .= "</noframes>";
$page .= "</frameset>";

$page .= "</body>";
$page .= "</html>";

echo $page;

// -----------------------------------------------------------------------------------------------------------
// History version
// 1.0 - Euuhh ... je ne sais plus ...
?>


Merci a tous et bonne nuit


Contenus similaires
Meilleure solution
partage
|
Un petit point sur ce topic...

Il semblerait que le pb viennent de l'encodage des fichiers modifiés par le notepad windows (???)

Trouvé sur www :
"Cette erreur apparait lorsque vous modifiez un fichier avec le bloc note. Vous devez modifier vos fichiers à l'aide du logiciel Notepad++, qui fonctionne comme le bloc note mais évite des problèmes d'encodage."

Après avoir contacté baptiste59, une réinstallation en local puis transfert ftp des fichiers ont réglé l'histoire d'affichage de la page frames.php
  • Commenter cette solution |
Score
0
òh
òi
|
Je suis parti faire un tour sur ton site :

1. Enlève tes adresses mails !! On t'as déjà dit qu'il existe des moteurs de recherche automatiques qui récupèrent ça pour te spamer tes boites ;

2. Je vois toujour pas pourquoi tu utilise des frames : petit historique :
les frames ont été inventés par Netscape (4 je crois) et ont révolutionné le web : ils permettent d'actualiser une seule partie de la page => moins de poids de téléchargement pour l'utilisateur, moins de trafic pour l'hébergeur, tous le monde il était content ^^ . Cela permettait d'économisé du transfert de part et d'autre génial ! On avait des connexions 56k, avec un forfait 40 heures/mois, 100 heures/mois pour les riches ............ M'enfin c'est quoi ton forfait actuel ? Il existe encore des offres limités ? L'objectif à l'époque était de faire des pages qui ne dépassaient pas le 90 Ko, Ton images de fond fait 60 ko ....

3. En utilisant des frames, les personnes ne pourront pas allez sur ton site avec leur téléphone portable avec Opéra Mini installé dessus ... C'est balot ...

4. Indente ton code, c'est pour toi que je dit ça : ça va permettre te t'y retrouvé plus facilement, le code sera plus clair.

5. J'ai vu dans les commentaires précédent que tu mettais la variable d'erreur php sur All : ne fait JAMAIS ça sur un site en ligne, tu vas le perdre ton site ...
On utilise cette configuration uniquement en développement LOCAL.

6. Les textes sur ta pages d'accueil sont limites lisible, choisi une autre couleur, met en gras ou met le fond en transparent (opacity 30%) pour que l'on puisse lire ce qui est mis.
De plus tu utilise des couleurs différentes au niveau des textes ;ça fait un peu carnaval, et pas du tout propre ; Tu as plein d'exmple de site à travers le web, inspire toi d'eux, et pose toi la question du comment qu'ils ont fait pour avoir un bon résultat visuel ; On est certe pas tous des infographistes mais cela n'empèche pas le fait que tu puisses avoir quelquechose de plus propre que ce que tu as pour le moment.

7. Va sur les sites que je t'ai cité, apprend à faire un site internet correctement : au vu de tes objectifs, c'est vraiment pas bon pour toi de partir sur des bases aussi ... légères : plus tu va avancé dans ton projet et plus tu va avoir du mal ; Si on ajoute à ça le fait que tu ne maîtrise pas du tout ce que tu fais ... galère galère.

Voilà encore une fois bon courage.
  • Commenter cette réponse |
Score
0
òh
òi
|
Bonjour/Bonsoir,

Je n'est pas testé ton site mais une petite remarque : va faire un petit tour sur le site du zéro , et lit un peu les tutos sur le xhtml : c'est la norme utilisé par tous les navigateurs modernes suivant les recommandations du W3C .

Petites astuces pour le développement en php : je reprend juste une partie de ton code :

  1. // ( ... ) blablabla le code avant ( ... )
  2.  
  3. $XNovaRootURL = "http://". $XNova_Host ."/". $XNova_URI ."/" ;
  4. // Utilise la cote simple ' à la place de la cote double " si tu as un contenu sans variable
  5. // avec " PHP recherche dabord s'il n'a pas une variable à interpréter
  6. // avec ' PHP écrit sans traitement supplémentaire
  7.  
  8. $ugamela_root_path = './' ;
  9.  
  10. // On utilise include_once si le fichier ne sera utilisé qu'une fois histoire de pas en avoir 36 qui foutes le bordel
  11. include_once($ugamela_root_path . 'extension.inc') ;
  12. include_once($ugamela_root_path . 'common.'.$phpEx) ;
  13.  
  14. // Ici je passe à la partie html, plus besoin du php de manière direct
  15. // Si on a besoin de mettre du php on l'inserre avec <?= qui pourrais signifié écrit ça
  16. ?>
  17. <html>
  18. <head>
  19. <meta http-equiv="Content-Type" content="text/html;charset="<?= $langInfos['ENCODING'] ?> \>
  20. <link rel="shortcut icon" href="favicon.ico" />
  21. <title><?= $game_config['game_name'] ?></title>
  22. </head>
  23.  
  24. <!-- ( ... ) blablabla ( ... ) -->
  25.  
  26. <?php
  27. /*
  28. * Là on reprend en php
  29. * mais on a plus besoin de faire écrire la variable $page
  30. */
  31. // echo $page;
  32.  
  33. // -----------------------------------------------------------------------------------------------------------
  34. // History version
  35. // 1.0 - Euuhh ... je ne sais plus ...
  36. ?>

Je te jète pas la pierre mais on n'utilise plus les frames de nos jours ... si tu en a vraiment besoin pourquoi pas ...

Je te recommenderais également une autre référence incontournable : un tuto figurant sur le site d'AlsaCréation

Voilà, bon courage
  • Commenter cette réponse |
Score
0
òh
òi
|
flo_974 a dit :
Il semblerait que le pb viennent de l'encodage des fichiers modifiés par le notepad windows (???)
Trouvé sur www :
"Cette erreur apparait lorsque vous modifiez un fichier avec le bloc note. Vous devez modifier vos fichiers à l'aide du logiciel Notepad++, qui fonctionne comme le bloc note mais évite des problèmes d'encodage."

Bien vu.
N'utilisant jamais Notepad, je n'y aurai pas pensé.

  • Commenter cette réponse |
Score
0
òh
òi
|
Bonsoir,


Problème relger

Je crois que je peux remercier flo_974 !!

Qui a fait tout simplement un travail genial !

Merci a tous !


Bapt :) 
  • Commenter cette réponse |
Score
0
òh
òi
|
<?php

/**
* frame.php
*
* @version 1.0
* @copyright 2008 by e-Zobar for XNova
*/

define('INSIDE' , true);
define('INSTALL' , false);

$InLogin = false;

$XNova_Host = $_SERVER['HTTP_HOST'];
$XNova_Script = $_SERVER['SCRIPT_NAME'];
$Uri_Array = explode ('/', $XNova_Script);
// On vire le script
array_pop($Uri_Array);
$XNova_URI = implode ('/', $Uri_Array);

$XNovaRootURL = "http://". $XNova_Host ."/". $XNova_URI ."/";

$ugamela_root_path = './';
include($ugamela_root_path . 'extension.inc');
include($ugamela_root_path . 'common.'.$phpEx);

$page = "<html>";
$page .= "<head>";
$page .= "<meta http-equiv=\"Content-Type\" content=\"text/html;charset=". $langInfos['ENCODING']."\">";
$page .= "<link rel=\"shortcut icon\" href=\"favicon.ico\">";
$page .= "<title>". $game_config['game_name'] ."</title>";
$page .= "</head>";

$page .= "<frameset framespacing=\"0\" border=\"0\" cols=\"190,*\" frameborder=\"0\">";
$page .= "<frame name=\"LeftMenu\" target=\"Mainframe\" src=\"leftmenu.php\" noresize scrolling=\"no\" marginwidth=\"0\" marginheight=\"0\">";
$page .= "<frame name=\"Hauptframe\" src=\"overview.php\">";
$page .= "<noframes>";
$page .= "<body>";
$page .= "<p>". $lang['NoFrames']."</p>";
$page .= "</body>";
$page .= "</noframes>";
$page .= "</frameset>";

$page .= "</html>";

echo $page;

// -----------------------------------------------------------------------------------------------------------
// History version
// 1.0 - Euuhh ... je ne sais plus ...
?>
  • Commenter cette réponse |
Score
0
òh
òi
|
J'ai fait un sujet parralèle crazycat@idn,

Peut être que ça t'aidera, http://board.xnova-ng.org/index.php?showtopic=1233&pid=...
  • Commenter cette réponse |
Score
0
òh
òi
|
Je pense que cela viens de mon hebergeur ? Non?

Pck avant ça tourné nikel ...

Edit, J'ai essaye ton code effectivement j'ai change et ça marche merci beaucoup, mais toujour pas sur firefox et ie

Pour mon hebergement je suis chez Lws en formule basic..

Je pense que ça vient de mon hebergeur parce que d'autre personne utilise ses fichier et chez eux sa marche bien..
  • Commenter cette réponse |
Score
0
òh
òi
|
A mon avis, il y a 2 problèmes:
1) j'ai fait une erreur en mettant le code et j'ai mal nommé la frame principale: c'est Hauptframe et non pas Hautframe. Ceci est la raison pour laquelle ça s'ouvre dans une autre fenêtre/un autre onglet
2) ... je ne vois pas, désolé. Ton frameset semble propre, rien ne hurle dans mon firefox, mais ça reste effectivement page blanche. Les frames prises séparément s'affichent bien, je vais creuser un peu, je t'en dirais un peu plus (j'espère) demain.
  • Commenter cette réponse |
Score
0
òh
òi
|
Bon j'ai copier ton texte et ça marche toujours sur google chrome sauf que dés que je clique sur mon menu sa m'ouvre une page,

Et pour Firefox j'ai toujours ses probleme une pages blanche !
  • Commenter cette réponse |
Score
0
òh
òi
|
Mauvaise nouvelle: tes "erreurs" ne sont que des avertissements, rien de vraiment bloquant.
Bonne nouvelle, je pense que c'est juste la génération de ta page qui n'est pas comme il faut:
  1. $page = "<html>";
  2. $page .= "<head>";
  3. $page .= "<meta http-equiv=\"Content-Type\" content=\"text/html;charset=". $langInfos['ENCODING']."\">";
  4. $page .= "<link rel=\"shortcut icon\" href=\"favicon.ico\">";
  5. $page .= "<title>". $game_config['game_name'] ."</title>";
  6. $page .= "</head>";
  7.  
  8. $page .= "<frameset framespacing=\"0\" border=\"0\" cols=\"190,*\" frameborder=\"0\">";
  9. $page .= "<body>";
  10. $page .= "<frame name=\"LeftMenu\" target=\"Mainframe\" src=\"leftmenu.php\" noresize scrolling=\"no\" marginwidth=\"0\" marginheight=\"0\">";
  11. $page .= "<frame name=\"Hauptframe\" src=\"overview.php\">";
  12. $page .= "<noframes>";
  13. $page .= "<p>". $lang['NoFrames']."</p>";
  14. $page .= "</noframes>";
  15. $page .= "</frameset>";
  16.  
  17. $page .= "</body>";
  18. $page .= "</html>";

devrait être (à mon avis):
  1. $page = "<html>";
  2. $page .= "<head>";
  3. $page .= "<meta http-equiv=\"Content-Type\" content=\"text/html;charset=". $langInfos['ENCODING']."\">";
  4. $page .= "<link rel=\"shortcut icon\" href=\"favicon.ico\">";
  5. $page .= "<title>". $game_config['game_name'] ."</title>";
  6. $page .= "</head>";
  7. $page .= "<frameset framespacing=\"0\" border=\"0\" cols=\"190,*\" frameborder=\"0\">";
  8. $page .= "<frame name=\"LeftMenu\" target=\"Mainframe\" src=\"leftmenu.php\" noresize scrolling=\"no\" marginwidth=\"0\" marginheight=\"0\">";
  9. $page .= "<frame name=\"Hautframe\" src=\"overview.php\">";
  10. $page .= "</frameset>";
  11. $page .= "<noframes>";
  12. $page .= "<body>";
  13. $page .= "<p>". $lang['NoFrames']."</p>";
  14. $page .= "</body>";
  15. $page .= "</noframes>";
  16. $page .= "</html>";

  • Commenter cette réponse |
Score
0
òh
òi
|
Notice: Undefined index: lang in /var/www/lordofgame.fr/htdocs/includes/unlocalised.php on line 211

Notice: Undefined index: cp in /var/www/lordofgame.fr/htdocs/includes/functions/SetSelectedPlanet.php on line 13

Notice: Undefined index: re in /var/www/lordofgame.fr/htdocs/includes/functions/SetSelectedPlanet.php on line 14

Notice: Undefined index: NoFrames in /var/www/lordofgame.fr/htdocs/frames.php on line 43


Voila les erreurs je pense que le rapport d'erreur est ceci

Merci de vos reponse c'est super sympa !!

Bapt
  • Commenter cette réponse |
Score
0
òh
òi
|
crazycat@idn a dit :
  1. <?php
  2. ini_set('error_reporting', E_ALL);
  3. ?>

A mettre au début de tes pages php


Bonjour

Tu peux prendre la suite de l'aide ?
Cela dépasse un peu mes compétences, à ce niveau.
Merci,

@+
JM
  • Commenter cette réponse |
Score
0
òh
òi
|
  1. <?php
  2. ini_set('error_reporting', E_ALL);
  3. ?>

A mettre au début de tes pages php
  • Commenter cette réponse |
Score
0
òh
òi
|
Oui ça j'ai compris mais :

Comment fais ton pour voir les log php pour voir l'erreur que ça produit ?
  • Commenter cette réponse |
Score
0
òh
òi
|
Citation :
Alors?


Pas d'impatience. on peut avoir un autre fer sur le feu.

1) Ne laisse pas ton adresse mel dans un forum. Elle va être récupérée vite fait par un robot spécialisé, et tu vas comprendre ta douleur. Ou par un lecteur un peu farceur. Donc, tu commence par éditer ton message, et tu l'effaces.
je ne suis pas un spécialiste du HTML, mais je touche un peu (pas assez pour reprendre tout ton code. j'ai déjà pas mal à faire avec le mien).

2) La balise </BODY> est une balise HTML. Elle délimite le contenu d'un document.
Placée au début, elle suit obligatoirement la balise "head"
cette balise peut désormais recevoir un attribut. (ex : <body vlink> voir plus bas)

Elle finit en bas de page par la Balise </BODY> , qui indique la fin du document

entre <BODY>et</BODY> se trouvent tout ce qui est inséré dans la page ( textes, images, sons, hyperliens, listes, tableaux, etc...)

Ex :

<html>
<head>
<meta content="text/html; charset=utf-8" http-equiv="content-type">

. . . / . . .

<body vlink="#c0c0c0" text="#ffffff" link="#cccccc" bgcolor="#000000" background="anthracite.gif" alink="#ffffff">
<div><strong><a title="Retour vers l'accueil des différentes galeries photos." href="../../"><font size="1"><font color="#ffff66"><span style="background-color: #ff0000"><font size="5">Retour vers l'accueil </font></span></font></font></a></strong><a title="Retour vers l'accueil des différentes galeries photos." href="../../"><font size="1"><font color="#ffffff"><font size="0"><strong><font size="0"><span style="background-color: #ff0000"><font size="5"><strong><font color="#ffffff">desphotos.net</font></strong></font></span></font></strong></font></font></font></a></div>
<div>
<div><font size="1"><br>
</font></div>
<table style="border-collapse: collapse" align="center" bgcolor="#0000ff" border="1" bordercolor="#ffffff" cellpadding="0" cellspacing="0" height="67" width="1230">
<tbody>
<tr align="center" valign="middle">
<td align="left" valign="center" width="9%">
<div><font color="#ff0000" size="6"><strong>Liens</strong></font></div>
<div><strong><font color="#ff0000" size="4"><strong>favoris</strong></font></strong></div></td>

. . . / . . .

</body>
</html>

Tu devrais faire une recherche sur "gogole" : "balises HTML", et tu obtiendras une liste impressionnante de sites qui t'expliqueront beaucoup mieux que moi l'utilisation des balises en HTML

@+
JM
  • Commenter cette réponse |
Score
0
òh
òi
|
Alors?
  • Commenter cette réponse |
Score
0
òh
òi
|
J'ai pas de fichier noframe

Merci de vos réponse

Si vous avez le courage de m'aidez moi c'est

Formule: basic
Type serveur Web: Apache
Espace Web: 3000Mo
Espace Mails: 2Go/Boîtes/maxi
Nbre Emails: 10
Base Mysql: oui Max: 10 Mo
Base Access: oui
Trafic max /mois: NEW: Illimité
Extra(s): rien
Création domaine: oui
Date d'expiration: 03-11-2010

Voila les parametre de mon site voila
  • Commenter cette réponse |
Score
0
òh
òi
|
tu entend quoi par balise body?
  • Commenter cette réponse |
Score
0
òh
òi
|
Bonjour...

Un petit peu de recherche :

http://www.snv.jussieu.fr/archambault/cours/html/textes...
http://pagesperso-orange.fr/bernard.quevillier/toposnew...


La balise body doit être à l'intérieur de noframe...

++

  • Commenter cette réponse |
Score
0
òh
òi
|
Citation :
personne :s


Bonjour

je viens de faire un essai ave FireFox (v2.0) sur http://lordofgame.fr/frames.php et j'obtiens une page blanche.
mais je te le rappelle, acec Safari (navigateur d'apple, j'obtiens bien la page d'accueil en utilisant http://lordofgame.fr/frames.php

Toutefois,ci la page apparaît et ne plante pas, le cadre central (2 lignes) indique "erreur"
Le "deboggueur" de Safari, sur les sources de la page indiquent des erreurs, hélas trop longues à analyser.

En particulier (journal des erreurs) :

Extra <html> encountered. Migrating attributes back to the original <html> element and ignoring the tag.
frames.php:1<head> must be a child of <html>. Content ignored.
frames.php:1<meta> is not allowed inside <body>. Moving <meta> into the <head>.
frames.php:1<title> is not allowed inside <body>. Moving <title> into the <head>.
frames.php:1Unmatched </head> encountered. Ignoring tag.
frames.php:1<noframes> is not allowed inside <frameset>. Content ignored.
frames.php:1Unmatched </noframes> encountered. Ignoring tag.
leftmenu.php:1Extra <html> encountered. Migrating attributes back to the original <html> element and ignoring the tag.
leftmenu.php:2<head> must be a child of <html>. Content ignored.
leftmenu.php:3<title> is not allowed inside <body>. Moving <title> into the <head>.
leftmenu.php:7<meta> is not allowed inside <body>. Moving <meta> into the <head>.
overview.php:1Extra <html> encountered. Migrating attributes back to the original <html> element and ignoring the tag.
overview.php:2<head> must be a child of <html>. Content ignored.
overview.php:3<title> is not allowed inside <body>. Moving <title> into the <head>.
overview.php:7<meta> is not allowed inside <body>. Moving <meta> into the <head>.
leftmenu.php:10Unmatched </head> encountered. Ignoring tag.
leftmenu.php:11Extra <body> encountered. Migrating attributes back to the original <body> element and ignoring the tag.
leftmenu.php:20Extra <body> encountered. Migrating attributes back to the original <body> element and ignoring the tag.
overview.php:10Unmatched </head> encountered. Ignoring tag.
overview.php:11Extra <body> encountered. Migrating attributes back to the original <body> element and ignoring the tag.

si cela peut t'aider.
@+
JM
  • Commenter cette réponse |
Score
0
òh
òi
|
personne :s
  • Commenter cette réponse |
Score
0
òh
òi
|
Moi je parle quand on ce connect, on arrive pas a acceder a la pages frames.php qui bloquent,

Dés que je me connecte via firefox ou ie j'ai une pages blanches.

Alors que j'ai essayé d'autre pages et ça marche trankil, ya que la pages frames.php

En tout cas merci de vos reponses !

  • Commenter cette réponse |
Score
0
òh
òi
|
Citation :
Voila depuis hier j'ai un probleme avec mon site internet,

C'est un jeu en reseau et ça bug sur une certaine pages

Quand j'ouvre ma page avec google Chrome sa marche bien, mais avec firefox et IE, rien ne marche cette page bloquent...

Merci a tous et bonne nuit


Bonjour

Je viens d'accéder à ton site avec Safari 4.0.4 (dernière version).

1) Pas de problème pour y accéder (page présentant la terre, la lune, et à gauche, des liens hypertextes
Mais
2) Erreur sur la page d'accueil (vue générale)
erreurs sur "batiments" (toute une page d'item)
erreur sur "flotte"
erreur sur "liste amis"
erreur sur "notes"
"Forum" ne "réagit pas". (lien non actif)

@+
JM
  • Commenter cette réponse |
Score
0
òh
òi
|
Citation :
bonjour....mettre a jour java pour firefox....et pourquoi pas télécharger en même firefox 6 bêta 2.....



Bonjour

Je ne voudrais pas te contredire, mais, en théorie un site doit être lisible par tous les navigateurs, dans toutes leurs versions (en excluant celles vraiment trop anciennes).
Sinon, soit le site fait appel à des commandes accessibles à certains navigateurs seulement (ou certaines versions), et à mon sens, c'est une erreur, soit il comporte des erreurs de balises ou syntaxe, ou il y a problème avec l'hébergeur.

@+
JM
  • Commenter cette réponse |
Score
0
òh
òi
|
bonjour....mettre a jour java pour firefox....et pourquoi pas télécharger en même firefox 6 bêta 2.....
  • Commenter cette réponse |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS