Se connecter / S'enregistrer
Votre question

(RESOLU)-Resolution ecran linux

Tags :
  • linux
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
8 Juin 2008 19:08:40

Bonjour a tous et a toutes

decidant de me mettre a linux je l'ai installé il y a 3 jours. Donc je susi un grand débutant.
Ayant déja rencontré quelques soucis du fais de la difference en Windows et linux j ai deja parcouru un grand nombre de forum où j ai trouvé quelques réponses.
Mais la j ai un petit probleme la résolution max qui est disponible est 1024*768 50Hz alors que sur Windows je monte a 1280*1024

Apres plusieurs lectures de divers post sur des forums j ai essayé des commande dans le terminal mais sans resultat

Je suis sur Ubuntu et Gnome

Sinon ma config de mon PC:
Amd sempron 2600+
6600 GT
1go ram

Ps: j'ai cru comprendre que l on pouvait modifier le fichier xorg.conf donc voici le mien

Citation :
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "UseFBDev" "true"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
EndSection


PS: j'ai également cru comprendre que Linux instalé les drivers automatiquement donc je n'ai rien installé j ai juste activé le pilote d'acceleration graphique dans Systeme-->Administration-->Pilote de peripherique


Voila merci :hello: 

Autres pages sur : resolu resolution ecran linux

Anonyme
8 Juin 2008 19:56:22

salut
tente de taper ça dans un terminal


sudo dpkg-reconfigure -phigh xserver-xorg
ça te demandera la résolution, ensuite redemarre le serveur x.
8 Juin 2008 20:21:07

en faite jai reboot le pc et miracle la resolution est apparu
par contre quand je déplace les fentre je trouve que c ets moi fluide que sur windows, j'ai en quelque sorte la trace de la fentre
est ce normal ?
Contenus similaires
8 Juin 2008 22:38:28

Si tu es sous Hardy Heron, parfois, l'edition Xorg.conf ne suffit pas.
JE te conseille d'installer nvidia settings

  1. sudo apt-get install nvidia-settings


puis Systeme>Administration>Nvidia X server Settings
pour configurer au mieux ta resolution, ton taux de rafraichissement et tout ce qui concerne l'acceleration 3D

Attention, pour que les changements soient permanents, apres un reboot, il faut lancer le soft en root

  1. sudo nvidia-settings
puis enregistrer les modifications.
a b 5 Linux
8 Juin 2008 22:50:05

Hum, il a vraiment ses pilotes installés là ?
9 Juin 2008 19:17:54

Apres avoir fait la commande de The_Gonzo
Citation :
1. sudo nvidia-settings


Une petite fentre apparait dans laquell est ecrit:
Citation :
You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just runas root), and restart the X server.


Je tape alors la commande `nvidia-xconfig` dans le terminal en root j ai alors ca:
  1. Using X configuration file: "/etc/X11/xorg.conf".
  2.  
  3. VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
  4. Device section "Configured Video Device" must have a Driver
  5. line.
  6.  
  7. Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
  8. New X configuration file written to '/etc/X11/xorg.conf'

Du coup je sais pas trop ca veut dire quoi ni qu est ce que je doit faire :s
9 Juin 2008 19:57:18

Nan mais deja, dans ajouter/supprimer des programmes, y a t il un pilote nvidia qui apparait comme installé?
Ensuite, as tu installé nvidia-settings, par apt-get ou par le menu ajouter/supprimer?

Si tu lances le nvidia-settings sans l'avoir installé, c'est normal que ca foire.
a b 5 Linux
9 Juin 2008 20:04:59

You do not appear to be using the NVIDIA X driver
9 Juin 2008 20:30:56

  1. sudo apt-get install nvidia-glx-new

Ensuite:
  1. sudo nvidia-xconfig


Et reboot de X (Ctrl+Alt+Return), ou reboot du PC.
9 Juin 2008 20:51:59

jai fait ce que Moi123@IDn a dit ca marche impect juste le clavier qui est passe en qwerty mais c est un detail jvais trouver comment changer cela
merci a vous
9 Juin 2008 22:02:54

Tu peux taper cette commande dans un terminal, histoire de voir si ton clavier est bien configuré en Fr:
  1. cat /etc/X11/xorg.conf | grep XkbLayout


Si tu vois que le résultat ressemble à quelque chose comme:
Citation :
XkbLayout "En"
tape:
  1. sudo sed -i 's/"en"/"fr"/' /etc/X11/xorg.conf
10 Juin 2008 00:20:56

Je m'incline.
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS