Se connecter / S'enregistrer
Votre question

linux disque dur externe usb accessible seulement par root

Tags :
  • Disque dur externe
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
24 Mai 2005 11:20:41

Bonjour a tous,

J'ai des petits soucis avec ma mandriva 10.2 LE2005. J'arriva à lire mes partitions ntfs qui sont sur mon disque dur principal mais quand je branche mon disque dur externe je me retrouve bloqué je ne peux y accèder qu'avec l'utilisateur root. Ce qui est un poil pénible pour lire que des mp3.

J'ai regardé le fichier /etc/fstab mais même en mettant les même règles que pour mes autres partitions windows cela ne marche pas. Pouvez vous m'aider ?

C'est la seule chose qui me retient sinon je suis prêt à passer sous linux définitevement.

Merci bcp par avance

Autres pages sur : linux disque dur externe usb accessible seulement root

24 Mai 2005 13:00:28

slt !

montres nous ton fstab !

Sinon essayes dans fstab :
/dev/sda1 /mnt/disk-usb auto user,iocharset=iso8859-15,kudzu,codepage=850,noauto,exec 0 0
ou peut-être (jamais essayé)
none /mnt/sda1 supermount dev=/dev/sda1,fs=auto,ro,--,iocharset=iso8859-15,codepage=850 0 0
24 Mai 2005 13:03:12

d'habitude linux ne lit que les fichiers fat
Contenus similaires
24 Mai 2005 13:04:17

depuis quelques version, linux lit nickel les ntfs, mais n'écrit pas dessus...
24 Mai 2005 13:05:53

Citation :
d'habitude linux ne lit que les fichiers fat

Qu'est-ce que tu racontes ?
Linux lis le FAT, le NTFS, le ext2, ext3, ReiserFS et bien d'autres... par contre, il n'écrit que de façon expérimentale sur du NTFS.
24 Mai 2005 13:10:49

Citation :
par contre, il n'écrit que de façon expérimentale sur du NTFS.


avec quoi il écrit dessus ???
24 Mai 2005 13:17:04

C'est un peu Hors-sujet mais bon...
"Comment écrire avec linux sur du NTFS ?"

Solution 1 : Un noyau 2.6 peut écrire sur du NTFS, mais l'option correspondante doit être activée... et elle est souvent désactivée dans les noyaux fournis par les distributions... mais si tu compile ton noyau toi-même, tu peux essayer.

Solution 2 : Utiliser captive
24 Mai 2005 14:25:33

oui je me doute que vous voulez voir mon fichier fstab malheureusement je ne l'ai pas actuellement sur moi je suis au boulot promis ce soir je le mets en ligne vers 18h 18h30.

Merci a vous
24 Mai 2005 17:52:19

Voici mon fichier /etc/fstab

/dev/hda8 / ext3 noatime 1 1
/dev/hdc /mnt/cdrom iso9660 user,iocharset=iso8859-15,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0022,iocharset=iso8859-15,sync,codepage=850 0 0
/dev/hda1 /mnt/win_c ntfs umask=0022,nls=iso8859-15,ro 0 0
/dev/hda5 /mnt/win_d ntfs umask=0022,nls=iso8859-15,ro 0 0
/dev/hda6 /mnt/win_e ntfs umask=0022,nls=iso8859-15,ro 0 0
/dev/hda7 /mnt/win_f ntfs umask=0022,nls=iso8859-15,ro 0 0
none /proc proc defaults 0 0
/dev/hda9 swap swap defaults 0 0
/dev/sda5 /mnt/Music ntfs pamconsole,exec,noauto,utf8,iocharset=iso8859-15,managed 0 0
/dev/sda6 /mnt/Videos_Images ntfs pamconsole,exec,noauto,utf8,iocharset=iso8859-15,managed 0 0

Ce sont les deux dernières lignes qui foutent la merde.
24 Mai 2005 18:07:49

moi je rajouterais l'option user :
/dev/sda5 /mnt/Music ntfs pamconsole,
user,exec,noauto,utf8,iocharset=iso8859-15,managed 0 0
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS