Se connecter / S'enregistrer

Résolu Excel 2007 : comment réaliser une opération avec la fonction somme.si ?

Solutions (1)
Tags :
  • b&c
  • Microsoft Excel
  • Logiciels
|
Bonjour,
Je voudrai réaliser l'opération suivante. Si dans la colonne A il y a 1* faire la somme de la colonne B moins la somme de la colonne C et ajouter la valeur de la cellule G4. S'il n'y a pas 1* dans la colonne A, alors blanc.
A--------------------B--------------C---------------------------G4=1250
1Sold -----------498,43-----------0
1Entr---------------12,25-----------0
1Entr------------------------------125
2Colm----------------200-----------0
2sort-------------------------------300
3Entr------------------125
3Sort---------------------------------56
Donc le résultat est : 385,68 + 1250 = 1635.68
J'ai essayé avec somme.si et somme.prod mais si dans A je n'ai pas 1* j'ai tjrs la valeur de G4 qui s'inscrit.
Merci
  • Meuniers a édité ce message
  • patanegra a édité ce message
Contenus similaires
Meilleure solution
partage
, Modérateur |
Salut,

Tu dois pouvoir faire ça avec un "COUNTIF", qui doit être NB.SI en français.
Ca sera une formule similaire à ton SOMME.SI:

En anglais (désolé j'ai un Excel en anglais) ça doit donner ça :
  1. =SUMIF(A1:A7;"1*";B1:B7)-SUMIF(A1:A7;"1*";C1:C7)+IF(COUNTIF(A1:A7;"1*")>0;G4;0)


En français ça doit être :
  1. =SOMME.SI(A1:A7;"1*";B1:B7)-SOMME.SI(A1:A7;"1*";C1:C7)+SI(NB.SI(A1:A7;"1*")>0;G4;0)
  • patanegra a sélectionné cette solution comme la meilleure réponse
  • Commenter cette solution |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS