Votre question

[Linux] Problème StepMania

Tags :
  • linux
  • Logiciels
Dernière réponse : dans Logiciels
19 Avril 2007 13:44:21

Bonjour alors je suis sous fedora core 6 et jesseye d'installer StepMania sur mon pc....
Apres quelques heures de recherches, jen suis arrivé au point où il me manque "Liblua".
En effet, je fait ./configure tout se passe bien jusque
"checking for lua-config50... no
checking for lua-config... no
checking for lua_open in -llua... no
checking for lua_open in -llua50... no
checking for luaopen_base in -llualib... no
checking for luaopen_base in -llualib50... no

*** liblua is required to build StepMania; please make sure that
*** it is installed to continue the installation process."

Voila jai fait des recherches il semblerais quil faille installer lubula et libula-devel mais je ne les trouves pas....
(jai débuté depuis peut sous linux ^^)

Merci de votre aide :jap: 

Autres pages sur : linux probleme stepmania

Contenus similaires
19 Avril 2007 17:16:12

Tout dabord marci davoir rep!! ^^

Alos jai fait ca que u ma dit (ayan Fedora core 6 sur fedora-fr ils disent que le dépot extrat est mis a linstallation depuis core 4)

jai donc tapé ta ligne de code il men sort
[root@localhost ~]# yum install lua-devel
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do

Et malheureusement je ne couprend pas bien le message mais ça n'a pas eu lair de marcher....
et le ./configure ne donne rien de plus.
19 Avril 2007 17:33:47

  1. yum --enbalerepo=extras install lua-devel

19 Avril 2007 17:44:23

Arf il me repond
[root@localhost ~]# yum --enbalerepo=extras install lua-devel
Loading "installonlyn" plugin
usage: yum [options] < grouplist, localinstall, groupinfo, localupdate, resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell, install, whatprovides, groupinstall, update, groupupdate, info, search, check-update, list, remove, clean, grouperase >

Command line error: no such option: --enbalerepo
19 Avril 2007 17:49:58

j'ai tapé trop vite:
  1. yum --enablerepo=extras install lua-devel

enable et non enbale
rien ne t'empeche de taper
  1. man yum

ca te donne pas mal d'infos sur la commande
19 Avril 2007 17:59:39

Merci pour "man yum"
Il me met ca ca na pas laire davoire fini....

[root@localhost ~]# yum --enablerepo=extras install lua-devel
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
livna 100% |=========================| 1.1 kB 00:00
core 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
Nothing to do
19 Avril 2007 18:28:41

Ma version de lua est : "lua-5.1.2-13fc6.i386" (pareil pour lua-devel)
Alors je ne couprend pas pourquoi cela ne marche pas....
il faut que je redescende de version? si oui jai juste a decocher la case "lua-5.1.2....?
sachant que je nai pas de cases avec lua-5.0.
19 Avril 2007 18:41:11

http://doc.fedora-fr.org/D%C3%A9p%C3%B4t_rpmforge

configure le dépots rpmforge en ajoutant un fichier /etc/yum.repos.d/rpmforge.repo
  1. [rpmforge]
  2. name = Fedora Core 6 - i386 - RPMforge.net - dries
  3. baseurl = http://apt.sw.be/dries/fedora/fc6/i386/RPMS.dries/
  4. enabled = 1
  5. gpgcheck = 1
  6. gpgkey = http://apt.sw.be/dries/RPM-GPG-KEY.dries.txt

puis
  1. yum remove lua
  2. yum --disablerepo=extras --enablerepo=rpmforge install lua-devel


mais ca risque de supprimer d'autres paquets

19 Avril 2007 19:21:30

Dsl jai cherché je ne sais pas pourquoi pour ta deuxiemme comande (yum --disablerepo=extras --enablerepo=rpmforge),il me dit:

Loading "installonlyn" plugin
You need to give some command

Vraiement dsl mais je début sous linux et jai un peut de mal...

Dsl javais coupé la comande.....

Je vien de faire ./configure mais ca plante ttjour au même endroit....
checking for lua-config50... no
checking for lua-config... no
checking for lua_open in -llua... no
checking for lua_open in -llua50... no
checking for luaopen_base in -llualib... no
checking for luaopen_base in -llualib50... no

*** liblua is required to build StepMania; please make sure that
*** it is installed to continue the installation process.
19 Avril 2007 19:54:41

tiens un autre essai:
ouvre le fichier configure, va à la ligne 5680:
  1. for ac_prog in lua-config50 lua-config

et changes la en
  1. for ac_prog in 'pkg-config lua' lua-config50 lua-config

sauve et relance le ./configure
19 Avril 2007 20:22:30

checking whether sinf is declared... yes
checking whether tanf is declared... yes
checking whether cosf is declared... yes
checking whether acosf is declared... yes
checking whether roundf is declared... yes
checking whether truncf is declared... yes
checking whether SIGPWR is declared... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating src/config.h
config.status: src/config.h is unchanged
config.status: executing depfiles commands


Jen suis la...
(javais oublier de présiser que cetait mon premier paquet .tar.gz...

Quand je fait make il me fait
Making all in src
make[1]: entrant dans le répertoire « /usr/local/StepMania-3.9-src/src »
make all-am
make[2]: entrant dans le répertoire « /usr/local/StepMania-3.9-src/src »
if g++ -DHAVE_CONFIG_H -I. -I. -I. -I/usr/include/SDL -D_GNU_SOURCE=1 -D_REENTRANT -finline-limit=300 -Wall -W -Wno-unused -Wno-switch -O3 -MT Screen.o -MD -MP -MF ".deps/Screen.Tpo" \
-c -o Screen.o `test -f 'Screen.cpp' || echo './'`Screen.cpp; \
then mv -f ".deps/Screen.Tpo" ".deps/Screen.Po"; \
else rm -f ".deps/Screen.Tpo"; exit 1; \
fi
GameState.h:88: erreur: extra qualification ‘GameState::’ on member ‘GetRandomCharacter’
GameState.h:89: erreur: extra qualification ‘GameState::’ on member ‘GetDefaultCharacter’
make[2]: *** [Screen.o] Erreur 1
make[2]: quittant le répertoire « /usr/local/StepMania-3.9-src/src »
make[1]: *** [all] Erreur 2
make[1]: quittant le répertoire « /usr/local/StepMania-3.9-src/src »
make: *** [all-recursive] Erreur 1

Merci pour ton aide jusque la ^^
19 Avril 2007 20:57:36

tu te débrouilles en anglais?
19 Avril 2007 20:59:53

Bah bof (jai 15 ans en même temps)
19 Avril 2007 21:07:27

Ok merci je regarde ca et je te dit ou jen suis ^^

Merci beaucoup^^
19 Avril 2007 21:18:27

Je doit dabord te remercier ca cela ma débloquer mais cependent il a été restoper ~~

archutils/Unix/LinuxThreadHelpers.cpp:32: erreur: ‘gettid’ has not been declared
archutils/Unix/LinuxThreadHelpers.cpp:39: erreur: expected initializer before ‘CStdStringA’
archutils/Unix/LinuxThreadHelpers.cpp: In function ‘uint64_t GetCurrentThreadIdInternal()’:
archutils/Unix/LinuxThreadHelpers.cpp:136: erreur: ‘gettid’ was not declared in this scope
make[2]: *** [LinuxThreadHelpers.o] Erreur 1
make[2]: quittant le répertoire « /usr/local/StepMania-3.9-src/src »
make[1]: *** [all] Erreur 2
make[1]: quittant le répertoire « /usr/local/StepMania-3.9-src/src »
make: *** [all-recursive] Erreur 1
19 Avril 2007 21:42:00

Ok merci beaucoup de ton aide ^^

19 Avril 2007 21:57:39

Désolé mais je ne suis pas sur davoir bien compris

Quand il dit ca
"I was having the same problem a couple of months ago trying to compile StepMania 3.9 but the problem did not occur when compiling 4.0 CVS. I used the changes from 4.0 CVS to make a patch for 3.9 that solves this problem.

http://aur.archlinux.org/packages/stepmania/stepmania/s..."

il dit bien qui a eu me même problème et quil a fait un patch lui même mais le lien est un texte.
si ce que jai comppris est bon je doit faire

# cd StepMania-3.9

# wget http://aur.archlinux.org/packages/stepmania/stepmania/s...

# cat stepmania-3.9-glibc.patch | patch -p0

C'est ca ?
édit: non cest pas ca aparement jai esseyer ~~
19 Avril 2007 22:11:23

je dirais:
  1. cat stepmania-3.9-glibc.patch | patch -p1

le truc, c'est le nom du fichier dans le fichier .patch
dedans le chemin est StepMania-3.9-src/src/archutils/Unix/LinuxThreadHelpers.cpp

donc p0 cherchera un fichier avec le meme chemin, vu que tu es déjà dans StepMania-3.9, je crois qu'il faut -p1, ainsi il enlevera le premier répertoire
19 Avril 2007 22:17:59

Arf
Aparement no, il dit que le chemin nest pas bon...
(merci de tes explication jai compris comment cela marchais ^^)
19 Avril 2007 22:21:02

donc ca marche la?
19 Avril 2007 22:21:42

No.
Il me dit ca
cat: stepmania-3.9-glibc.patch: Aucun fichier ou répertoire de ce type
et en effet, je n'ai pas le patch mais 2 fichier.
un index et lautre process....
19 Avril 2007 22:25:02

non, mais apres faut etre un peu logique :p , tu es dans le bon répertoire ou pas?
tu l'as placé où ce fichier
EDIT: la, ca y est, je suis perdu, que te sauvegarde le wget?
19 Avril 2007 22:27:13

Dans mon repertoie stepmania-3.9-src
Mais jai dut edit trop tard xD
et en effet, je n'ai pas le patch mais 2 fichier.
un index et lautre process....
il me sauvegarde un fichier index.html
et un autre process?key=001b9fb2b18442ca7a0c08f0129e47e2730
19 Avril 2007 22:36:32

  1. $ wget http://aur.archlinux.org/packages/stepmania/stepmania/stepmania-3.9-glibc.patch
  2. --22:35:41-- http://aur.archlinux.org/packages/stepmania/stepmania/stepmania-3.9-glibc.patch
  3. => `stepmania-3.9-glibc.patch'
  4. Resolving aur.archlinux.org... 66.211.213.17
  5. Connecting to aur.archlinux.org|66.211.213.17|:80... connected.
  6. HTTP request sent, awaiting response... 200 OK
  7. Length: 676 [text/plain]
  8.  
  9. 100%[===================================================================>] 676 --.--K/s
  10.  
  11. 22:35:41 (71.63 MB/s) - `stepmania-3.9-glibc.patch' saved [676/676]

je suis curieux de voir comment tu les recois ces fichiers ;) 

19 Avril 2007 22:41:24

Lol bah jai réussit aussi xD merci.
mais maintement quand je tape
cat stepmania-3.9-glibc.patch | patch -p1
jai
[root@localhost local]# cat stepmania-3.9-glibc.patch | patch -p1
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|--- StepMania-3.9-src-orig/src/archutils/Unix/LinuxThreadHelpers.cpp 2004-10-22 17:23:38.000000000 -0500
|+++ StepMania-3.9-src/src/archutils/Unix/LinuxThreadHelpers.cpp 2006-11-18 13:36:18.000000000 -0600
--------------------------
File to patch:


Edit: oubli ce que je tai dit dsl jetait dans la mauvait dossier
19 Avril 2007 22:44:28

Merci je make et je te dit ce qu'il en est ^^
ps: jai des dossier qui sont la je ne sais pas trop pourquoi le index et lautre comment je peut es supprimer plis
19 Avril 2007 22:57:35

Arf alors la il ce passe quelquechose de bizard.
je ne sais pas où est lerreur,je ne la localise pas ~~
je te laisse la fin de mon code:

SongManager.cpp:( .text+0xa73d): undefined reference to `lua_type'
SongManager.cpp:( .text+0xa796): undefined reference to `lua_touserdata'
collect2: ld a retourné 1 code d'état d'exécution
make[2]: *** [stepmania] Erreur 1
make[2]: quittant le répertoire « /usr/local/StepMania-3.9-src/src »
make[1]: *** [all] Erreur 2
make[1]: quittant le répertoire « /usr/local/StepMania-3.9-src/src »
make: *** [all-recursive] Erreur 1
19 Avril 2007 23:04:02

donne la commande gcc juste avant l'erreur
19 Avril 2007 23:08:36

Désolé mais je ne vois pas de quoi tu veux parlé :$
19 Avril 2007 23:14:22

ben normalement, c'est une erreur d'édition de liens, il doit y avoir un gcc ou g++ juste avant l'erreur, un truc de ce genre:
if g++ -DHAVE_CONFIG_H
19 Avril 2007 23:15:22

Il n'y a marqué gcc nule part (jai copier collé dans un "bloc note" et jai fait une recherche.
mais je ne peut pas monter tout en haut de de la session...
19 Avril 2007 23:17:54

jai ca beaucoup plus haut g++ -finline-limit=300
19 Avril 2007 23:22:31

donne la sortie de:
  1. rpm -ql lua-devel
19 Avril 2007 23:24:16

[root@localhost StepMania-3.9-src]# rpm -ql lua-devel
/usr/include/lauxlib.h
/usr/include/lua.h
/usr/include/lualib.h
/usr/lib/liblua.a
/usr/lib/liblua.so
/usr/lib/liblualib.a
/usr/lib/liblualib.so
19 Avril 2007 23:37:32

à mon avis le config s'est mal passé, il te faut ajouter les références de lua dans le Makefile, mais la je l'ai pas sur place, je pourrais pas te dire :/ 
en gros, ca doit etre une entrée LDADD ou LDFLAGS ou il faudrait ajouter "-llua -lm -ldl " sans "
19 Avril 2007 23:39:51

Mmm et si je te lenvoyais tu pourrais me le dire ?
dans le makefile jai
LDFLAGS = -rdynamic
20 Avril 2007 13:28:34

la ligne devient alors
  1. LDFLAGS = -rdynamic -llua -lm -ldl

C'est ca ?
20 Avril 2007 13:38:38

je regarde chez moi puis je te repond
20 Avril 2007 13:41:07

Ok merci beaucoup ^^
20 Avril 2007 13:56:03

alors ouvre le Makefile dans le répertoire StepMania-3.9-src
cherche la ligne LUA_LIBS =
et rajoute -llua -lm -ldl

fais de meme avec src/Makefile et relance le make
20 Avril 2007 14:00:07

Ok je fait ca je te dit ^^
20 Avril 2007 14:07:47

Mmmm je ne peut pas toucher au makefile je ne sais pas comment faire tu naurais une idée plis
20 Avril 2007 14:10:02

j'ai vu que tu lancais le make depuis /usr/local (c'est pas tres indiqué :) )
fais le en root
20 Avril 2007 14:12:34

Tu me conseil de metre mon fichier step ou (je lai misla javais vu un tuto pour les .tar.gz où il disait quil falait le mettre la jai trouvé ca bizard aussi car on a pas la main ici quand on est pas en root
et je ne conais pas la commande pour toucher au fichiers ac le terminal :$
      • 1 / 2
      • 2
      • Dernier
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS