Résolu EXCEL problème résultat calcul croisé

Solutions (1)
Tags :
  • Microsoft Excel
  • Programmation
  • Logiciels
|
Bonjour,

J'ai un petit soucis avec EXCEL....

J'ai plusieurs colonne avec des données chiffrées.....la colonne C, K, et dans la colonne N le résultat de C / K.

Si je fais le total de la colonne C et K et que je divise le total C / K j'obtient un résultat de 74'545.75.

Par contre si je fais le total de la colonne N (qui est le résultat de C / K et que je divise ce résultat par le nombre de ligne, j'obtiens un résultat différent......(70'738.93)...

J'ai bien regarder que mes cellules de calcul soient corrects et c'est le cas...je n'arrive pas à comprendre comment j'ai une différence si importante....

Est-ce que quelqu'un peut m'aider ou à déjà rencontré ce genre de cas ?

D'avance un grand merci et meilleures salutations.
Contenus similaires
Meilleure solution
partage
, Programmation (collector) |
Salut,
Du point vue d'un informaticien cela est presque normal ! ( en fais l’écart me semble un peut gros , a moins que tu est vraiment beaucoup de valeur ! )

Par exemple :
Si de A1 a A1000 je remplie de 1,
de B1 a B1000 je remplie de 3,
de C1 a C1000 je remplie de = Ax / Bx ( avec x pour la ligne , ce qui affiche 0,33333333 ( e-8 par defaut ))

maintenant en D1 j'ecrit : =SOMME(A1:A1000);
en D2 : =SOMME(B1:B1000);

En E1 : =D1/D2
et en E2 : =SOMME(C1:C1000)/1000

L'on peut constater que les deux case affiche 0.33333333 ( avec 8 "3", car par defaut excel affiche a 10e-8 )
Maintenant si l'on change le format de cellule de la colonne E , en nombre avec 30 décimal ( le max ^^ )

L'on vas pouvoir voir que la case E1 contient : 0,333333333333333000000000000000 ( au passage l'on remarque qu'excel arrete de calculer les fraction a la 15eme décimal )

Et dans la case E2 on peut voir : 0,3333333333333320000000000000000 , ici l'on a perdu de la précision du a des arrondi qui ce sont fais dans la colonne C ...

Donc la la différence est vraiment minime mais j'ai pris 1/3 pour l'exemple, si l'on commence a jouer avec des fraction un peut plus complexe l’écart ce creuse rapidement...

Ici pour avoir le vraie resultat la formule serait : =(A1/B1+A2/B2+ ....) / 1000; mais on vois bien que cela n'est pas faisable ^^ ...

Tous sa pour en conclure que la formule la plus juste est : =SOMME(A:A)/SOMME(B:B)
  • Dreamcaster a sélectionné cette solution comme la meilleure réponse
  • Commenter cette solution |

Ce n'est pas ce que vous cherchiez ?

Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS