Se connecter / S'enregistrer
Votre question

Ubuntu: Installation de xbslink

Tags :
  • linux
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
26 Novembre 2010 20:48:28

Bonjours à tous je fais vite car j'aimerai qu'on me réponde rapidement =)
Alors voila je voudrais installer le logiciel xbslink sous linux (ubuntu) j'ai téléchargé le package .tar.gz puis extrait, il me donne un dossier avec plein de chose dedans, daccord!
Mais pour installer ce logiciel aparemment j'ai lu (en anglais^^) qu'il fallait d'abord installer 2 choses suplementaire, et franchement j'y comprend pas grand chose pour installer ce "libpcap-1.1.1.tar" que j'ai extrait et l'autre logiciel
Voila la source du logiciel:
http://www.secudb.de/~seuffert/xbslink/xbslink-and-linu...

J'espere vraiment que des âmes charitable pourront m'aider et m'éclaircir dans l'installation de logiciel non trouvables dans les dépot ubuntu =) car j'utilise ubuntu depuis tres peu de temps et j'essai d'éviter Windob au maximum depuis que j'ai découvert ce trésor de linux x)
MERCI =)

Autres pages sur : ubuntu installation xbslink

a b 5 Linux
28 Novembre 2010 00:09:50

Le paquet Linux est contient un exe et des dll, donc ce sera Wine.
m
0
l
Contenus similaires
28 Novembre 2010 15:37:50

ah dacoord merci les gars je vais essayer Wine parce que j'ai essayé d'installer tout ca, mais apparement il faut que j'installe Mono et Libpcap pour pouvoir installer ensuite xbslink mais impossible encore une fois =/ je sais pas comment je vais pouvoir faire =(
m
0
l
28 Novembre 2010 16:25:24

J'espere que vous etes toujours là, alors j'ai installé Wine sans soucis, j'ai lancé mon installation de XBSlink il l'a bien émulé: installation classique comme sur windows "suivant, etc"
Mais maintenant que faire? lorsque je vais dans /home/matthieu/.wine/dosdevices/c:/Program Files/XBSlink et que je reclique sur "XBSlink.exe" rien ne se passe :s
Dites moi la marche à suivre, faut t-il installer des chose suplementaier contenue dans le dossier exemple "Mono.Nat.dll" :s
Merci de m'avoir fait découvrir ce petit outil Wine plutot util =D

PS: J'ai essayé de lancer l'appli par le terminal et voici le resultat:
matthieu@matthieu-Ubuntu:~$ cd /home/matthieu/XBSlink/bin/Release
matthieu@matthieu-Ubuntu:~/XBSlink/bin/Release$ wine XBSlink.exe
install the Windows version of Mono to run .NET executables
m
0
l
a b 5 Linux
28 Novembre 2010 16:41:52

Dans le menu "aplications" tu dois avoir "wine/programmes/etc"
TU m'as l'air d'aimer compliquer les choses simples :) 
Maintenant ça ne garantit pas le bon fonctionnement du logiciel ou même de Wine, perso je l'installe toujours via "Palyonlinux" qui le configure très bien sans intervention de ma part.
m
0
l
28 Novembre 2010 16:50:45

Et d'ailleurs,tu l'a essayé sous Windows pour voir s'il marche?
m
0
l
28 Novembre 2010 16:57:30

Oui j'ai essayé de le lancer avec "application--> Wine --> et XBSlink mais j'ai une fenetre reduite qui se lance avec "lancement de XBSlink" puis se ferme et rien du tout n'apparait...
Playonlinux, il marche XBSlink dessus?
Et oui sous windows j'ai essayé et fonctionne super!
Merci à vous encore une fois ;) 
m
0
l
a b 5 Linux
28 Novembre 2010 17:14:17

J'en sais rien je ne suis pas allé jusqu'à essayer (chais même pas ce que c'est )
Playonlinux se sert de Wine, et donc l'installe au poil, c'est surtout pour ça que je m'en sers, je n'ai installé aucun jeu Windows sous Nux :) 
m
0
l
28 Novembre 2010 17:14:30

Meme en passant par Playonlinux rien ne se lance =/ sachant que ce n'est pas un jeux, cest un programme permettant de jouer en LAN avec une autre personne sur PS3 ^^
m
0
l
a b 5 Linux
28 Novembre 2010 17:17:08

Bah faut croire que sous Nux c'est mort.
m
0
l
28 Novembre 2010 17:32:04

Rah merde alors, pourtant il nous donne tout ce qu'il faut sur le site il mettent une version linux inutilisable ou alors faut etre un pro de linux pour arrivé au bout de tout ca =/ super -_-'
Mais bon merci à toi quand meme, je passerai sous windob pour le lancer =(
Et donc petite question, avec playonlinux j'installe mes programmes .exe meme si ce ne sont pas des jeux? et ensuite je pourrai en lancer certains?
m
0
l
a b 5 Linux
28 Novembre 2010 18:06:08

Oui, c'est conçu pour le jeu à la base, mis c'est surtout une interface conviviale à Wine, au delà du catalogue de logiciels déjà configurés.
Je m'en sers pour un petit utilitaire électronique par exemple, écrit pour Windows, j'ai installé de cd de jeux de mes (petits) gamins aussi (je disais pas de jeux mais j'avais oublié ça)
m
0
l
28 Novembre 2010 18:13:00

D'accord, et bien écoutes merci quand meme de m'avoir aidé, j'aurai toujours appris des choses sur linux =D
et si quelqu'un à reussi à installer XBSlink sur liunux, qu'il me fasse signe =)

Merci à tous
m
0
l
28 Novembre 2010 19:17:35

Dans ton 1er post:

matthieubarcadu85 a dit :
J'ai téléchargé le package .tar.gz puis extrait, il me donne un dossier avec plein de chose dedans


Il y a toujours un fichier README à l'interieur de l'archive pour te guider dans la compilation car celà diffère souvent d'un programme à un autre.Qu'est ce qu'il dit ?
En principe,tu fais ça:
  1. cd \Réperoire_dans_lequel_wbslink_est situé(bureau,home,telechargements,etc)/le_dossier_des_fichiers_extraits
  2. configure
  3. mkdir build

Mais bon,j'suis pas très sûr,car comme je te l'ai dis tout depend de ce qui est indique dans le fichier README.

m
0
l
28 Novembre 2010 20:12:15

Salut, nan enfaite je réexplique: Je veux installer xbslink: j'ai un dossier avec seulement un fichier .exe .exe.mdb et d'autres fichiers .dll

Mais déja pour pouvoir l'installer il me faut Mono et Libpcap que eux je n'arrive pas à installer =/, pour libpcap j'ai un readme en effet mais je n'arrive pas à installer quoi que ce soit =( je renonce trop compliqué pour l'instant =/ domage c'est un point négatif de linux je trouve =/
m
0
l
28 Novembre 2010 20:27:12

Moi je parle du package tar.gz
m
0
l
28 Novembre 2010 22:15:12

quand on l'extrait le xbslink, a l'interieur il n'y a rien a complier ou je suis completement à coté ^^
m
0
l
a b 5 Linux
28 Novembre 2010 22:44:53

Non je l'ai D/L pour voir et il n'y a aucun fichier "nux" dans l'archive, que l'exe et des dll, pur Windows quoi.
Ama ils se sont gourés.
m
0
l
a b 5 Linux
28 Novembre 2010 22:51:36

Salut matthieubarcadu85
matthieubarcadu85 a dit :
quand on l'extrait le xbslink, a l'interieur il n'y a rien a complier ou je suis completement à coté ^^

Sur la page que tu as donnée comme lien dans ton premier message, il est marqué :

Extract the XBSlink Linux package, go into the directory and run:
“sudo mono XBSlink.exe“

Apparemment, il ne faut pas passer par wine, mais directement lancer l'exe dans mono.

A +
m
0
l
29 Novembre 2010 18:20:42

Ah merci de votre participation =D
Alors j'ai mis dans mon terminal: sudo mono XBSlink.exe
Mais voici la réponse:
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/1.0/mscorlib.dll' directory.

Donc voila, je pense qu'il y a un autre probleme, si quelqu'un pourrai essayer de voir si ca fait pareil chez eux merci ;)  =)
m
0
l
a b 5 Linux
29 Novembre 2010 19:11:39

matthieubarcadu85 a dit :
Ah merci de votre participation =D
Alors j'ai mis dans mon terminal: sudo mono XBSlink.exe
Mais voici la réponse:
The assembly mscorlib.dll was not found or could not be loaded.
It should have been installed in the `/usr/lib/mono/1.0/mscorlib.dll' directory.

Donc voila, je pense qu'il y a un autre probleme, si quelqu'un pourrai essayer de voir si ca fait pareil chez eux merci ;)  =)

Il semble qu'un fichier mscorlib.dll soit absent de ton répertoire /usr/lib/mono/1.0/
Je viens de vérifier chez moi, il est bien présent à l'emplacement attendu.

Qu'as-tu dans le répertoire /usr/lib/mono/ ?

A +
m
0
l
29 Novembre 2010 20:03:05

J'ai suivi ton lien et en lisant un peu la FAQ:
XBSlink for Linux requires mono and libpcap to be installed on your system. a dit :
XBSlink for Linux requires mono and libpcap to be installed on your system.

Tes paquets sont-ils bien à jour?
m
0
l
29 Novembre 2010 20:12:58

Beh enfaite j'utilise la version 8.je_sais_plus combien car j'avais installé la 10.10 il y a environs 2 mois et j'avais des probleme de bootloader et du coup impossible de lancer ni windows ni linux, donc je n'ose pas mettre à jour ma distribution de peur de devoir reinstaller encore une nouvelle fois tout mon linux ( supprimer partitions avec Gparted live CD puis reinstaller ubuntu 8.04 il me semble)

Donc oui cest possible que je n'ai pas tous les paquets =s
m
0
l
29 Novembre 2010 20:17:13

Geis007 a dit :
Il semble qu'un fichier mscorlib.dll soit absent de ton répertoire /usr/lib/mono/1.0/
Je viens de vérifier chez moi, il est bien présent à l'emplacement attendu.

Qu'as-tu dans le répertoire /usr/lib/mono/ ?

A +



Et dans mon dossier ./mono jai : 2.0, gac, gtk-sharp-2.0 et mono-addins

Je n'ai pas de ./mono/1.0 =s
m
0
l
a b 5 Linux
29 Novembre 2010 20:45:59

matthieubarcadu85 a dit :
Et dans mon dossier ./mono jai : 2.0, gac, gtk-sharp-2.0 et mono-addins

Je n'ai pas de ./mono/1.0 =s

Ne cherche pas plus loin, voilà la cause du problème.
Vérifie dans Synaptic quel est le paquetage qui installe /usr/lib/mono/1.0/mscorlib.dll, et installe-le.

Pour info, chez moi, sur Mandriva 2010.0, c'est le paquetage mono, en version 2.4.2.3



Bonne chance,
A+
m
0
l
29 Novembre 2010 21:13:57

D'accord, mais j'ai beau essayer d'installer des chose il me trouve toujours des problemes de dépendances!
Par exemple pour mettre à jour le paquet "mono-runtime" il me dit:
mono-runtime:
Dépend : libc6 (>=2.11) mais 2.10.1-0ubuntu18 doit être installé
Dépend : libglib2.0-0 (>=2.23.5) mais 2.22.3-0ubuntu1 doit être installé
Dépend : mono-gac (=2.6.7-3ubuntu1~dhx1) mais 2.4.2.3+dfsg-2 doit être installé

Donc je suis bloqué quoi que je veux faire =/

Mais j'ai trouvé enfin je pense pour installer le fichier usr/lib/mono/1.0/mscorlib.dll il pourrai se trouver dans ce paquet "libmono-corlib1.0-cil" mais:
Dépend : mono-runtime (>=2.6.7) mais 2.4.2.3+dfsg-2 doit être installé
Recommande : libmono-i18n-west1.0-cil mais ne doit pas être installé

Donc c'est une histoire sans fin ='( ca tourne en rond, chacun dépend de l'autre ou je ne sais quoi =/
m
0
l
29 Novembre 2010 21:17:28

Je confirme que c'est bien ce paquet, dans les description j'ai trouvé "This package contains the Core Library (mscorlib.dll) of Mono for CLI 1.0"
m
0
l
a b 5 Linux
29 Novembre 2010 21:36:39

matthieubarcadu85 a dit :
Je confirme que c'est bien ce paquet, dans les description j'ai trouvé "This package contains the Core Library (mscorlib.dll) of Mono for CLI 1.0"

Normalement Synaptic est sensé gérer les dépendances et faire les mises à jour nécessaires des autres paquets, surtout s'il propose d'installer ce paquet. Ça ne marche pas ?

As-tu installé tous les dépôts recommandés (Universe, Multiverse, ...).

Les libc6 (>=2.11), libglib2.0-0 (>=2.23.5), mono-gac (=2.6.7-3ubuntu1~dhx1) n'existent pas pour ta distro ?

Si vraiment, il n'y a rien à faire peut-être est-ce parce que la version 2008 d'Ubuntu est un peu ancienne.
La 10.10, je ne connais pas, mais la 10.04 (Long Time Support) n'est pas mal du tout. Peut-être faut-il franchir le pas...

A +
m
0
l
29 Novembre 2010 21:53:39

En passant par synaptic j'ai toujours des erreurs..
Tu entends quoi par installer les dépots recommandés? Dans mes sources de logiciels les deux sont cochés...

Ensuite la libc6 est installé en version 2.10.1-0ubuntu18, la libglib2.0-0 est installé en version 2.22.4-1, mono-gac est installé en 2.4.2.3 (mais impossible de faire la mis a jour)

Et je mettait trompé j'utilise la version 9.10 d'ubuntu =) et oui si vraiment ma version devien trop juste je réessayerai la mis à jour avec le nouveau MBR qui ne se lance pas ^^
m
0
l
29 Novembre 2010 21:55:28

En tout cas merci de te casser la tête pour moi, pour un probleme à la base pas si important mais qui en vaut la peine =p j'apprends plein de choses au fur et à mesure de tes explications =D
m
0
l
a b 5 Linux
29 Novembre 2010 22:04:31

matthieubarcadu85 a dit :
En passant par synaptic j'ai toujours des erreurs..
Tu entends quoi par installer les dépots recommandés? Dans mes sources de logiciels les deux sont cochés...

Jettes un oeil sur http://doc.ubuntu-fr.org/depots et installe le maximum, même les "testing", peut-être que s'y trouvent les versions plus récentes de ces paquets.
matthieubarcadu85 a dit :

Ensuite la libc6 est installé en version 2.10.1-0ubuntu18, la libglib2.0-0 est installé en version 2.22.4-1, mono-gac est installé en 2.4.2.3 (mais impossible de faire la mis a jour)

S'ils ne sont pas dans les dépôts standards, peut-être dans des supplémentaires (Medibuntu) ou des "testing". Insère-les dans ta liste de dépots (comme indiqué sur le lien donné ci-dessus) et mets à jour la liste. avec un peu de chance...
matthieubarcadu85 a dit :

Et je mettait trompé j'utilise la version 9.10 d'ubuntu =) et oui si vraiment ma version devien trop juste je réessayerai la mis à jour avec le nouveau MBR qui ne se lance pas ^^
.
Ètonnant tout de même que tu aies mono2 et pas mono1...
matthieubarcadu85 a dit :
En tout cas merci de te casser la tête pour moi, pour un probleme à la base pas si important mais qui en vaut la peine =p j'apprends plein de choses au fur et à mesure de tes explications =D

C'est en se creusant la tête, en fouillant les docs et les forums qu'on apprend ! Comment crois-tu que je fasse ;) 
Ce n'est pas toujours facile, mais ça vaut le coup... Et plus on résoud de problèmes, plus les suivants sont faciles.

A +

m
0
l
29 Novembre 2010 22:37:40

Donc oui j'ai rajouté quelques sources, je met à jours là mais bon je sais pas trop ce que ca va donner =s je pense que je devrait passer aux versions supérieurs oui...

Heu peut etre bien x) je te crois =p

Oui en effet, mais bon j'espere que tu est d'accord avec moi que linux est pas aussi simple que windows mais bien mieu (quand on sait s'en servir^^)

Bon beh je crois que si avec tout cela ca ne marche pas, j'abandonnerais le sujet initial qui était XBSlink :D 
Si tu a d'autres idées qui te viennes dans la nuit n'hésite pas x) et encore merci pour tout, je te tien au courant de tout ca!
Bonne nuit et MERCI pour tout...
m
0
l
a b 5 Linux
30 Novembre 2010 15:17:41

matthieubarcadu85 a dit :
j'espere que tu est d'accord avec moi que linux est pas aussi simple que windows

Pas d'accord ! ;) 

Tout dépend de ce qu'on attend de sa machine.

Pour un usage de base (90% des utilisateurs), tous les gens que j'ai convertis à Linux (Ubuntu) sont enchantés. Rapidité, stabilité, ergonomie, esthétique et effets 3D, logithèque par défaut ou disponible en 3 clics...
Pas de prise de tête avec les anti-virus, anti-malware, pare-feu... pas de parano sur internet (toujours faire gaffe aux sites sur lesquels on va, aux liens sur lesquels on clique, aux mails qu'on reçoit).
Pour un usage un peu avancé (en vidéo, par exemple), si on est prêt à se documenter et à utiliser des commandes un peu élaborées, il n'y a pas photo.

Si on veut la même machine que tout le monde, si on veut l'utiliser en imitation (je te montre comment il faut faire...) plutôt qu'en compréhension (je t'explique comment ça marche...), si on veut garder ses logiciels habituels, dans ce cas, oui, Windows est plus facile.

Mais il faut dans ce cas se résoudre à accepter ce qui pour moi est inacceptable, et qui est pourtant le quotidien de 80% des utilisateurs :
Windows tout neuf, c'est très bien. Et encore, dès qu'on veut des logiciels performants, il faut mettre la main au portefeuille (sauf utiliser des logiciels libres issus de ... Linux).
Un an après, on commence à pester contre ralentissements et autres désagréments.
Deux ans après, on commence à penser à changer de machine (parce que 80% des utilisateurs ne veulent/peuvent pas se lancer dans la galère qu'est un formatage/réinstallation).
Trois ans après, on change de machine, et de version de Windows, admettant enfin ce que les Linuxiens disent depuis toujours : la version précédente de Windows, quelle galère !!! (parce que les Windowsiens, manquant d'éléments de comparaison, ont besoin du recul que leur donne la nouvelle version).


Mais bon !!! J'ai l'impression que xbslink est plus facile à utiliser sous Windows... selon la version.

matthieubarcadu85 a dit :

mais bien mieu (quand on sait s'en servir^^)

D'accord !
N'empêche que pour un usage avancé de Windows, il faut aussi savoir s'en servir, et avec mes connaissances de noob, je préfère mille fois Linux, plus documenté, plus compréhensible que la BDR, les comportements erratiques dus aux malwares, etc.

A +

PS : Tout ça reste entre nous parce qu'on est à 90% d'accord. Je ne veux surtout pas lancer un troll, ces avis étant tout à fait subjectifs et n'appelant aucun commentaire contradictoire.
m
0
l
30 Novembre 2010 16:29:23

Salut =) Bon je suis tout à fait d'accord avec toi en ce qui est plus haut, aucuns soucis pour ca =D

Le problème étant que maintenant ayant mis à jours hier comme je t'avais dis, cela a bien mis une demi heure à telecharger les paquets (à 130 K/s) donc un bon petits nombres^^ et ubuntu les a installé!
A l'instant je démarre mon ordi, selectionne la derniere version de linux dans mon bootler loader et là image de ubuntu avec ecran qui reste figée! =/
Donc j'ai booté sur "une version" precedente mais roh je desespere avec tout ca moi ^^

J'ai essayé "sudo mono XBSlink.exe" si par miracle cela marcherai mais malheureusement toujours ./mono/1.0/mscorlib_etc...." manquant donc bon =/
m
0
l
a b 5 Linux
30 Novembre 2010 17:26:12

matthieubarcadu85 a dit :
Salut =) Bon je suis tout à fait d'accord avec toi en ce qui est plus haut, aucuns soucis pour ca =D

Le problème étant que maintenant ayant mis à jours hier comme je t'avais dis, cela a bien mis une demi heure à telecharger les paquets (à 130 K/s) donc un bon petits nombres^^ et ubuntu les a installé!
A l'instant je démarre mon ordi, selectionne la derniere version de linux dans mon bootler loader et là image de ubuntu avec ecran qui reste figée! =/
Donc j'ai booté sur "une version" precedente mais roh je desespere avec tout ca moi ^^


Avant ta mise à jour (ou avant de redémarrer sur la nouvelle version), il faut que tu désinstalles le driver vidéo propriétaire (Menu "Système / Administration / Pilotes propriétaires") et que tu le réinstalles une fois redémarré avec la nouvelle version du noyau.
En effet, celui-ci a été compilé avec la version précédente du kernel, et doit être recompilé avec la nouvelle (dkms se charge de ça automatiquement lors du boot, ça prend environ une minute).
matthieubarcadu85 a dit :

J'ai essayé "sudo mono XBSlink.exe" si par miracle cela marcherai mais malheureusement toujours ./mono/1.0/mscorlib_etc...." manquant donc bon =/
.
Il doit vraiment te manquer un paquetage. Revois (patiemment !) ce que tu avais vu précédemment, en particulier les paquetages libcap et mono, et, si ce n'est pas automatique, vérifie les versions de libc6 (>=2.11), libglib2.0-0 (>=2.23.5), mono-gac (=2.6.7-3ubuntu1~dhx1).

A +
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS