Votre question

installer un logiciel sous Linux

Tags :
  • linux
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
13 Mai 2004 19:23:35

Voila je suis un noob et j'ai une question a demander au linuxien.
Comment fait ton pour installer un logiciel ?
Parce que j'arrive a installer sans aucun probleme linux et partitionner sans aucun probleme.
Le seul probleme est que quand je telecharger un logiciel quel qu'il soit, j'arrive pas a l'installer.

Merci d'avance :-(

Autres pages sur : installer logiciel linux

13 Mai 2004 19:34:06

Les logiciels ne sont pas les mêmes sous Linux !
Sur telecharger.com il faut sélectionner Windows en haut ;-)
13 Mai 2004 19:40:45

We je sait j'ai telecharger AMSN pour linux mais ils marchent pas. Idem pour les autres: Imule, etc... jarivea dezzipper mais apres j'arrive pas :-(
Contenus similaires
Anonyme
13 Mai 2004 19:43:24

Certains programmes ont besoin d'etre compiler sur sa machine, peut etre sont ils concernés.
Tape sur google "comment installer XXXX sur linux" par exemple..
13 Mai 2004 19:46:55

oki merci je vais voir sa desuite :-D
Merci encore de m'aider
13 Mai 2004 20:24:43

selon les cas, tu as un setup (pas forcement sous ce nom) qu'il suffi de lancer
--> machin
parfois de cette maniere :
--> ./machin
parfois il faut compiler :
--> make ./machin
parfois c'est un rpm :
--> rpm -ivh machin


en general c'est un de ceux la

mais dans tous les cas, tu as un readme ou un howto a lire dans lequel tout est ecrit
13 Mai 2004 20:50:43

il faut voir aussi tu as pris quoi, si c'est un .rpm, un .tar, ... l'installation est differente...
13 Mai 2004 21:13:30

Lol pour amsn tu n'as rien a faire. Si tu prends les sources, tu les detar et tu lances amsn. Tout est deja fait.
13 Mai 2004 21:36:07

alors pour amsn j'ai trouver un truc qui ma tout installer :-D mais pour xmule je pige rien c'est un fichier tar.bz2.
Ma version de linux est mandrake 10.0 8-)
13 Mai 2004 21:38:39

$ tar jxf lefichier.tar.bz2
$ cd lerepertoirecréé
# ./configure && make && make install
13 Mai 2004 21:41:12

petite explication des extensiosn linux :
.rpm : il s'agit de packages redhat et mandrake ; tu double cliques et ça installe (pour faire simple)
.tar.gz : tar : ça regroupe tous tes fichiers en un seul;
pour extraire : tar -xf nomdu fichier
.gz : gunzip : compression, comme winzip ; ta commande tar devient : tar -xzf fichier
tar -xvzf fichier est mieux ; tu peux voir ce qui se passe

bz, c'est un autre type de compression mais je sais plus comment ça se décompresse.

Une fois que tu as décompressé le fichier.tar.gz, tu as un dossier "fichier".
tu vas dedans
tu fais
./configue
make
make install

et c'est fait (en général)
13 Mai 2004 21:48:35

Pour installer certains logiciels il me semble que c'est possible à l'aide d'une manipulation qui rajoute des logiciels dans 'Installer des logiciels". On m'avait dis la manipulation mais je me souviens plus... et en fait après tu recherches xMule et t'as juste à faire installer !
13 Mai 2004 21:52:11

ba j'ai fait sa et ya plein de truc qui se sont afficher, etc... comment on fait pour le demarrer ? :oops: 
merci de votre aide
13 Mai 2004 22:00:06

si c'est correctement installé, tu ouvres une console (ou tu peux faire alt+F2, je crois sous mdk) et tu tapes le nom du logiciel installé.
si tu connais pas précisément le nom, dans la console, tu tapes les premières lettres puis tab et ça affichera toutes les possibilités.

Il y a aussi moyen de créer des raccourcis...
13 Mai 2004 22:35:37

ba zut j'ai du foirer quelque chose parce que sa marche pas :-( voici une place pour moi :boulay: :crying: :crying:
13 Mai 2004 22:37:09

quand tu as vu pleins de trucs affichés, tu n'avais pas un message du type "erreur"
14 Mai 2004 13:09:22

ba a priori non. mais si sa marche pas c'est moi qui ai du foirer quelsuechose, vu que je mis connais pas trop au niveau de linux.
14 Mai 2004 13:16:04

quel logiciel essaies tu d'installer ?
22 Mai 2004 16:29:44

dsl szdavid j'aais pas vu que tu me demander quelque chose, alors j'essaye desesperement d'installer Amule mais sa ne passe pas :kaola: 
Il me dit ce qui suit:
Certains paquetages demandés ne peuvent pas être installés :
aMule-1.2.6-2mdk.i586 (car libwx_base-2.4.so.0 est non satisfait)
Êtes-vous d'accord ?
Alors que faire
:crying: :crying:
1 Juin 2004 12:55:44

etant tout nouveau sur linux, je galere un peu(meme beucoup):oops:  enfin bref j'aimerai mettre ma connexion sur linux avec kppp mais le prob est que je n'arrive pas a l'installer. kelkun pourrait m'aider. je vs remercie.:roll:
11 Juillet 2004 02:13:27

Salut tout le monde, moi ossi je suis un débutant en sequi consèrne nunux :-)
Et moi ossi j'ai également des problème pour linstalation et lutilisation de certains programmes
Par exemple, je n'arrive pas a lancé VisualBoyAdvance ou aMULE

je croi avoir tout bien instalé ( ct des fichiers .tar.gz ) mais quand je clique sur le logo pour lancé le programme, il ne se passe rien, ou ossinon si j'éssaye de louvrir otrement, sa me di quele programme ne sera pas lancer par sécuritée...

( pour dézipé l'émulateur GBa, j'ai éssayé de 2 fasson :
1 ouvrir le fichier compréssé et déplacé les fichiers compréssé a linterieur vers un dossier non comprésser a l'extérieur.

2 Utiliser la commande tar zxvf LeNomDuFichier.tar.gz

"les fichiers se sont décomprésser dans le mème répèrtoire du fichier compréssé ( le fichier VisualBoyAdvance.tar.gz) et je les é mis dans un dossier que j'ai créé par la suite pour ne pas léssé tout les fichiers en bordel dans le dossier ".

Et donc au final, sa donne exactement la mème chose! )

je ne comprend pas, petètre que je ne suis pas en administrateur ? vu que je ne peu pas enregistré des document téléchargésur avec linux vers ma session windows ???
mais si c sa ? comment faire pour devenir l'administrateur ?
Et si sa ne vien pas de la.. Comment faire!?!?!?

HELP HELP HELP HELP HELP HELP HELP HELP HELP
11 Juillet 2004 02:20:03

Pour information, les extensions éxécutables Linux se terminent par "tar.gz" ;-)
11 Juillet 2004 10:04:44

Je rajoute mon grain de sel, en espérant que ça aidera quelqu'un.
Le problème (mais qui n'en est pas vraiment un) est que sous linux, on peut installer les softs de plusieurs façons : de façon très simple, à partir de binaires (.rpm, .deb) ou de façon plus complexe, à partir des sources (tar.gz, tar.bz2).

Pour des débutants, mon conseil est d'éssayer de trouver le binaire qui correspond au logiciel et à la distribution que vous utilisez.

Sous Mandrake, il y a un outil intégré, je crois que c'est dans système>gestion des paquetages>installer des logiciels.
Ou sinon alors vous allez sur http://www.rpmfind.net

Sous une distrib basé sur debian, vous allez sur debian.org et vous cherchez dans debian package.

Et si là, vous trouvez pas, occupez-vous d'installer à partir des sources. la méthode la plus courante est celle indiqué par Lissyx plus haut. Mais une archive de source bien faite contient normalement un fichier texte qui explique comment installer le soft.
Anonyme
20 Juillet 2004 15:12:37

Pour les tar.gz : tu décompresse, tu compile, tu vois si ça marche ..
(pour trouver le nom de ton "executable" sous Red Hat:
1) updatedb
2) slocate [lenom ou une partiedunom de ton programme})

Les rpms: rpm -ivh pour installer
rpm -Uvh pour upgrader
rpm -e pour desinstaller
rpm -qa | grep programme pour voir si installé

Je te conseille pour les packages à installer deux méthodes testées sous Red Hat:
1) apt-get (super simple d'utilisation) http://www.aplawrence.com/Linux/aptget.html

2)yum qui fonctionne idem
http://linux.duke.edu/projects/yum/download.ptml

ceux-ci sont pratiques pour la mise à jour de ton système et pour les recherches ponctuelles de packages
24 Septembre 2005 22:28:06

Je viens aussi rajouter moi petit grain de sel :-P
Je suis sous Mandrake 10.1 official
j'ai téléchargé un rpm de amule (derniere version)
mais quand je le lance, linux me dit que je vais installer le packatage,mais juste après il me dit que ceci ne pourra etre installer car: amule-2.0.3-2.1.101ise.i586 (car libwxgtk2.6 est non satisfait)
Donc je suis perdu :-?

Merci de votre future aide 8-)
25 Septembre 2005 01:50:36

Salut,

Bizarre que la MDK10.1 n'ai pas le rpm libwxgtk
Chez moi MDK9.2 j'ai bien libwxgtk2.4.2-1mdk.rpm ?

Tu as téléchargé surement une version trop récente pour ta MDK !

Mais http://fr2.rpmfind.net est ton amis !
Tape le nom d'un prog, si il existe en rpm et dans leur base alors....

A+
25 Septembre 2005 09:12:35

T'as qu'à pas installer amule !

Essaie :
urpmi amule
urpmi xmule
25 Septembre 2005 09:54:18

"Mais http://fr2.rpmfind.net est ton amis !"
Oui,d'accord mais j'ai 141 fichier trouvé pour Amule et donc je sais pas lequel prendre

Pour les urpmi : (taper dans un ternimal)
[root@ip-78-47 root]# urpmi xmule
pas de paquetage nommé xmule
[root@ip-78-47 root]# urpmi amule
pas de paquetage nommé amule

donc je suis pas très avancé :-?
je me souviens avoir installer amule d'un des cd de mandrake (version 2.00.0 du genre) mais je l'ai déinstaller

merci d'avance pour l'eclaircissement
:-)
25 Septembre 2005 11:15:06

Bonjour, moi aussi j'ai un petit problème ^^,

j'ai beau télécharger n'importe quel logiciel (firefox, edonkey, amule ...), il m'est impossible de lancer mes nouveaux programmes :-( .
J'ai téléchargé des .tar.gz et je les aient décompresser, ensuite quand je vais dans le dossier que ça a créé et que je lance le seul fichier qui veut bien afficher quelque chose à l'écran (dsl je débute avec linux ^^, pour firefox je lance le fichier "firefox-installer", pour edonkey "runDonkey.sh") et ça me lance une fenêtre qui me demande ce que je veux faire avec le fichier, soit le "lancer dans un terminal", "afficher", "annuler" ou "lancer".
Mais le problème est que si je fais "lancer dans un terminal" il y a une petite fenetre noir qui s'affiche 1/2 seconde puis plus rien :-(, et si je fais "lancer" il ne se passe rien :-(. ça me fait ça pour tous les programmes :-(. Si quelqu'un peut m'aider, merci énormément d'avance :-).

P.S. : J'ai Mandriva v10.2
25 Septembre 2005 13:45:46

Merci pour le lien :-), ça a résolu une partie de mes problèmes mais pour installer edonkey pour linux je n'y arrive vraiment pas :-( (je prend la version pour linux sur le site officiel) :-(
25 Septembre 2005 13:46:06

Merci pour le lien :-), ça a résolu une partie de mes problèmes mais pour installer edonkey pour linux je n'y arrive vraiment pas :-( (je prend la version pour linux sur le site officiel) :-(

dsl pour le doublon ...
25 Septembre 2005 17:53:17

Tu l'installes comment ??
moi je lancais le rpm et un gmessage me disait:
libwxgtk2.6 est non satisfait
alors j'ai décidé de réinstaller libwxgtk2.6 et un gmessage me dit:
wxGTK2.6 est non satisfait

Et donc je décide de reinstaller wxGTK2.6-2.6.1-0.1.101ise.i586.rpm
mais un gmessage me dit:
wxGTK2.6-2.6.1-0.1.101ise.i586.rpm Signature incorrecte ((SHA1) DSA sha1 md5 (GPG) (MISSING KEY) GPG#ba0401fa NOT OK)
Je fais ok et donc il s'intalle puis je passe a:
libwxgtk2.6-2.6.1-0.1.101ise.i586.rpm
gmessage:libwxgtk2.6-2.6.1-0.1.101ise.i586.rpm Signature incorrecte ((SHA1) DSA sha1 md5 (GPG) (MISSING KEY) GPG#ba0401fa NOT OK)
Donc je cherche les problème et j'installe et donc je passe a amule :
gmessage (original):
Les paquetages suivants ont des signatures non valides:
/home/dark/Desktop/Téléchargements/amule-2.0.3-2.1.101ise.i586.rpm: Signature incorrecte ((SHA1) DSA sha1 md5 (GPG) (MISSING KEY) GPG#ba0401fa NOT OK)
Et installe henri....euh linux ;-)

je viens d'essayer cela marche mais attend le feu vert d'une perso qui n'a pas linux depuis 3 jours :-o
Ca marche mais ce n'est pas exactement ce que je recherché car le protocole ed2k n'est pas reconnu
25 Septembre 2005 22:33:21

En fait ce que je ne comprend pas c'est que si je vais sur le site de Thunderbird par exemple et que je télécharge le logiciel, il n'est pas en .rpm (d'après ce que j'ai compris c'est parce que chaque distribution de linux est différente). Mais je ne comprend pas quoi faire de ce fichier ... il faudrait que je le compile pour pouvoir l'installer ? (dsl avec toutes mes questions mais j'ai Linux depuis hier seulement ^^). Merci.
26 Septembre 2005 17:40:20

Si tu pouvais donné plus de détails sur le fichier en question.
26 Septembre 2005 18:14:40

Ben en fait, peut importe le fichier que je télécharge (sur clubic par exemple), je n'arrive pas à installer (je télécharge bien les logiciels pour linux ^^). Je n'utilise que l'interface graphique de Linux, donc je me contente de double cliquer sur le fichier qui porte le nom "install" quelque part dans son nom :-P, mais cela ne fait rien :-(, dois-je passer en mode ligne de commande pour installer les fichiers ? si oui quelle commande dois-je taper ? Merci
26 Septembre 2005 20:57:27

J'ai enfin résolu mes problèmes :-), merci bcp @tous :) 
29 Septembre 2005 14:58:48

salut anonyme!!! je vois ke tu de débrouille pas mal sous linux! moi ce le contraire je débute je viens d('installer mandrake 10.1 community!! et je n arrive pas a installé des logiciels ke j ai télécharger !! il son en tar.gz ja i essayer les commandes ke tu a dit mais rien ne marche!!! cé peut etre moi ki fait n importe koi aussi!!! ps faut il estre en root pour ke sa fonctionne !! peutu me dire comment faire pour se mettre en root! je sia k a l ouverture deseession il faut taper root et son mot de passse mais je peu pas le faire!!! merci d('avance....
22 Novembre 2005 15:56:15

Bonjour a tous! voila moi je suis aussi débutant sous linux, mais bon je tente de me débrouiller comme je peux... J'ai installer Mandriva 2006 sur mon PC (et j'en suis fier!) pas moyen non plus d'installer aMule... mais bon je connais la procédure faut en fait d'abord istaller 2 RPM (je sais plus les nom c un truc du genre GTK et GTK devel) ensuite faut compiler... mais chez moi le ./configure ou meme ./configure -h ou -- help ca marche pas!!! je finirais par trouver!!! jer voulais juste poser une question : existe-il un site ou un document téléchargable qui me donne toute les commande possible avec le bash (les commande de K konsole quoi!!!)??? merci de me réponre... si j'ai des news pour installe aMule (ou autre) je vous communique ca...

Xa!!! et vive Linux... (même si c plus compliquer que windaube c'est vachement mieux)

5 Août 2006 17:40:28

Je passait par ici et j'ai un super tutorial qui pourra vous montrer comment mettre en place urpmi (sous mandriva ) avec des sources valable, accompagné du manuel officiel d'urpmi en français

en espérant que cela fasse la joie de tous!


Tutorial Urpmi en image

Si vous avez des question ou des améliorations a me proposé je reste a votre ecoute!!
8 Novembre 2006 18:24:10

Bonjour,j'ai Mandriva linux 2006,et je télécharger un fichier n'inporte lequel,ça marche,y'a le fichier sur mon ordi ! je clique dessus mais à chak fois ya :
file:///home/famille/dekstop/[le nom du fichier]-0.96.rc1.tar.gz,ça et apres ya toute une liste de amsn !! :whistle:  c'est en archiveur mais je c pas ou cliqué ,kar yen as au moin 1000 avec amsn-0.96.rc1/ sa commnce toujour par ca..puis-je avoir de l'aide svp?Si vous ne comprennez pas fait moi signe!
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS