Votre question

problème avec un formulaire

Tags :
  • Script
  • Programmation
Dernière réponse : dans Programmation
26 Février 2007 22:26:36

bonjour, j'ai un problème avec le formulaire de mon site il fonctionne bien, mais le problème c'est que je reçois les réponse du formulaire avec des chiffres et des % entre chaque réponse. si quequ'un peut me dire ce qui ne va pas avec mon script ca serrait simpa. Je met mon script en dessous :

<form action="mailto:mon.mail@fournisseur.fr?subject=Fomulaire de contact simple" name="envoi" method=POST enctype="text/plain">
<table border="0"><tr><td>
<p><span class="Style13">Nom : </span>
<input name="nom"size=50 maxlength=50>
<br>
<span class="Style13">Prenom : </span>
<input name="PRENOM"size=50 maxlength=50>
</p>
<p align="center"><span class="Style13">Commentaire</span> <span class="Style13">( n'oubliez pas le mot clé et votre E mail ) </span><br>
<textarea name="message" cols="60" rows="10"></textarea>
</p></td></tr></table><br>
<span class="Style13">Est-ce votre 1ère visite sur ce site</span>
<input type="radio" name="visite" value="oui">
<span class="Style7"><span class="Style12"><strong>Oui - </strong></span> </span>
<input type="radio" name="visite" value="2-3eme">
<span class="Style13">Non 2 à 3éme - </span><span class="Style12"> </span>
<input type="radio" name="visite" value="4+">
<span class="Style13">Non 4 à +</span><br>
<br>
<span class="Style13">Votre avis sur le site</span>
<input type="radio" name="avis" value="tres bien">
<span class="Style7"><span class="Style12"><strong>Très Bien -</strong></span>  </span>
<input type="radio" name="avis" value="bien">
<span class="Style7"><strong><span class="Style12">Bien</span> -</strong>  </span>
<input type="radio" name="avis" value="moyen">
<span class="Style13">Moyen -</span> <span class="Style8"> </span>
<input type="radio" name="avis" value="Pas bien">
<span class="Style13">Pas bien</span><br>
<input type="submit" value="Envoyer" name="Envoyer">
<input type="reset" name="Submit" value="Effacer">
</form>

Autres pages sur : probleme formulaire

a c 145 L Programmation
26 Février 2007 22:43:31

C'est tout simplement parce que l'encodage du formulaire est modifié.
Essaye en supprimant le enctype="text/plain".

Mais le mieux est de retraiter ton formulaire avec une page php qui enverra le mail.
26 Février 2007 22:59:12

Merci, je vais essayer ce que tu me dit
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS