Votre question

plantage Beryl sous KDE

Tags :
  • Midi
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
23 Juillet 2007 23:20:35

Bon... me revoici pour demander de l'aide (et troller un peu sur kde... :D  )

Cette aprés-midi j'ai décidé d'installer Kubuntu histoire de m'amuser un peu à me prendre la tête avec cet ignoble kde.
Et ca n'a pas raté, il a du se passé en tout et pour tout 3 minutes ou KDE ne m'a pas donné envie de pleurer, c'est quand je suis allé faire pipi...

Enfin bref, a un moment j'ai installé Beryl, tout content.
J'ai démarré Beryl, tout content encore.
J'ai mis Beryl dans les "autostarts" comme ils appellent ca chez kde
J'ai redemarré Kubuntu, et puis la, plus content du tout! Impossible de changer le gestionnaire de fenêtres, ca retombe systematiquement sur Kwin (super laid, au passage)
Et puis j'ai viré beryl des autostarts, mais depuis, toujours impossible de relancer Beryl!!

Lorsque je lance en console, voici le log d'erreur;

Citation :
m3ta@tuxmachine:~$ beryl-manager
m3ta@tuxmachine:~$ X Error: BadDevice, invalid or uninitialized input device 169
Major opcode: 147
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
Major opcode: 147
Minor opcode: 3
Resource id: 0x0
Failed to open device


Est-ce que quelqu'un aurait la solution miracle à ce problème?
A savoir que Beryl fonctionnait bien au depart, et que beryl --test only me dit "passed" partout (un peu comme le nain... hum!)

Merci de votre aide :) 

Autres pages sur : plantage beryl kde

24 Juillet 2007 01:28:20

Si tu pouvais poster xorg ?
24 Juillet 2007 01:30:42

Oui bien sur, y'a qu'a demander :) 

Citation :

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Philips 170S"
Option "DPMS"
EndSection

Section "Device"
Identifier "Carte vidéo générique"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Carte vidéo générique"
Monitor "Philips 170S"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "TripleBuffer" "true"
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection
Contenus similaires
24 Juillet 2007 01:39:53

Alors il te suffit de commenter les sections (3) du début à la fin en rapport avec wacom.

De façon a ce que ton xorg ressemble à ça;

Citation :
Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

#Section "InputDevice"
# Identifier "stylus"
# Driver "wacom"
# Option "Device" "/dev/input/wacom"
# Option "Type" "stylus"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

#Section "InputDevice"
# Identifier "eraser"
# Driver "wacom"
# Option "Device" "/dev/input/wacom"
# Option "Type" "eraser"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

#Section "InputDevice"
# Identifier "cursor"
# Driver "wacom"
# Option "Device" "/dev/input/wacom"
# Option "Type" "cursor"
# Option "ForceDevice" "ISDV4" # Tablet PC ONLY
#EndSection

Section "Monitor"
Identifier "Philips 170S"
Option "DPMS"
EndSection

Section "Device"
Identifier "Carte vidéo générique"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Carte vidéo générique"
Monitor "Philips 170S"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
Option "TripleBuffer" "true"
SubSection "Display"
Depth 1
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
EndSection


et ça devrait aller ?

PS; N'oublies pas le backup au cas ou...
24 Juillet 2007 01:42:23

salut, pour les messages d'erreur, je pense que c'est juste des warnings du au devices /dev/input/wacom de ton xorg.conf, il suffit de commenter les stylus, eraser et cursor dans la section "ServerLayout" ainsi que leur définition.

par contre pour beryl, tu ne peux plus changer depuis l'icone de beryl-manager? elle apparait au moins?
24 Juillet 2007 01:45:24

Je suis revenu sous Ubuntu un petit temps, je vais sur Kubuntu et je fais ca!

Oui coca25 Beryl-manager se lance bien, j'ai l'icone dans la barre des taches, mais quoi que je fasse je retombe sur kwin comme gestionnaire de fenetre... :-/
24 Juillet 2007 01:51:53

tu n'aurais pas choisi un effet (celui de l'eau ou de la pluie) avant de redemarrer?

dans le doute, tu peux effacer (ou deplacer) ton repertoire de settings de beryl:
.beryl-managerrc et .beryl
24 Juillet 2007 01:54:48

As tu bien mis dans /etc/environement :
KDEWM=/usr/bin/beryl

Dans mon Autostart, j'ai fait un script :
sleep 13;
beryl-manager;

Le sleep laissant correctement KDE démarrer !
24 Juillet 2007 01:54:51

non, pas de pluie... apparement votre methode marche mais j'ai toujours un probleme;

Lorsque je lance beryl-manger, l'icone se place dans la barre des taches, mais lorsque je choisi Beryl comme gestionnaire de fenetre, voici ce que ca me met:

Citation :
m3ta@tuxmachine:~$ beryl-manager
m3ta@tuxmachine:~$ **************************************************************
* Beryl system compatiblity check *
**************************************************************

Detected xserver : NVIDIA

Checking Display :0.0 ...

Checking for XComposite extension : passed (v0.3)
Checking for XDamage extension : passed
Checking for RandR extension : passed
Checking for XSync extension : passed

Checking Screen 0 ...

Checking for GLX_SGIX_fbconfig : passed
Checking for GLX_EXT_texture_from_pixmap : passed
Checking for non power of two texture support : passed
Checking maximum texture size : passed (4096x4096)

beryl: Another window manager is already running on screen: 0
beryl: No manageable screens found on display :0.0
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS