Se connecter / S'enregistrer
Votre question

[Résolu] Hardy Heron : Pb d'affichage ouverture de session

Tags :
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
9 Octobre 2008 22:45:46

Bonjour,

J'ai sur un disque dur une install d'Ubuntu régulièrement mise à jour. Pilote graphique propriétaire (Nvidia), affichage en 1280X1024, compiz-fusion des plus flashants, même si ce n'est pas ce que j'utilise au quotidien, j'ai déjà bluffé plus d'un windowsiens avec ;) 

Seul, un petit problème, apparu suite à une des dernières mises à jour, gâche un peu le spectacle :

La fenêtre de connexion (utilisateur, mot de passe) semble bien être en 1280X1024, mais ne s'en affiche que le quart supérieur gauche (soit un écran d'environ 640X512).

Je tape mon nom d'utilisateur et mon mdp quasiment en aveugle, la session s'ouvre, et tout rentre dans l'ordre.

Pas vital, mais gênant quand même !

Je n'ai pas trouvé où régler ce problème (pas trop envie de tatonner dans le xorg.conf vu que ça fonctionne bien dans la session, et que maladroit comme je suis... ;) ).

Des idées ?
Merci d'avance

Autres pages sur : resolu hardy heron affichage ouverture session

9 Octobre 2008 23:41:25

Bonsoir Geis007
Geis007 a dit :
(pas trop envie de tatonner dans le xorg.conf

Pourtant il va falloir y passer si tu veux régler ton problème.
Utilise nvidia X server setting pour t'aider à paramétrer la partie graphique de xorg.conf.
Attention n'utilise pas la sauvegarde automatique prend juste les renseignements dont tu as besoin et fait un copier/coller.
9 Octobre 2008 23:56:26

Slut vikin

Merci pour ta tentative,
vikin a dit :
Bonsoir Geis007

Pourtant il va falloir y passer si tu veux régler ton problème.
Utilise nvidia X server setting pour t'aider à paramétrer la partie graphique de xorg.conf.


Mais justement, la sortie graphique fonctionne très bien, une fois la session ouverte. Ce n'est que pour l'écran de connexion qu'apparemment, les réglages graphiques ne sont que partiellement pris en compte (affichage correct en 1280X1024 mais envoyé sur un écran n'affichant que 640X512)

Des fois que, voici mon xorg.conf

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "Emulate3Buttons" "true"
EndSection

Section "Device"
Identifier "Configured Video Device"
Boardname "NVIDIA GeForce4 (generic)"
Busid "PCI:1:0:0"
Driver "nvidia"
Screen 0
Vendorname "NVIDIA"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Plug 'n' Play"
Modelname "Plug 'n' Play"
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
modeline "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
Gamma 1.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1400 1050
Modes "800x600@85" "800x600@60" "800x600@75" "832x624@75" "800x600@72" "1024x768@85" "800x600@56" "1024x768@75" "640x480@85" "1024x768@70" "640x480@75" "1024x768@60" "640x480@72" "1024x768@43" "640x480@60" "1152x864@75" "1280x960@60" "1280x1024@60" "1400x1050@60"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen 0 "Default Screen" 0 0
EndSection
Section "Module"
Load "glx"
Load "v4l"
EndSection
Section "device" #
Identifier "device1"
Boardname "NVIDIA GeForce4 (generic)"
Busid "PCI:1:0:0"
Driver "nv"
Screen 1
Vendorname "NVIDIA"
EndSection
Section "screen" #
Identifier "screen1"
Device "device1"
Defaultdepth 24
Monitor "monitor1"
EndSection
Section "monitor" #
Identifier "monitor1"
Gamma 1.0
EndSection
Section "ServerFlags"
EndSection
Section "Extensions"
EndSection
Contenus similaires
10 Octobre 2008 00:15:42

Une solution simple qui devrait fonctionner , utilise startupmanager pour paramétrer la résolution.


Ps: C'est le bordel dans ta config xorg ;) 
10 Octobre 2008 00:35:04

vikin a dit :
Une solution simple qui devrait fonctionner , utilise startupmanager pour paramétrer la résolution.

J'ai déjà essayé ça, réglé sur la bonne résolution, rien à faire !

Dans la session tout va bien, si je me déconnecte, l'écran de connexion revient avec cet affichage incorrect.
C'est donc bien un réglage spécifique à cet écran qui est mauvais, mais où ???
vikin a dit :

Ps: C'est le bordel dans ta config xorg ;) 

tu vois pourquoi j'hésite à y toucher ;) 
c'est du 100% paramétrage automatique Ubuntu + Nvidia.
Je crois que l'install de base remonte à la 7.04 (voire avant). c'est peut-être les nombreuses mises à jour qui ont mis le b****l !

Merci pour pour ta tentative d'aide, je ne vais pas me prendre la tête (ce n'est pas vital) et je retourne sous Mandriva (ça me détendra avant de dormir).

Peut-être une prochaine mise à jour rectifiera ça...

A +
10 Octobre 2008 13:18:46

Tu fais un simple copier/coller de cette partie et en cas de problème lorsde la modification , tu démarres en recovery mode en tu la recolles
  1. Section "InputDevice"
  2. Identifier "Generic Keyboard"
  3. Driver "kbd"
  4. Option "XkbRules" "xorg"
  5. Option "XkbModel" "pc105"
  6. Option "XkbLayout" "fr"
  7. Option "XkbVariant" "oss"
  8. EndSection
  9.  
  10. Section "InputDevice"
  11. Identifier "Configured Mouse"
  12. Driver "mouse"
  13. Option "Emulate3Buttons" "true"
  14. EndSection
  15.  
  16. Section "Device"
  17. Identifier "Configured Video Device"
  18. Boardname "NVIDIA GeForce4 (generic)"
  19. Busid "PCI:1:0:0"
  20. Driver "nvidia"
  21. Screen 0
  22. Vendorname "NVIDIA"
  23. Option "NoLogo" "True"
  24. EndSection
  25.  
  26. Section "Monitor"
  27. Identifier "Configured Monitor"
  28. Vendorname "Plug 'n' Play"
  29. Modelname "Plug 'n' Play"
  30. modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  31. modeline "640x480@72" 31.5 640 664 704 832 480 489 491 520 -vsync -hsync
  32. modeline "640x480@75" 31.5 640 656 720 840 480 481 484 500 -vsync -hsync
  33. modeline "640x480@85" 36.0 640 696 752 832 480 481 484 509 -vsync -hsync
  34. modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
  35. modeline "800x600@72" 50.0 800 856 976 1040 600 637 643 666 +hsync +vsync
  36. modeline "800x600@75" 49.5 800 816 896 1056 600 601 604 625 +hsync +vsync
  37. modeline "800x600@85" 56.3 800 832 896 1048 600 601 604 631 +hsync +vsync
  38. modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
  39. modeline "832x624@75" 57.284 832 864 928 1152 624 625 628 667 -vsync -hsync
  40. modeline "1024x768@85" 94.5 1024 1072 1168 1376 768 769 772 808 +hsync +vsync
  41. modeline "1024x768@75" 78.8 1024 1040 1136 1312 768 769 772 800 +hsync +vsync
  42. modeline "1024x768@70" 75.0 1024 1048 1184 1328 768 771 777 806 -vsync -hsync
  43. modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
  44. modeline "1024x768@43" 44.9 1024 1032 1208 1264 768 768 776 817 +hsync interlace +vsync
  45. modeline "1152x864@75" 108.0 1152 1216 1344 1600 864 865 868 900 +hsync +vsync
  46. modeline "1280x960@60" 102.1 1280 1360 1496 1712 960 961 964 994 -hsync +vsync
  47. modeline "1280x1024@60" 108.0 1280 1328 1440 1688 1024 1025 1028 1066 +hsync +vsync
  48. modeline "1400x1050@60" 122.61 1400 1488 1640 1880 1050 1051 1054 1087 -hsync +vsync
  49. Gamma 1.0
  50. EndSection
  51.  
  52. Section "Screen"
  53. Identifier "Default Screen"
  54. Device "Configured Video Device"
  55. Monitor "Configured Monitor"
  56. Defaultdepth 24
  57. SubSection "Display"
  58. Depth 24
  59. Virtual 1400 1050
  60. Modes "800x600@85" "800x600@60" "800x600@75" "832x624@75" "800x600@72" "1024x768@85" "800x600@56" "1024x768@75" "640x480@85" "1024x768@70" "640x480@75" "1024x768@60" "640x480@72" "1024x768@43" "640x480@60" "1152x864@75" "1280x960@60" "1280x1024@60" "1400x1050@60"
  61. EndSubSection
  62. EndSection
  63.  
  64. Section "ServerLayout"
  65. Identifier "Default Layout"
  66. screen 0 "Default Screen" 0 0
  67. EndSection
  68. Section "Module"
  69. Load "glx"
  70. Load "v4l"
  71. EndSection
  72. Section "device" #
  73. Identifier "device1"
  74. Boardname "NVIDIA GeForce4 (generic)"
  75. Busid "PCI:1:0:0"
  76. Driver "nv"
  77. Screen 1
  78. Vendorname "NVIDIA"
  79. EndSection
  80. Section "screen" #
  81. Identifier "screen1"
  82. Device "device1"
  83. Defaultdepth 24
  84. Monitor "monitor1"
  85. EndSection
  86. Section "monitor" #
  87. Identifier "monitor1"
  88. Gamma 1.0
  89. EndSection
  90. Section "ServerFlags"
  91. EndSection
  92. Section "Extensions"
  93. EndSection


Laisse cette partie intacte.
  1. Section "InputDevice"
  2. Identifier "Generic Keyboard"
  3. Driver "kbd"
  4. Option "XkbRules" "xorg"
  5. Option "XkbModel" "pc105"
  6. Option "XkbLayout" "fr"
  7. Option "XkbVariant" "oss"
  8. EndSection
  9.  
  10. Section "InputDevice"
  11. Identifier "Configured Mouse"
  12. Driver "mouse"
  13. Option "Emulate3Buttons" "true"
  14. EndSection

10 Octobre 2008 18:43:32

Salut Vikin,

Bonne nouvelle, j'ai fini de te faire bosser, le problème est résolu.
Mais...

vikin a dit :
Tu fais un simple copier/coller de cette partie et en cas de problème lorsde la modification , tu démarres en recovery mode en tu la recolles
  1. Section "InputDevice"
  2. Identifier "Generic Keyboard"
  3. Driver "kbd"
  4. Option "XkbRules" "xorg"
  5.  
  6. ......
  7.  
  8. EndSection
  9. Section "ServerFlags"
  10. EndSection
  11. Section "Extensions"
  12. EndSection

Pas sûr d'avoir bien compris (ou bien fait)
Déjà, il fallait que je colle ton script en remplacement de ce que contenait mon xorg.conf (sauvé auparavant sous le nom xorg.conf.saved)
Pas évident à copier/coller vu que le tag "code" insère une numérotation qu'il faut virer à la paluche (raison pour laquelle j'ai préféré utiliser la couleur bleue qui laisse le contenu intact).
Bref, j'ai essayé, j'ai dû merdouiller quelque chose car je me suis retrouvé en 800X600 comme résolution maximale (mais l'écran de connexion correct)


vikin a dit :

Laisse cette partie intacte.
  1. Section "InputDevice"
  2. Identifier "Generic Keyboard"
  3. Driver "kbd"
  4. Option "XkbRules" "xorg"
  5. Option "XkbModel" "pc105"
  6. Option "XkbLayout" "fr"
  7. Option "XkbVariant" "oss"
  8. EndSection
  9.  
  10. Section "InputDevice"
  11. Identifier "Configured Mouse"
  12. Driver "mouse"
  13. Option "Emulate3Buttons" "true"
  14. EndSection

C'était le début du xorg.conf, apparemment, il était dans ton script...

Mais ça n'a pas marché, j'ai donc viré ce xorg.conf modifié, et au moment de remettre mon xorg.conf.saved, j'ai constaté que j'avais un xorg.conf.1 (sauvegarde d'une modif automatique ?). Je l'ai essayé, et... bingo !Tout est bien revenu (À part Compiz qu'il m'a fallu réactiver, sans conséquence fâcheuse).
Ce nouveau (ancien !) xorg.conf est nettement plus propre que celui qui m'emm...nuyait, pour info :

# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "oss"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7600 GT]"
Driver "nvidia"
Busid "PCI:1:0:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

Section "Monitor"
Identifier "DELL D1028LR"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GT]"
Monitor "DELL D1028LR"
Defaultdepth 24
SubSection "Display"
Modes "1280x1024" "1024x768" "800x600" "720x400" "720x350" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
screen "Default Screen"
Inputdevice "Generic Keyboard"
Inputdevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
EndSection
Section "Module"
Load "glx"
EndSection


Je ne vais pas fouiller pour essayer de comprendre, mais je le garde en lieu sûr, c'est lui qui deviendra mon xorg.conf.saved de référence. Va savoir ce qui m'a mis ce souk, et risque de récidiver !

Merci beaucoup pour ton aide, même si je n'ai pas su utiliser ton script, c'est toi qui m'a incité à jetre un regard insistant sur mes fichiers de xorg.conf.

a +
10 Octobre 2008 19:57:45

Geis007 a dit :
même si je n'ai pas su utiliser ton script,

En faite c'était une partie du tien.
C'est la partie clavier , souris qu'il n'y a en général pas besoin de modifier. ( hors cas spécifique )
C'est sur que si tu l'as utilisé en l'état , elle n'a pas du te servir :D 

Geis007 a dit :
Va savoir ce qui m'a mis ce souk, et risque de récidiver

Les mises à jour du pilote graphique et bien souvent ce qui est lié à GLX.
10 Octobre 2008 22:35:58

vikin a dit :
En faite c'était une partie du tien.
C'est la partie clavier , souris qu'il n'y a en général pas besoin de modifier. ( hors cas spécifique )
C'est sur que si tu l'as utilisé en l'état , elle n'a pas du te servir :D 

Ok ! J'ai cherché au début ce que tu avais pu modifier, puis ne trouvant rien, j'en ai eu marre, et j'ai tout copié pour le coller.
J'ai quand même réussi à tout bloquer en 800X600 ;) 
Au moins, je déculpabilise de n'en avoir rien tiré : tu n'as pas passé 3 plombes à essayer de me le débugguer...
vikin a dit :

Les mises à jour du pilote graphique et bien souvent ce qui est lié à GLX.

Je garde maintenant celui qui marche sous le coude...

A +
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS