Se connecter / S'enregistrer
Votre question

Pourriez-vous me dire quelle est la formule Excel necesaire?

Tags :
  • format
  • Logiciels
Dernière réponse : dans Logiciels
21 Février 2011 23:10:51

bojour je recherche une formule excel qui me permettra de réaliser un tableau à partir d un fichier de base:

ma base se présent comme suivant (le ; est le séparateur de cellule):

code client montant facturé mouvement

1007 ; 230.57 ; D
1007 ; 150.54 ; C
1007 ; 99.45 ; D
1008 ; 88.57 ; D
1008 ; 78.45 ; C
1008 ; 12.20 ; D

je souhaiterai faire un petit tableau qui me permettrait en tapant seulement mon code client (ex:1007)
que tout mes montants correspondant au code client 1007 apparaissent .............

Deuxièmement, j aimerai me servir de la colonne mouvement dont "D "correspond à débit affecterait la donnée concernée dans une première colonne et lorsque que l on a "C" (crédit) la valeur viendra s affecté dans la colonne à droite de la première ............(principe de la facture / avoir)

Cependant je ne trouve pas encore sur excel les fonction ou formule adéquate

En espérant avoir été le plus clair possible, quelqu un pourrait il m aider

Cordialement

Autres pages sur : pourriez dire formule excel necesaire

21 Février 2011 23:36:50

Pour la première partie, il faudra utiliser un tableau croisé.
Pour la deuxième, imaginons que tu veuille, par exemple, afficher dans une première colonne en vert le crédit, et dans une deuxième en rouge le débit :

Première colonne =SI(A3="C";"+"&A2;"")
Format de cellule en vert

Deuxième colonne = SI(A3="D";"-"&A2;"")
Format de cellule en rouge

Explications :
=SI(Formule à vérifier;Valeur si Vrai;Valeur si faux)
En gros, pour la première colonne, si en A3 il y a un C, la cellule affichera +230.57 en vert, sinon, la cellule restera vide. Ce qui est entre les guillemets est du texte.

Pour le tableau croisé, je ne m'en sers pas alors je te laisse le soin de regarder ou d'attendre que quelqu'un d'autre réponde.
m
0
l
22 Février 2011 21:50:17

MERCI beaucoup tu as répondu parfaitement à la deuxieme partie du sujet reste plus q u'à voir pour la premiere

ce que tu pense c'est qu i faut faire un tableau croisée dynamique

peut etre via une macro afin d actualisé la base client ?????

merci pour ton aide et les futures aides à venir

cordialement

m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS