Se connecter / S'enregistrer
Votre question

MASQUER ####### SOUS EXCEL

Tags :
  • Microsoft Excel
  • Logiciels
Dernière réponse : dans Logiciels
8 Mars 2010 12:34:36

Bonjour à tous,

Je suis à la recherche d'un moyen de masquer ####### sous excel dans un calcul heure (négative) quand la cellule de reference n'est pas renseignée

EXEMPLE AVEC LA FORMULE UTILISEE: =SI(B2-A2-"12:00"<>0;B2-A2-"12:00";"")

COLONNE A2(DATE DEBUT)
16/10/2010 07:00

COLONNE B2 (DATE DE FIN)
17/10/2010 19:00

COLONNE C2 (NOMBRE HEURES)
24H

Tout va bien quand les cellules sont renseignée. Mais lorsqu'il n'y à aucune valeurs dans A2 et B2 le résultat dans C2 est ######. Je voudrais que lorsque que A2 et B2 sont vides C2 soit vide également

Merci d'avance.

Autres pages sur : masquer excel

8 Mars 2010 12:42:24

Salut,

Il te faut rajouter la fonction ESTERREUR dans une fonction SI.
  1. SI(ESTERREUR(B2-A2-"12:00"<>0;B2-A2-"12:00"),"",B2-A2-"12:00"<>0;B2-A2-"12:00")
m
0
l
8 Mars 2010 14:09:28

Ca ne marche pas, il me dis que que j'ai marqué un trop grand nombre d'arguments
Que faire?????
m
0
l
Contenus similaires
8 Mars 2010 16:13:43

Je te donne un exemple :
  1. =SI(ESTERREUR(A1/B1);"";A1/B1)

Si la division de la cellule A1 par la cellule B1 donne une erreur alors n'écrit rien sinon effectue la division de la cellule A1 par la cellule B1.

Donc plutot
  1. =SI(ESTERREUR(B2-A2);"";B2-A2)


Au premier coup, je suis pas totalement rentré dans ton tableau.
m
0
l
8 Mars 2010 16:33:34

Excuses moi, mais j'ai pas tout compris. Par rapport à ma formule de début comment je dois proceder?
m
0
l
8 Mars 2010 17:14:53

Si l'heure de fin moins l'heure de départ donne une erreur alors n'écrit sinon effectue la soustraction de l'heure de fin mois l'heure de départ.
  1. =SI(ESTERREUR(B2-A2);"";B2-A2)


Je ne peux pas plus te le mâcher!
m
0
l
9 Mars 2010 15:57:44

Pour info, la solution est:
=SI(OU(A2="";B2="");"";SI(B2-A2-"12:00"<>0;B2-A2-"12:00";"" ))

Merci quand même de m'avoir consacré un petit peu de temps.
Merci encore.
m
0
l
10 Mars 2010 10:13:00

pageot a dit :
Pour info, la solution est:
...

"UNE solution est", devrait-on dire...
La fonction ESTERREUR(), très utile dans beaucoup de cas, est ici complètement inefficace, car le calcul renvoie bien une valeur correcte. Simplement, Excel ne sait pas l'afficher sous forme d'heure par défaut.
Pour cela, il faut passer par le menu "Outils \ Options" et cocher "Calendrier depuis 1904" dans l'onglet "Calcul".
ATTENTION ! Cette manipulation modifie les dates et heures déjà saisies, il vaut donc mieux préparer un classeur avec les formules et coller les données après.
Enfin, pour revenir sur "UNE solution", on peut aussi remplacer "12:00" par 0.5 ...

Bonne continuation
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS