Se connecter / S'enregistrer
Votre question

Tableau Outlook : images en pièces jointes, non !

Tags :
  • Logiciels
  • Écrans
Dernière réponse : dans Logiciels
a b 6 Logiciels
1 Octobre 2007 08:36:38

Bonjour,

Le sujet a dû vous semble bizarre mais comme il faut faire court...

Alors voilà : j'utilise la fonction tableau sous Outlook pour une newsletter d'association. Dedans bien sûr, j'insère divers éléments dont des images. Celles-ci s'affichent bien à l'écran à l'ouverture du message, pas de problème à ce niveau.

Mais ce qui m'agace et que je ne m'explique pas c'est que certaines de ces images apparaissent également en "pièces jointes" dans le message reçu. Certaines, pas toutes et pas toujours... Je n'ai pas réussi à trouver de liens entre celles qui "s'insèrent" ainsi.

Bon, ça n'a rien de dramatique bien sûr, mais j'aimerais bien comprendre et envoyer un document "propre" tant qu'à faire !

Si quelqu'un a une idée...

Merci d'avance !

Autres pages sur : tableau outlook images pieces jointes

a b 6 Logiciels
1 Octobre 2007 13:21:18

Aucune idée ?
a b 6 Logiciels
1 Octobre 2007 20:20:30

Modération: Pas de up avant 24h, merci.

(t'es une femme, donc mi-pardonnée parce que mi-cerveau)

:D 
Contenus similaires
Anonyme
a b 6 Logiciels
3 Octobre 2007 00:42:11

Hello
bon je n'ai jamais utilisé Outlook
mais je peux essayé de te donner une piste, si le message reçu est au format html, on pourrait regardé son code source et voir où sont hébergées les images
elles pourraient être en locale (pièce jointe) ou distante (sur le serveur mail?), Outlook déciderait en fonction de leur poids..
bon ce n'est que des hypothèses..
a b 6 Logiciels
4 Octobre 2007 07:44:49

Hypothèses très intéressantes Cart ! Merci :D 

Effectivement, je n'avais pas regardé le poids, il pourrait expliquer pourquoi certaines images apparaissent en pièces jointes... Je vais regarder cela.

ps n'ayant rien à voir : vous m'avez offert un nouveau centre d'intérêt sur OS, j'ai squatté l'ordi de ma p'tiote et teste les possibilités d'Ubuntu... passionnant ! Merci pour ça aussi ;) 
a b 6 Logiciels
4 Octobre 2007 10:29:42

Salut!

J'ai aussi remarqué cela: Certaine fois il y a des images qui sont affichées dans le message et en pièces jointes.
Est ce que tes messages sont au format HTML?
Sur l'explication local/distant j'ai de gros doutes.... facile de vérifier toutefois, il n'y a qu'à débrancher le cable réseau redemarrer et voir si la manière d'afficher les images des messages déjà reçus change à ce moment là! S'il les affiche elles ne pourraient pas être sur un serveur distant mais bel et bien quelque part sur le DD.

A creuser!
Anonyme
a b 6 Logiciels
4 Octobre 2007 13:33:57

il faut savoir si c'est bien en html ou pas (j'ai pas de outlook sous la main)
sinon je viens d'y penser, est ce que ça fait ça avec tous les clients de messageries (à la reception) ?

@TCM, n'hésite pas à allez voir d'autres distrib
a b 6 Logiciels
5 Octobre 2007 18:28:37

Pas tout compris Maxoupierrotin. Oui, bien sûr les messages sont en htlm (je ne crois pas qu'on puisse adresser des tableaux sous outlook sous un autre format ?).
Débrancher le câble réseau and so on, tu veux dire, redémarrer la bécane hors réseau et voir ? Mais si les images ont été stockées sur le serveur cause poids, puis diffusées en pièces jointes, il serait logique qu'elles soient "figées" en l'état non ?

Bon, j'ai une nouvelle lettre à envoyer ce week-end je vais faire quelques tests au niveau poids des images, brancher, débrancher et essayer de trouver des liens. Evidemment, je vous donnerai les résultats des essais.
On va comprendre ! :)  Merci

Edit : grr, en me connectant à 18 h et quelques, je n'avais pas trace d'un message posté à 13 h ! :ange:  pff
Oui, Carl, c'est bien en html (il y a le choix sous outlook entre html et -je ne sais plus, un truc genre mode texte, mais pour une newsletter / un tableau / quelque chose de "bien présenté", oui, c'est "forcément" du html à ma connaissance-
Je ne sais pas si ça fait cela avec tous les clients à vrai dire : je l'ai constaté sur des test que j'ai fait en m'auto-envoyant la newsletter, puis sur des transferts de la news en question (qui transite par une autre personne avant de me revenir comme à n'importe quel autre abonné...)
C'est un peu difficile à expliquer : j'envoie la newsletter (le tableau) "propre" à X en me mettant en copie pour vérifier. Tout est clean.
X envoit la lettre à un fichier dont je fais partie ; elle me parvient avec deux ou trois des cinq ou huit images en pièces jointes... :( 
Donc voilà... le poids des images me semble toujours une hypothèse intéressante
a b 6 Logiciels
5 Octobre 2007 19:24:47

ben Cart nous dit que les images pourraient être distantes, stockées sur un serveur. Je dis donc que c'est facile de le vérifier car si on n'est pas connecté alors ces images ne devrait plus apparaitre.
C'est clair que par contre une fois qu'Outlook a récupéré les images en PJ ben c'est fait on n'y peut plus grand chose!
Anonyme
a b 6 Logiciels
5 Octobre 2007 20:47:09

Hello
alors l'interêt que ce soit en html, c'est de voir, grâce au code source, où sont hebergées les images.
Ca serait bien TCM, que tu postes ici un exemple de code source d'un mail avec des images qui apparaitrait en pièces jointes (et des images qui n'y n'apparaitrais pas)
a b 6 Logiciels
6 Octobre 2007 05:05:48

Euh... même en remplaçant les textes internes à la lettre par une simple *, le premier code-source fait plus de trente pages sous word :( 
L'indication du lieu d'hébergement est censée se trouver plutôt vers le début ou vers la fin ? Je n'ai pas réussi à le repérer.
Il faudrait que je ne passe qu'un court extrait, sinon, tu imagines l'allure du post !
Anonyme
a b 6 Logiciels
6 Octobre 2007 11:05:39

Waw 30 pages !
alors normalement les images sont codées comme ça
  1. <IMG SRC="url_de_l_image">

sinon tu peux coller les 30 pages a cet endroit
http://www.archlinuxfr.org/paste/
et après tu mettras juste le lien ici
a b 6 Logiciels
6 Octobre 2007 23:08:05

Je crains de mettre ta patience à rude épreuve... Le problème n'est pas si important qu'il faille y passer trop de temps quand même.
Enfin bref, tout ça pour avouer que j'avais effacé mon fichier "allégé" de ce matin et que... bon je te laisse regarder... http://www.archlinuxfr.org//paste/839/
Euh... oui... là du coup c'est plutôt 50 que 30... :ange:  désolée

Si ça peut donner des indications : 5 images apparaissent en pièces jointes en réception pour ce numéro, elles font de 1 à 15 Ko et sont indifféremment en jpeg ou en gif

Mais bon, ne t'embête pas trop avec ça Cart !


Edit : n'empêche qu'avec ce site d'accueil bien plus lisible qu'une page word, je viens enfin de repérer les "img" - l'image001.gif qui figure à la ligne 258 n'apparaît pas en "pièce jointe"
Par contre l'image 010, ligne 1475 est en pièce jointe

Anonyme
a b 6 Logiciels
8 Octobre 2007 01:15:49

Ah mais ça peut être intéressant de chercher à comprendre
alors j'ai regardé les sources de image001.gif et image010.gif
et elles sont tous les deux de la forme :
  1. <img src="cid:imageXXX.gif@01C7FBA1.FE07F7F0">

tous comme les 10 autres
le "cid" est particulier pour les mails, après une petite recherche :
Citation :
En fait dans l'HTML d'un mail, il y a des urls comme ça pour faire un lien vers une image attachée :

<img src="cid:042f01c4b23e$e610be70$6401a8c0@stephane2" />

donc en gros mon hypothèse est fausse et on retourne à la case départ
je me demande quand même où sont stocké les images si elles sont pas en pièces jointes
a b 6 Logiciels
8 Octobre 2007 08:09:15

Et si je comprends bien l'explication sur le cid, ce qui figure après le @ est une forme "d'adresse", c'est cela ? Et, elles ont toutes les deux exactement la même adresse tout en se comportant différemment. Ouh là, ça se complique :/ 

J'ai fait un autre test hier : je ne sais pas si c'est de nature à faire avancer le schmilblick ou à brouiller encore plus les pistes...
En gros une même image ne se "comporte" pas de manière identique entre deux envois. ça ne tient pas debout ?...

En détail :
- Je me transfère une lettre reçue avec en pièces jointes les images 010, 020, 021, 022
- Sur le brouillon du transfert, je constate qu'il propose en pièces jointes les img 010 et... 019 ! :heink: 
- Je les efface, j'expédie
- Je réceptionne ma lettre "propre" sans pièce jointe
- Je refais un transfert, sur le nouveau brouillon apparaît en pièce jointe l'img 003 !
- J'efface, j'expédie, je reçois la lettre sans pièce jointe

On dirait donc que c'est au moment de l'envoi que ça se passe et pas au niveau du stockage, une sorte de "bug" d'outlook à défaut de meilleure explication, non ?

Ah oui, et aussi, le fait d'effacer ces pièces jointes n'a aucune incidence sur l'aspect de la lettre, un peu comme si ces images étaient des "doublons".

Anonyme
a b 6 Logiciels
8 Octobre 2007 15:50:33

Mmh ça a tout l'air d'être aléatoire vu tes tests et j'ai rien trouvé sur le net :/ 
mystère ...
a b 6 Logiciels
10 Octobre 2007 04:41:34

Pour couronner le tout, j'avais écrit à la personne qui transfère la lettre en lui demandant de bien effacer toutes pièces jointes qui apparaîtraient lorsqu'il fait "transfert". Il me répond qu'il n'y en a pas trace chez lui et que l'exemplaire qu'il s'auto envoie pour contrôle n'en contient pas :/ 
Sauf que le dernier numéro m'est revenu avec 3 PJ ...

Je crois qu'il n'y a plus qu'à donner sa langue au chat. Merci en tout cas pour le temps passé.
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS