Votre question

Creation d'un reseau local!

Tags :
  • Serveurs
  • Internet
Dernière réponse : dans Internet
6 Janvier 2009 09:12:50

Bonjour,

Je souhaiterais creer un reseau local avec 3 ordinateurs chez moi.
Et parmis ces 3ordis, je voudrais qu'il y en ai un qui soit un serveur web local afin que je puisse mettre toutes mes application php dessus, et qu'elles soient accesibles sur les autres ordis.

Voila ce que je possede :
* Un ordi sous vista avec ethernet
* Un ordi sous vista avec wifi
* Un ordi avec ethernet et wifi (clé usb) qui peut être sous xp ou linux (je preferais linux ^^) qui sera le serveur
* Cable RJ45 croisé
* Freebox

Est-ce que quelqu'un peut m'expliquer comment faire?

Merci d'avance

Ps : Si vous n'avez pas tout compris ou si vous avez besoin de plus de renseignements demandez moi.

Autres pages sur : creation reseau local

9 Janvier 2009 15:55:04

Salut,

Le mieux, je pense ( pas expert en la matière ) est de créer ton serveur web sous linux, une debian etch en installant apache, PHP, Mysql .. etc

Ensuite tu integre ton site php dans le répertoire par defaut d'apache qui doit etre dans /var/www

et enfin si tous les autres pc sont dans le même réseaux du serveur, logiquement tu n'auras qu'a rentré l'ip du serveur dans un navigateur pour atteindre ton site en LAN.

Comme je l'ai dis, suis pas expert ^^ , mais je verrais ça comme ça.
++
17 Janvier 2009 15:51:35

Salut, merci de m'avoir repondu.

Par contre s'est ce que j'ai fais mais ca ne marche pas.

Voici en detail ce que j'ai fais :

1) J'ai installé fedora sur un pc.
2) Ensuite j'ai installé apache, php et mysql dessus.
3) J'ai branché les 3pc sur le routeur de ma freebox.
4) Sur mon pc portable qui est en wifi, j'ai fais un ping vers le pc sous fedora (et vice-versa), ca fonctionne.
5) En local sous fedora mon site fonctionne bien.
6) Lorsque sur mon pc sous vista j'entre l'adresse ip de mon serveur ca ne fonctionne pas.

Est ce que quelqu'un pourrait m'aider?

Merci d'avance.
Contenus similaires
17 Janvier 2009 18:15:00

Dans un des fichiers de apache2, il doit y avoir une directive :
Order allow,deny
allow from X

C'est ce X qu'il faut mettre à "all" !
Order allow,deny
allow from all
17 Janvier 2009 18:22:47

Merci de ta reponse, mais j'ai deja allow from all.

Il n'y aurait pas un autre truc a configurer defois?

17 Janvier 2009 19:37:58

Voici le diagnostique de vista :

L'ip du serveur n'est pas configuré pour etablir une connexion au port <<Service Web (HTTP)>> avec cet ordinateur
17 Janvier 2009 23:59:17

Peut être le paramètre <VirtualHost 127.0.0.1:80>
Alors le mettre sur : <VirtualHost *:80>

Cherche toutes les entrés qui sont sur 127.0.0.1.
Les fichiers apache2 sont suffisamment commentés pour comprendre la fonction des paramètres.
18 Janvier 2009 20:05:44

Salut, merci de tes reponses!

C'est bon ca fonctionne, aujourd'hui en allumant mes ordis tous fonctionné bien!! Maintenant reste plus qu'a trouver comment acceder au dossier html lorsque je suis sous vista ^^.
19 Janvier 2009 12:00:11

Tu parle d'accèder au site en http, ou administrer à distance le serveur ?
19 Janvier 2009 17:04:17

Je veux administrer à distance le serveur maintenant.
21 Janvier 2009 14:43:36

Salut,

Tu veux faire quoi exactement ? administrer ta base de donnée à distance ?
avoir un shell sur le serveur Web ? soit plus précis stp ?

++
22 Janvier 2009 11:32:07

Salut, alors je voudrais administrer mes pages web a distance, donc pouvoir les modifier, en ajouter et en supprimer, et aussi ma base de donnée mysql.

J'ai mis en place le serveur ftp vsftpd sous fedora, et j'y accede sur mon vista via filezilla, par contre je n'arrive pas a creer de dossier ou de fichier je n'ai pas les droits necessaire, bien que j'ai fais un chmod 777 dessus!

Alors est-ce qu'il y a un autre service pour faire ca mais sans utiliser de logiciel comme filezilla, ce que je voudrais c'est juste un partage du dossier HTML avec vista (j'ai essayé samba mais ca ne fonctionne pas :sweat:  ).


Voila j'espere avoir ete clair. Si t'as a des questions n'hesite pas ^^.

a++
13 Mars 2009 19:30:00

lolotux a dit :
Peut être le paramètre <VirtualHost 127.0.0.1:80>
Alors le mettre sur : <VirtualHost *:80>

Cherche toutes les entrés qui sont sur 127.0.0.1.
Les fichiers apache2 sont suffisamment commentés pour comprendre la fonction des paramètres.



Bonjour,

J'ai le même problème que Riss à la seule différence que moi je ne suis pas du tout expert.
Voilà la situation :
Je développe en local un site que j'hébergerai lorsque tout fonctionnera correctement et j'utilise wampserver.
Jusqu'à présent il n'y avait aucun problème j'accédais à localhost.
Depuis une semaine IMPOSSIBLE de me connecter à localhost (ni sous FF ni sous IE).
Le diagnostic windows est : "localhost" n'est pas configuré pour établir une connexion au port "service web (HTTP)" avec cet ordinateur.
Pour moi c'est de l'hébreux.
Je veux bien aller modifier des paramètres dans APACHE mais je ne sais pas où il faut aller, quel élément ouvrir et comment l'ouvrir (avec notepad ? )
Merci de votre aide.
Cordialement.
ElTarfObama
13 Mars 2009 21:27:14

eltarfobama a dit :

Depuis une semaine IMPOSSIBLE de me connecter à localhost (ni sous FF ni sous IE).
Le diagnostic windows est : "localhost" n'est pas configuré pour établir une connexion au port "service web (HTTP)" avec cet ordinateur.

Qu'a t'il eu comme changement entre temps ?
14 Mars 2009 19:08:00

A priori rien de particulier, aucun nouveau logiciel, pas de téléchargement particulier. La seule piste que je peux envisager c'est celle du virus qui a pu transiter par les fichiers (surtout des vidéos et des pps) reçus, j'ai pourtant installé NORTON 360.
Les autres symptômes que j'ai observés concernent une certaine lenteur inhabituelle quand je vais sur internet.
Je m'initie au développement de sites web et je suis en train d'en programmer un (presque terminé) ; pour ce faire j'ai installé WAMPSERVER depuis bien longtemps et ça marchait. Depuis que ce problème est apparu il m'est impossible de me connecter à localhost.
Merci de prendre 5 minutes de votre temps et de me donner des pistes, sans être tout à fait un béotien je ne suis quand même pas un expert.
Cordialement.
EltarfObama
14 Mars 2009 20:10:14

Dans les journaux de Apache, qu'est ce qu'il y a ?
15 Mars 2009 19:53:43

Bonsoir,

Je ne sais pas si c'est ce que vous vouliez que je vous communique. Désolé c'est un peu long mais pour moi c'est incompréhensible.

[Fri Mar 13 20:45:54 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-1 configured -- resuming normal operations
[Fri Mar 13 20:45:54 2009] [notice] Server built: Dec 10 2008 00:10:06
[Fri Mar 13 20:45:54 2009] [notice] Parent: Created child process 16708
[Fri Mar 13 20:45:54 2009] [notice] Child 16708: Child process is running
[Fri Mar 13 20:45:54 2009] [notice] Child 16708: Acquired the start mutex.
[Fri Mar 13 20:45:54 2009] [notice] Child 16708: Starting 64 worker threads.
[Fri Mar 13 20:45:54 2009] [notice] Child 16708: Starting thread to listen on port 80.
[Fri Mar 13 23:08:19 2009] [error] [client 192.168.1.10] client denied by server configuration: C:/wamp/www/
[Fri Mar 13 23:08:19 2009] [error] [client 192.168.1.10] client denied by server configuration: C:/wamp/www/favicon.ico
[Fri Mar 13 23:08:22 2009] [error] [client 192.168.1.10] client denied by server configuration: C:/wamp/www/favicon.ico
[Sat Mar 14 19:09:18 2009] [warn] pid file C:/wamp/bin/apache/Apache2.2.11/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Mar 14 19:09:19 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-1 configured -- resuming normal operations
[Sat Mar 14 19:09:19 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat Mar 14 19:09:19 2009] [notice] Parent: Created child process 7912
[Sat Mar 14 19:09:19 2009] [notice] Child 7912: Child process is running
[Sat Mar 14 19:09:19 2009] [notice] Child 7912: Acquired the start mutex.
[Sat Mar 14 19:09:19 2009] [notice] Child 7912: Starting 64 worker threads.
[Sat Mar 14 19:09:19 2009] [notice] Child 7912: Starting thread to listen on port 80.
[Sat Mar 14 19:09:41 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sat Mar 14 19:09:41 2009] [notice] Child 7912: Exit event signaled. Child process is ending.
[Sat Mar 14 19:09:42 2009] [notice] Child 7912: Released the start mutex
[Sat Mar 14 19:09:43 2009] [notice] Child 7912: All worker threads have exited.
[Sat Mar 14 19:09:43 2009] [notice] Child 7912: Child process is exiting
[Sat Mar 14 19:09:43 2009] [notice] Parent: Child process exited successfully.
[Sat Mar 14 19:09:46 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-1 configured -- resuming normal operations
[Sat Mar 14 19:09:46 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat Mar 14 19:09:46 2009] [notice] Parent: Created child process 5588
[Sat Mar 14 19:09:46 2009] [notice] Child 5588: Child process is running
[Sat Mar 14 19:09:46 2009] [notice] Child 5588: Acquired the start mutex.
[Sat Mar 14 19:09:46 2009] [notice] Child 5588: Starting 64 worker threads.
[Sat Mar 14 19:09:46 2009] [notice] Child 5588: Starting thread to listen on port 80.
[Sat Mar 14 19:09:47 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sat Mar 14 19:09:47 2009] [notice] Child 5588: Exit event signaled. Child process is ending.
[Sat Mar 14 19:09:48 2009] [notice] Child 5588: Released the start mutex
[Sat Mar 14 19:09:49 2009] [notice] Child 5588: All worker threads have exited.
[Sat Mar 14 19:09:49 2009] [notice] Child 5588: Child process is exiting
[Sat Mar 14 19:09:49 2009] [notice] Parent: Child process exited successfully.
[Sat Mar 14 19:09:54 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-1 configured -- resuming normal operations
[Sat Mar 14 19:09:54 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat Mar 14 19:09:54 2009] [notice] Parent: Created child process 4752
[Sat Mar 14 19:09:55 2009] [notice] Child 4752: Child process is running
[Sat Mar 14 19:09:55 2009] [notice] Child 4752: Acquired the start mutex.
[Sat Mar 14 19:09:55 2009] [notice] Child 4752: Starting 64 worker threads.
[Sat Mar 14 19:09:55 2009] [notice] Child 4752: Starting thread to listen on port 80.
[Sun Mar 15 19:49:04 2009] [warn] pid file C:/wamp/bin/apache/Apache2.2.11/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Mar 15 19:49:05 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-1 configured -- resuming normal operations
[Sun Mar 15 19:49:05 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sun Mar 15 19:49:05 2009] [notice] Parent: Created child process 4004
[Sun Mar 15 19:49:06 2009] [notice] Child 4004: Child process is running
[Sun Mar 15 19:49:06 2009] [notice] Child 4004: Acquired the start mutex.
[Sun Mar 15 19:49:06 2009] [notice] Child 4004: Starting 64 worker threads.
[Sun Mar 15 19:49:06 2009] [notice] Child 4004: Starting thread to listen on port 80.

Merci de votre aide
EltarfObama
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS