Se connecter / S'enregistrer
Votre question

probleme connection ftp derriere livebox

Tags :
  • Ftp
  • Internet
Dernière réponse : dans Internet
16 Février 2008 11:02:17

bonjour,

j'ai installé un serveur ftp windows derriere une livebox sagem,
et lorsqu que je le test avec fillezilla en mode passif, filezilla renvoi ce message :
"adresseip non routable, remplacée par l'adresse du serveur",
j'ai ouvert les ports et désactivé le firewall mais rien à faire

merci de bien vouloir m'aider

Autres pages sur : probleme connection ftp derriere livebox

16 Février 2008 13:08:21

L'adresse de ton ordinateur n'est pas la même que celle de la livebox car la livebox peut connecter 10 channels.
16 Février 2008 13:23:15

non l'adresse c'est 192.168.1.10
Contenus similaires
16 Février 2008 13:45:44

Ce n'est pas la véritable IP, la preuve j'ai exactement la même la sous mon MacBookPro. C'est en quelque sorte un masque de sous réseau. La vraie IP est cachée par le routeur.
16 Février 2008 22:57:19

si tu veux te connecter sur ton ip j'ai fait un petit "redirigeur" : http://jeremy1000.free.fr/serveur
Ca va t'envoyer sur ton IP.
Pour ton probleme, il faut que tu soit en ip fixe pour monter ton ftp.
Le seul port à ouvrir est le 80.
17 Février 2008 14:32:22

oui à chaque fois , je met en ip fixe , en l'occurence france telecomnva bientot passé l'adresse en ip fixe , tu pense que c'est pour ca que mon ip est non routable, moi ca m'etonne car avec vnc je n'ai pas de probleme et pôurtant j'ai juste ouvert les ports...
17 Février 2008 15:28:07

je parlais de l'ip fixe de ton ordi, pas celle de ta livebox. lol
17 Février 2008 15:39:35

mon ordi est deja en ip fixe
17 Février 2008 17:40:13

je sais que j'ai déja eu des soucis pour monter un serveur LAMP derrière une live box, mais comme j'avais un routuer sous la main j'ai simplement viré la fonction routeur de la livebox (enfin je crois, jme rapelle plus trop en fait).
17 Février 2008 18:00:01

jerbe a dit :
Pour ton probleme, il faut que tu soit en ip fixe pour monter ton ftp.
Le seul port à ouvrir est le 80.


Faux, et re-faux.
Il est tout à fait possible d'héberger un serveur FTP avec une IP fynamique, c'est juste moins partique pour les utilisateurs (s'pour ça que DynDns existe...)
Le port a ouvrir pour un seurver FTP c'est le 21 et non pas le 80 qui correspond au HTTP...

@ Scofield07
Tu as utilisé quel logiciel pour créer ton serveur FTP ?
17 Février 2008 18:13:29

a oui c'est vrai !! me suis planté dans les ports.
Quand je disais ip fixe je parlais de celle de l'ordi.
17 Février 2008 18:23:32

C'est tout à fait possible en IP dynamique...
On configure une IP statique par souci de comodité, s'tout...
17 Février 2008 18:26:58

bin je t'assure à 200% que mon serveur web, si je met une ip dynamique il est innaccessible.
17 Février 2008 18:32:37

Logique, il faut que tu redirrige le port 80 sur l'IP dynamique.
Si tu as configuré .10 en statique, elle peut très bien devenir .12 en dynamique donc c'est normal que ton HTTP soit inaccessible ;) 
17 Février 2008 19:53:14

et noon, j'ai ouvert le 80 pour tous.
Cherche pas, de toute façon c'est pas ça qui résoudra son probleme.
18 Février 2008 09:08:56

lord kiss cool tu semble peut etre avoir une reponse pour moi, alors mon serveur ftp est celui de windows...j'ai fixé l'adresse ip de l'ordi en 192.168.1.10...
18 Février 2008 13:01:45

XD! Ip fixe ou pas ça change rien! Il suffit de faire une redirection.

Faites un détour sur No IP vous verrez j'ai testé ça marche impeccable. Il faut juste mettre à jour le programme quand on se connecte à internet!

++
18 Février 2008 13:50:47

la redirection je l'ai faite..mais on dirait que y'a quelque chose qui la bloque car ca continue de me renvoyé sur 192.168.1.1 au lieu de l'adresse publique
18 Février 2008 13:51:17

192.168.1.10 pardon
18 Février 2008 13:57:52

j'avais le meme soucis quand j'ai monté le serveur de ma copine, mais je sais malheureusement plus du tout comment j'ai fait.
As-tu regardé dans les options de la livebox si il y avait pas un truc à la con à régler ?
18 Février 2008 14:01:58

oui j'ai regardé, j'ai rien trouvé, j'ai lu quelque part que meme avec le pare feu désactivé sur la live box il fallait quand meme creer une regle dans le pare feu , je vais essayé ca..j'ai rien à perdre
18 Février 2008 14:03:53

vraiment de la daube ces box ....
18 Février 2008 14:04:59

je te tiens au courant, mais bon si t'a une idée ou si quelqu'un a une idée merci de me tenir au courant
18 Février 2008 14:06:07

ce qui est bizarre c'est que la redirection pour vnc par exemple marche très bien..
19 Février 2008 21:07:14

Alors...
Si ce n'est pas fait:
- Redirrige le port 21 en TCP vers la machine serveur.
- Ouvre ce même port dans le Firewall Windows (ou tout autre FW)
- Pour avoir une adresse fixe comme la mienne (lynxxhosting.ath.cx à titre d'exemple non publicitaire :p ), utilise DynDns.com et crée ton compte et ta redirection puis paramètre ce compte dans le menu "Avancé > Réseau > DynDns" de ta LiveBox.
- Vérifie aussi que le serveur FTP est bien lancé (tout con mais on peut passer des heures dessus ^^').
19 Février 2008 23:55:42

Dydns redirige vers une ip, donc si son accès en tapant IP ne fonctionne pas, ça ne résoudra rien.
20 Février 2008 00:31:22

J'ai jamais dit que ça résoudra son problème...
C'est juste plus pratique si il veut utiliser son serveur FTP à distance.
C'est quand même plus simple de te rappeler de toto.ath.cx que de 90.26.246.152 alors que t'es même pas sûr que ton IP soit restée la même...
20 Février 2008 10:33:14

il sera obliger d'utiliser Dyndns de toute facon pour utiliser son serveur FTP, Orange utilise des ip dynamiques. Mais pas forcement le site, normalement la livebox dispose d'une option DynDNS :) 

Il ne faut pas SURTOUT PAS désactiver le firewall de la livebox, ca ne fonctionne pas : il faut juste faire une redirection du port 21 vers l'ip de ton PC, ca se débrouille tout seul pour ouvrir le port dans le firewall une fois que tu as validé cette redirection.

Tu peut nous montrer ta redirection? (imprim ecran)
20 Février 2008 11:27:21

la redirection est la suivante


vnc Oui TCP 5900 5900 192.168.1.10 ppp0
vncudp Oui UDP 5900 5900 192.168.1.10 ppp0
ftp Oui TCP 21 21 192.168.1.10 ppp0
ftpudp Oui UDP 21 21 192.168.1.10 ppp0
ftp2 Oui TCP 20 20 192.168.1.10 ppp0
ftp3 Oui UDP 20 20 192.168.1.10 ppp0
test Oui TCP 50000 50100 192.168.1.10 ppp0


Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS