Votre question

Ou est l'erreur dans mon code svp ????

Tags :
  • Internet Explorer
  • Programmation
Dernière réponse : dans Programmation
10 Juin 2005 11:32:17

Bonjour a tous, voila j'ai un probleme, j'ai fait un site et sur la premiere page (d'acceuil donc), je rencontre un probleme car mozilla accepte de centrer l'image dans la cellule, alors que internet explorer la centre dans la page entiere, voici le code de la page :

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN" "http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Mariage Serge et Julie</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css">
div#cadre {/* conteneur global et arrière-plan du titre du cadre */
width: 275px;
padding-top: 40px;
background: url(haut.gif) top left no-repeat;
}
div#bloccadre {/* arrière-plan bas et sur l'ensemble du cadre */
background: url(bas.gif) bottom left no-repeat;
padding-bottom: 40px;
}
div#bloccadre p {
margin: 0 30px 0 20px;
}</style>
<style type="text/css">
<!--
.centre
{
width:680px;
height: 430px;
overflow:auto;

}
//-->
</style>
<STYLE>
.tabnormal{background-color:white; color:white; font-weight:bold ; align:center}
.tabover{background-color:p ink; color:white; font-weight:bold}
</STYLE>
<style type="text/css">
<!--
html,body {
background-color : white;
}



a:hover {color:blue; text-decoration:none;}

a:link,a:active,a:visited
{
text-decoration:none;
font-family:aladdin,sans-serif;
color:blue;

}
//-->

</style>
</head>

<body>

<table border="0" width=800 height=110 background="haut.jpg" align="center">
<tr><td><center><font size="+6">Mariage Serge et Julie</font></center></td></tr>
</table>
<br>
<table width=800 align="center">
<tr>
<td width=90>
<table align="center">
<tr>
<td>
<table border="1" width=90 height=100 align="center" bordercolor="black" cellpadding="0" cellspacing="0">
<tr><td><center><b>Photos</b></center></td></tr>
<tr><td>

<table width=90>
<tr><TD class="tabnormal" onmouseover="this.className='tabover'" onmouseout="this.className='tabnormal'"><center><a href="affichecategorie.php?categorie=1&start=0&page=1">Photos Fiancailles</a></center></TD></tr>
<tr><TD class="tabnormal" onmouseover="this.className='tabover'" onmouseout="this.className='tabnormal'"><center><a href="">Photos</a></center></TD></tr>
<tr><TD class="tabnormal" onmouseover="this.className='tabover'" onmouseout="this.className='tabnormal'"><center><a href="">Photos</a></center></TD></tr>
</table>
</td>
</tr>
</table>
<br>
<table border="1" width=90 height=100 align="center" bordercolor=black cellpadding="0" cellspacing="0">
<tr><td><center><b>Videos</b></center></td></tr>
<tr><td>

<table width=90>
<tr><TD class="tabnormal" onmouseover="this.className='tabover'" onmouseout="this.className='tabnormal'"><center><a href="">Video</a></center></TD></tr>
<tr><TD class="tabnormal" onmouseover="this.className='tabover'" onmouseout="this.className='tabnormal'"><center><a href="">Video</a></center></TD></tr>
<tr><TD class="tabnormal" onmouseover="this.className='tabover'" onmouseout="this.className='tabnormal'"><center><a href="">Video</a></center></TD></tr>
</table>
</td>
</tr>
</table>
<br>
<table border="1" width=90 height=45 align="center" bordercolor=black cellpadding="0" cellspacing="0">
<tr><td><center><b>Me contacter</b></center></td></tr>
<tr><td>

<table width=90>
<tr><TD class="tabnormal" onmouseover="this.className='tabover'" onmouseout="this.className='tabnormal'"><center><a href="mail.php">Mail</a></center></TD></tr>

</table>
</td>
</tr>
</table>
</td></tr>
</table>



</td>
<td>

<table border="0" cellpadding="0" cellspacing="0" width=680>
<tr height=33><td width=680><img src="h.jpg" border="0"></td></tr>
<tr><td width=649 background="c.jpg"><center><img src="http://perso.wanadoo.fr/pegase86/photos/_00050.jpg" border="0"></center></td></tr>
<tr height=59><td width=680 background="b.jpg"><center>
Ce site a été fait pour etre visionné dans une resolution de 1024x768 ou supérieure, dans le cas ou vous ne possedez pas une telle configuration l'affichage risque de ne pas s'effectuer correctement.</center></td></tr>
</table>
[/color]
</td>
</tr></table>

</body>
</html>

j'ai mis la partie qui concerne directement l'image en question en rouge ainsi que le tableau qui la contient, voyez vous d'ou peut venir l'erreur ?

Merci...

Autres pages sur : erreur code svp

10 Juin 2005 12:19:11

J'ai regardé rapidement mais je crois qu'il te mansque le <center>
10 Juin 2005 13:48:16

Oui tu n'as mis que la balise de fin </center> !
Contenus similaires
10 Juin 2005 17:31:10

désolé d'avoir été aussi long mais en fait si la balise <center> est bien la, justa avant le lien img, ca doit pas etre ca... merci quand meme, d'autres idées?
10 Juin 2005 17:43:17

salut
ben j'ai regarder avec namo web editor mais je vois pas d'erreur a part une photo ou image qui ne s'affiche pas
10 Juin 2005 17:46:19

Citation :

monaco42 a écrit :
salut
ben j'ai regarder avec namo web editor mais je vois pas d'erreur a part une photo ou image qui ne s'affiche pas


en fait je ne pense pas qu'il y a une erreur puisque le site s'affiche correctement dans mozilla et firefox, a savoir : l'image apparait au centre de la cellule, alors que dans I.E elle apparait au centre de la page et donc hors de la cellule, je cherche en fait a savoir qu'elle modification je dois apporter au code pour que cela marche dans I.E aussi ...
10 Juin 2005 17:58:16

En effet, il y a une interprétation différente selon chacun des navigateurs !
En tout cas j'ai plutôt tendance à utiliser
  1. <div align="center"><img src="http://perso.wanadoo.fr/pegase86/photos/_00050.jpg" border="0"></div>


plutôt que <center></center>, c'est mieux interprété !

En tout cas ici ça ne change rien ... :-(
10 Juin 2005 18:02:03

à mon avis A380 à raison mais j'ai pas verifié
10 Juin 2005 21:40:22

Pourquoi tu mets div#machin {... ? Normalement #machin {... ça suffit.
11 Juin 2005 13:38:18

Citation :

A380 a écrit :
En effet, il y a une interprétation différente selon chacun des navigateurs !
En tout cas j'ai plutôt tendance à utiliser
  1. <div align="center"><img src="http://perso.wanadoo.fr/pegase86/photos/_00050.jpg" border="0"></div>


plutôt que <center></center>, c'est mieux interprété !

En tout cas ici ça ne change rien ... :-(


J'ai essayé cette methode aussi ... et aussi de mettre valign=middle dans la balise <td> mais ca ne change rien, la je bloque et j'arrive vraiment pas a savoir d'ou ca peut venir....
11 Juin 2005 13:40:33

Citation :

Rennou a écrit :
Pourquoi tu mets div#machin {... ? Normalement #machin {... ça suffit.


exact mais de toute maniere le cette partie du code n'intervient pas ici... j'aurais du d'ailleurs l'enlever...
11 Juin 2005 13:50:55

j'ai trouvé il suffisait de changer la taille de la ligne ^^
et de la passer a 680 maintenant ca marche !
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS