Se connecter / S'enregistrer
Votre question

Montage d'une partition sous debian linux

Tags :
  • Matériel
Dernière réponse : dans Matériel informatique
26 Octobre 2004 14:45:20

Bonjour


J'ai une partition FAt32 sur mon disque dur que j'ai posé dans le répertoire /windows sous linux. Or, elle ne se monte pas automatiquement, et en plus je n'y aie accès que en root en écriture et en exécution. Pourtant, je crois avoir fait ce qu'il faut :

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda6 / ext3 defaults,errors=remount-ro 0 1
/dev/hda7 /windows vfat rw,user,noauto,exec 0 2
/dev/hda5 none swap sw 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0

Qui a t-il d'erroné là dedans ?

Merci pour vos réponses...

Autres pages sur : montage partition debian linux

26 Octobre 2004 15:24:53

Ptit up
26 Octobre 2004 16:01:33

Salut,
Dans ton fichier fstab :

/dev/hda7 /windows vfat rw,user,noauto,exec 0 2

Essaye plutot de mettre auto plutot que noauto
Contenus similaires
26 Octobre 2004 16:06:16

ok merci...

Et pour ce qui est des permissions aux utilisateurs ??
Ca concerne cette ligne :

/dev/hda7 /windows vfat rw,user,noauto,exec 0 2
26 Octobre 2004 16:20:29

oui mais pour la gestion des droits, je ne sais pas trop. Au pire essaye de mettre defaults, mais en tt cas oui ca concerne cette ligne pour ta partition windows.
26 Octobre 2004 16:22:10

J'ai essayé ça marche pas...Merci quand même mec
26 Octobre 2004 16:26:54

comment tu as essayé aussi ? pour tester, il faut que tu demonte ta partition et que tu la remonte avec umount et mount.
26 Octobre 2004 18:58:28

Ouai j'ai réessayé ça a pas marché...
26 Octobre 2004 20:18:45

up again dans l'espoir que il y ait des fans du pingouin
26 Octobre 2004 20:26:57

Bon, mon /etc/fstab ressemble à ça :

/dev/hda1 /mnt/c vfat iocharset=iso8859-1,umask=0 0 0
/dev/hda9 /mnt/d ntfs iocharset=iso8859-1,umask=0 0 0
/dev/hda10 /mnt/e vfat iocharset=iso8859-1,umask=0 0 0

Et donc le montage est automatique et j'ai tous les droits en utilisateur. A toi de voir si ça peut t'aider !
26 Octobre 2004 20:29:20

Merci Palmic

Mais que veut dire ça :

iocharset=iso8859-1,umask=0 0 0
26 Octobre 2004 20:33:57

En fait, je sais pas trop ce que ça veut dire :-D
J'avais une Mandrake avant et c'est ce qu'elle avait générée, comme ça marche comme je veux je garde ce fichier...
Je crois que iocharset c'est pour préciser comment sont encodés les charactères qui composent les fichiers et les répertoire, et le umask ça a un rapport avec les droits, mais j'en sais pas plus !
Si tu fait "man fstab" dans une console tu devrais avoir quelques explications, mais il y a tellement d'options dans ce fichier, je cherche pas trop à comprendre !
26 Octobre 2004 20:34:31

As tu essayé ceci ? (le lien est plus mort ^^)
26 Octobre 2004 20:48:13

Merci à tous pour cette aide précieuse je vais essayer ça
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS