Votre question

VBA pour Excel - formule inopérante ?

Tags :
  • Microsoft Excel
  • Logiciels
Dernière réponse : dans Logiciels
5 Décembre 2010 17:18:35

Bonjour à tous les fans de VBA,

Une macro dans Excel écrit une formule dans une cellule, mais cette formule ne s’exécute pas.
Je fais écrire : Active.Cell.FormulaR1C1 = " = SOMME(R7C3 :R[-1]C3) "
La formule est correcte et écrite au bon endroit mais la cellule Excel renvoie #NOM ?
Il faut aller dans la cellule et en barre de commande où est écrit le contenu de la cellule : =SOMME($C$7 :$C19), et faire Entrée.
A ce moment seulement ma formule est opérante. (Le problème est le même avec : Value à la place de FormulaR1C1)
Où est l’erreur ? Que dois-je écrire pour que ma formule s’exécute directement ?
Merci de votre aide.
Gporte

Autres pages sur : vba excel formule inoperante

7 Décembre 2010 15:04:09

J'ai répondu moi-même à ma question.
Comme un certain nombre d'internautes ont lu ma question je leur livre ma réponse.
C'était pourtant évident. Il faut écrire "=SUM..." au lieu de "=SOMME...".
VBA est écrit en langue anglaise.
Merci tout de même.
gporte
m
0
l
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS