Se connecter / S'enregistrer
Votre question

installation de la librairie GTK

Tags :
  • Config PC
  • Logiciels
Dernière réponse : dans Logiciels
22 Décembre 2005 13:06:28

Bonjour a tous !

depuis plusieurs jours j'essaye d'installer la librairie gtk ... mais ça ne marche pas ...

pourtant j'ai bien installé les bibliothèque nécessaires, mais lors de la configuration de gtk on m'écrit :

checking for BASE_DEPENDENCIES... Requested 'glib-2.0 >= 2.7.1' but version of GLib is 2.6.3
configure: error: Package requirements (glib-2.0 >= 2.7.1 atk >= 1.0.1 pango >= 1.9.0 cairo >= 0.9.2) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.

ce qui est bizare c'est que j'ai installé la version 2.8.4 de Glib ...

a paremment il faut faire une manipulation avec pkg-config mais je ne vois pas quoi ..

merci de votre aide

Autres pages sur : installation librairie gtk

22 Décembre 2005 17:59:19

personne ne peux m'aider ??????
:crying: :crying: :crying: :haaa: :haaa: :haaa: :beuarf: :beuarf: :beuarf:
23 Décembre 2005 20:46:58

ALLEZ !
SILLLLLLLLLL VOUS PLLLLLLLLLLLLLLLLLEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEEE
C SUPER IMPORTANT !

:kaola:  :grrr: :snif:
Contenus similaires
23 Décembre 2005 21:18:35

Pour commencer, t'es sous quel système d'exploitation ?
23 Décembre 2005 21:54:14

je suis sous linux ..
en fait je fais du C et je voulais utiliser cette librairie graphique ..

j'ai trouvé ce qui ne va pas .. en fait c'est la pkg_config ..
quand je vais voir dans le fichier concernant glib de ce programme, j'ai encor la version 2.6.4 de glib ... alor que j'ai installé la 2.8.4 ..

j'ai trouvé dans l'aide à l'installation de glib ces conseils :

Installation directories
========================

The location of the installed files is determined by the --prefix
and --exec-prefix options given to configure. There are also more
detailed flags to control individual directories. However, the
use of these flags is not tested.

One particular detail to note, is that the architecture-dependent
include file glibconfig.h is installed in:

$exec_prefix/lib/glib/include/

if you have a version in $prefix/include, this is out of date
and should be deleted.

.pc files for the various libraries are installed in
$exec_prefix/lib/pkgconfig to provide information when compiling
other packages that depend on GLib. If you set PKG_CONFIG_PATH
so that it points to this directory, then you can get the
correct include flags and library flags for compiling a GLib
application with:

pkg-config --cflags glib-2.0
pkg-config --libs glib-2.0


j'ai essayé de taper les deux dernière line dans shell mais rien ne change .
23 Décembre 2005 22:04:02

j'ai même essayé de supprimer le glib config et les fichier qui me donne mais j'ai pas le droit d'accès :'( 
23 Décembre 2005 22:38:31

Et c'est quelle distribution ?

Tu l'installe en RPM ou en DEB ou bien tu veux le compiler ?
Tu as beaucoup de conflits de dépendances ?
Si c'est que glib qui pose problème, il suffit d'en trouver un paquetage et c'est bon normalement.
24 Décembre 2005 11:29:55

bien la je l'installe sous shell ..
le reste je comprends pas ^^

je vais essayer de trouver glib en rpm peux être que ça marchera ... je te dirais ..

edit : je ne trouve aucun glib en rpm ..
mais je suis persuadé qu'il faut faire juste une petit manip avec pkg_config pour q'il comprenne que j'ai une nouvelle version ..
je pense que la solution est dans l'aide à l'installation de Glib ecrite plus haut.
C'est pas tellement Glib qui pose probleme, je l'ai installé, mais c'est surtout pkg qui ne le reconnait pas.
19 Mars 2006 09:45:03

:crying: :haaa: :beuarf: :crying:

Bon s'avez même pas une petite idée ? ça fait quand même plusieur moi que j'ai posté ce Topic !
--____________--

J'espère que vous aller enfin me répondre !
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS