Votre question

Wifi sur debian

Tags :
  • Debian
  • Système d'exploitation
Dernière réponse : dans Systèmes d'exploitation
12 Avril 2007 12:01:06

Bonjour,
Je tourne sur une Debian Sid.
Aprés plusieurs recherches et moultes tentatives je ne parviens pas a faire fonctionner ma carte wifi intégrée à mon amilo.
Le chipset est AR5OO5G.

J'ai essayé de le ndiswrapper sans succés car la carte n'est pas active par défaut donc le pilote est installé mais le materiel n'est pas trouvé.

Je n'ai pas non plus l'interface wlan0 en fesant un iwlist.

Ma question est donc comment activer cette carte wifi intégrée (Atheros AR500G) ?
Et comment obtenir l'interface wlan0 ?

Merci de vos réponses :) 

Autres pages sur : wifi debian

12 Avril 2007 13:42:29

Si tu as windows active le sous windows, sinon installe madwifi. Le driver de ( quasiment ) tous les chipset atheros est intégré dedans.

Bonne chance. @+
12 Avril 2007 14:11:06

Non je n'ai pas windows.
Pour le driver c'est ok j'ai ndiswrapper celui de windows. Mais je pense que je vais installer madwifi plutot qu'un driver windows ndiswrapper.

Le souci c'est l'activation de l'interface wlan0 qui n'apparait pas dans iwlist.
Contenus similaires
12 Avril 2007 14:36:38

il doit y avoir possibilité de l'activer par défaut depuis le bios
12 Avril 2007 14:40:21

Hum... je suis pas sur mais peut etre que oui. Je regarderai ce soir et je vous tiendrais au courant.

J'avais aussi testé avec une carte pcmcia, driver ndiswrapper. Debian ativé bien la carte mais aucune interface wlan0 n'apparraissait...

Le wifi n'est pas vraiment une necessité mais je n'aime pas quand ca me resiste :whistle: 
12 Avril 2007 14:44:58

t'as regardé le wiki d'ndiswrapper ? tout ce qu'il faut pour de nombreuses cartes y est expliqué, même les plus exotiques (genre ma WG111T qui utilise deux drivers, un pour charger le firmware dans le dongle, et un pour lancer le firmware...)
12 Avril 2007 14:57:13

@Zukero : Pourrais-tu me donner le resultat de la commande lsusb ?

J'ai moi aussi une clé wg111 et je n'arrive pas à la faire marcher. Donc si on avait la même ça me rassurerai que quelqu'un ai réussi à la faire fonctionner


Edit : j'ai pas fais gaffe, tu as la 111 T, donc c'est sûr nous n'avons pas la même. En tout cas merci quand même pour l'idée wiki ndiswrapper, en fouillant bien j'ai trouvé qqun qui a la mêm clé que moi et qui a réussi à la faire fonctionner.
Voila dsl pour cette intervention, je vous rend le topic !
12 Avril 2007 14:59:02

suseX, je ne me sert plus de cette clef, mais le modèle exact, c'est la wg111t, et j'ai un post sur le forum de netgear qui explique comment j'ai fait.
18 Avril 2007 21:44:50

Re ici :) 

Bon j'ai laché l'affaire pour la carte wifi intégré et rebranché ma carte pcmcia (LinkSys Wireless-B WPC11).

J'ai remarqué qu'il y avait des paquets wlan dans les dépôts :
- linux-wlan-ng (patch du kernel je pense)
- linux-wlan-ng-modules

Je les ai installés mais sans résultat. (Je ne me suis pas encore renseigné sur la nature exacte de ces paquets)

En fait j'ai un message du kernel au boot :
Citation :
pcmcia: This interface will soon be removed from the kernel; please expect breakage unless you upgrade to new tools.
pcmcia: see http://www.kernel.org/pub/linux/utils/kernel/pcmcia/pcm... for details.
cs: memory probe 0xc0200000-0xc02fffff: excluding 0xc0200000-0xc02fffff
cs: memory probe 0xa0000000-0xa0ffffff: excluding 0xa0000000-0xa0ffffff
cs: memory probe 0x60000000-0x60ffffff: excluding 0x60000000-0x60ffffff
cs: memory probe 0x50000000-0x51ffffff: excluding 0x50000000-0x51ffffff


Je crois que c'est ça le soucis. Je suis aller jeter un coup d'oeil sur le site mentionné, mis à part que ce soit de l'anglais, je crois que c'est beaucoup de blabla.
A mon avis c'est un probleme de reserve de plage de la mémoire (dite moi si je m'égare...).

Quelqu'un peut il me dire ce qu'il comprend de ce log et comment y remédier ? En attendant je continu mes recherches :) 

A+
19 Avril 2007 10:35:44

A priori le problème vient du pcmcia, pas d'histoire de mémoire et co.

Le wifi en pcmcia sous linux, ca va pas etre la fete.
Vérifie déjà que le pcmcia marche bien en utilisant un autre périphérique sur le même port. Un truc standard tout bête.
Si çà marche, va voir sur le wiki de ndiswrapper pour le modèle EXACT de ta carte. numéro 15 & 16 ici p-e
Sinon, pour ta carte externe, réessaye avec diverses versions de ndiswrapper. Cherche AR5005G ici
Tom's guide dans le monde
  • Allemagne
  • Italie
  • Irlande
  • Royaume Uni
  • Etats Unis
Suivre Tom's Guide
Inscrivez-vous à la Newsletter
  • ajouter à twitter
  • ajouter à facebook
  • ajouter un flux RSS